webloc file cannot be opened by drag and drop into open tab/window

RESOLVED FIXED in mozilla1.9beta2

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: philippe (part-time), Assigned: Stan Shebs)

Tracking

({regression})

Trunk
mozilla1.9beta2
PowerPC
Mac OS X
regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Since bug 332913 landed, dragging a .webloc file into an opened tab/window does not open the URl (access the page).
The location bar shows a file:///Users/phiw/Desktop/xxx.webloc. The same appears on window title or tab title.
On 10.4:
At first try, blank contents area
If  tried a second time, the content area shows an unstyled xml file.
10.3.9: shows the unstyled xml file immediately.

This happens only in Camino atm. 
It works fine in Minefield 20061026.

Opening by double clicking, or dragging to application icon on the Dock works correctly.

Comment 1

11 years ago
Is it camino-specific or does it happen in Minefield too? If it does, it should be reassigned to Core > Widget: Cocoa.
Well, regardless of where the bug is, it looks like no bug on weblocs got filed as a follow-up, so this can be that bug, and if it needs to move to Widget, fine.

(I actually don't see an unstyled xml file on 10.3.9, just a blank page, but AFAIK I don't have any of the newfangled plist weblocs from 10.4). 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> Well, regardless of where the bug is, it looks like no bug on weblocs got filed
> as a follow-up, so this can be that bug, and if it needs to move to Widget,
> fine.

As I stated in comment #0, I can't reproduce this in Minefield (20061026 build, PPC).
 
> (I actually don't see an unstyled xml file on 10.3.9, just a blank page, but
> AFAIK I don't have any of the newfangled plist weblocs from 10.4). 

Hmm, I get a blank page now with a .webloc created on 10.3.9. Maybe I did only try with a 10.4 .webloc before. Regardless, the url doesn't load.

Blocks: 332913
Target Milestone: --- → Camino2.0
The question is not whether this is Camino-specific; the question is whether this bug is in our code, or in Widget:Cocoa code.  Given the poking that Chris and I did tonight on bug 363577, my bet is on the latter, but I don't know how webloc drags are being handled to say that with 100% certainty....

Comment 5

10 years ago
I just noticed on today's nightly trunk build that dragging a .webloc file to Camino's main window, causes Camino to spin with 100% CPU. I took a sample and will attach it here.
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)

That is almost certainly bug 397309. 

Comment 7

10 years ago
Moving to Cocoa widget and requesting 1.9 blocking, as it's a serious regression.

Josh, this used to fall into the kURLDataMime/kURLDescriptionMime block (line 605 of the old nsDragService.cpp), presumably because of the mime mapping (nsMimeMapper.cpp), as text/x-moz-url-data. The new DnD code has no URL type handling at all, which is obviously the source of the regression.
Assignee: nobody → joshmoz
Component: Drag & Drop → Widget: Cocoa
Flags: blocking1.9?
Product: Camino → Core
QA Contact: drag.drop → cocoa
Target Milestone: Camino2.0 → ---

Updated

10 years ago
Assignee: joshmoz → stanshebs
Flags: blocking1.9? → blocking1.9+
Target Milestone: --- → mozilla1.9 M10
(Assignee)

Comment 8

10 years ago
Created attachment 285952 [details] [diff] [review]
handle url-related mime types
Attachment #285952 - Flags: review?(joshmoz)
(Assignee)

Updated

10 years ago
Attachment #285952 - Flags: review?(stuart.morgan)
(Assignee)

Comment 9

10 years ago
The patch seems too simple, but empirically it does all the right things, presumably because pasteboards are a more uniform mechanism, and so it suffices just to get the urls in as if they were text strings, relying on other code later to recognize them correctly by flavor in the transferable.

Updated

10 years ago
Attachment #285952 - Flags: review?(joshmoz)

Comment 10

10 years ago
Comment on attachment 285952 [details] [diff] [review]
handle url-related mime types

Yep, the old code just pulled out the URL as text too, so that makes sense.
r=smorgan
Attachment #285952 - Flags: review?(stuart.morgan) → review+

Updated

10 years ago
Attachment #285952 - Flags: review?(joshmoz)

Updated

10 years ago
Attachment #285952 - Flags: superreview?(roc)
Attachment #285952 - Flags: review?(joshmoz)
Attachment #285952 - Flags: review+
Attachment #285952 - Flags: superreview?(roc) → superreview+

Updated

10 years ago
Attachment #285952 - Flags: approval1.9?
Comment on attachment 285952 [details] [diff] [review]
handle url-related mime types

a=drivers for after M9 freeze
Attachment #285952 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed

Comment 12

10 years ago
landed on trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.