Allow manual modification of threading

RESOLVED DUPLICATE of bug 36024

Status

--
enhancement
RESOLVED DUPLICATE of bug 36024
12 years ago
12 years ago

People

(Reporter: andershol, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Sometimes the automatic threading algorithm fail. It might be because the person, you are corresponding with, have a mail program that create no (or erroneous) mail headers, and thereby making the mail look like the beginning of a new thread when it in fact is just continuation. It might also be the case, that a person replies to an old email instead of typing in your address, or a correspondence might drift to another topic, thereby making a mail look like it is part of a thread while it logically is a hole new thread.

Therefor it would be nice if it would be possible to alter the threading manually. For example if you, in the list of messages for a folder, dragged a message onto another message, the dragged message should become the child of the drop-target message thereby combining two threads. Breaking a thread could be accomplished by a menu item in the context menu for a message (the item should be hidden or disabled for the root of each thread), called for example "New thread", "New topic" or "Break thread". Selecting the item for a message would make the message the root of a new thread by breaking the link to the parent message (links to any child messages would be retained).

Reproducible: Always
->NEW. Would be very cool.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

12 years ago
Dupe of bug 36024?
Yep, looks like a dupe to me.

*** This bug has been marked as a duplicate of 36024 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.