All users were logged out of Bugzilla on October 13th, 2018

Microsummaries need visual identity/icon

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Details

(Whiteboard: [microsummaries-feature-removal])

Attachments

(9 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061024 BonEcho/2.0 (pigfoot)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061024 BonEcho/2.0 (pigfoot)

I've just created a small web app that offers microsummaries and failed to come up with a suitable icon for them. I'd say the popularity of RSS (and Atom) feeds substantially benefited from the launch of the feed icon, which is now recognized cross-platform. Hence, I think that there should be some discussion about microsummaries' visual identity, which could drive other browser manufacturers toward implementing them.

There doesn't seem to be a bug for this yet (although bug 348944, for one, would benefit from it), and feel free to disagree with me here, or remind me that I'm not a dev and shouldn't interfere to this extent. Just putting it out there. :-)

Reproducible: Always

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
I agree.  A visual identity for microsummaries would be valuable.  cc:ing my favorite folks whose last names' first syllables end in z and do visual identity stuff.

Comment 2

12 years ago
Myk and I talked about this briefly a couple of days ago. My initial thought was that we should look for something like (but not) the ellipses, an indicator that this is an important excerpt but maybe not the whole story. 

I'll try to put some thought into this over the next week or so. My (working) use case is the icon that shows up in the address field when a page offers a live title, similar in placement and function to the feed icon that shows up when a page offers a web feed. 
(Reporter)

Comment 3

12 years ago
Created attachment 244431 [details]
Icon mockup

I was thinking of ellipsis as well, so I combined it with the waves from the feed icon ... Looks a bit chaotic though, but it might inspire someone.
> I was thinking of ellipsis as well, so I combined it with the waves from the
> feed icon ... Looks a bit chaotic though, but it might inspire someone.

These waves remind me of parentheses (()), which are also used to summarize information and thus potentially good symbols for this functionality.  But I worry about conflating microsummaries with feeds by reusing the same symbolism for both.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> These waves remind me of parentheses (()), which are also used to summarize
> information and thus potentially good symbols for this functionality.  But I
> worry about conflating microsummaries with feeds by reusing the same symbolism
> for both.

Good point. My web app calls both of them "feeds," because I hacked in microsummaries afterwards, so that's probably why my brain tends to associate the two. Still, in a way, they *are* feeds. Plus, the waves emphasize the "Live" aspect of both Live Bookmarks and Live Titles, no?

Comment 6

12 years ago
Created attachment 244537 [details]
Icon proposal, Style 1, blue

Comment 7

12 years ago
Created attachment 244538 [details]
Icon proposal, Style 1, orange

Comment 8

12 years ago
Created attachment 244539 [details]
Icon proposal, Style 2, blue

Comment 9

12 years ago
Created attachment 244540 [details]
Icon proposal, Style 2, orange

Two styles, two colors, still thinking. :)
(Reporter)

Comment 10

12 years ago
Created attachment 244828 [details]
Abstract ellipsis icon

Keeping the dots from ellipsis, but taking an abstract direction. Also going with original feed icon design, but in blue.
Someone has noted in my blog post that the greek micro character (which looks like a "u") might be a good symbol. 

Comment 12

12 years ago
I wonder if we want it to tie to the bookmarks icons somehow since our current implementation is with bookmark labels. Maybe we could have a general purpose icon and then somehow overlay that on a bookmarks icon.
(In reply to comment #12)
> I wonder if we want it to tie to the bookmarks icons somehow since our current
> implementation is with bookmark labels. Maybe we could have a general purpose
> icon and then somehow overlay that on a bookmarks icon.

Interestingly, someone in my blog post commented that it might make sense for the favicon to indicate that a microsummary is available.  I.e. we would overlay an icon onto the favicon (or a dropdown arrow to indicate choices).
Created attachment 244847 [details]
Faaborg's proposal 1
Created attachment 244848 [details]
Faaborg's proposal 2
>I.e. we would
>overlay an icon onto the favicon

Yeah, kind of like shortcuts in windows.  One great thing about this approach is that in the bookmarks sidebar it is clear which titles are live.
Created attachment 244853 [details]
Faaborg's proposal 3 - favicon mod

Here is a mockup of the favicon modification
(Reporter)

Comment 18

12 years ago
(In reply to comment #11)
> Someone has noted in my blog post that the greek micro character (which looks
> like a "u") might be a good symbol. 

(Heh, I didn't know about your blog or the extension, I'm slow.)

A µ character does sum up the terseness quite nicely, but it is also the logo of µTorrent, a very popular BitTorrent client. It's sort of a long shot, but they may think Mozilla stole their idea, which is going to look especially bad if Firefox ever gets a BitTorrent client. Though, from an ethical point of view, no one owns the letter mu.

I do like the overlay idea, but it's going to be a real challenge to create an icon that can be identified at a size of 5x5 pixels. I don't suppose putting some sort of visual indication on the right of the menu item would be an option?
- BUGSPAM -
Wontfixing all Microsummaries bugs, since the feature has been removed from the core product and previous versions won't get further fixes for it.
If interested in supporting Microsummaries in your add-on, you're free to use our old microsummaries code and to search all previously open bugs by looking for [microsummaries-feature-removal] in the status whiteboard field.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Whiteboard: [microsummaries-feature-removal]
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.