Keyboard Shortcuts need to be the same as the current Eudora

RESOLVED FIXED

Status

Penelope
General
P1
major
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: Matt Dudziak, Assigned: Matt Dudziak)

Tracking

Details

Attachments

(3 attachments)

(Assignee)

Description

11 years ago
The Keyboard shortcuts for Penelope need to be re-mapped to be as close as possible to the current Eudora. Per Steve Dorner:

The proper solution is to allow a high-level user choice amongst:
Mac Eudora keybindings
Windows Eudora keybindings
Thunderbird keybindings
We may eventually wish to add another set or two, for:
Unified Windows/Mac Eudora keybindings
Unified Eudora/Thunderbird keybindings

Comment 1

11 years ago
The could be done by moving the key definitions from keyconfig.js to an RDF file that defines the keymapping for each case. Then the user can switch on the fly to the selected set. There is no way to dynamically load a new DTD. 

It could also be done with properties files that are loaded by javascript based on the selected setting. This is likely simpler than the RDF approach.
Status: NEW → ASSIGNED

Comment 2

11 years ago
I have added shortcut keymaps for windows, mac and for the default thunderbird (disable penelope shortcuts).

There is now a penelope preferences pane that allows the user to select the penelope keymap for that platform or the Thunderbird keymap.

Comment 3

11 years ago
Need to have the ability to customise the key mapping to account for conflicts with other software.

Comment 4

11 years ago
Created attachment 246334 [details] [diff] [review]
Initial version of the penelope extension.

Here is the first patch for the penelope extension. It is the entire extension except for the image files and the wav file for the new mail sound. Those files are in a separate zip file.

This patch and the zip file will have to be applied to the Mozilla tree to start off contributions to the penelope code. The patch puts files in the extensions/penelope directory.

Comment 5

11 years ago
Created attachment 246337 [details]
zip of icons files for the penelope extension

The icon files in this zip file must be added with the penelope patch. There is another media file which must also be added. It will be attached separately due to its size.

Comment 6

11 years ago
Created attachment 246339 [details]
New mail wav file.

This wav file belongs with the penelope.patch file and must be added at the same time as the patch.

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

11 years ago
Status: REOPENED → NEW

Comment 7

11 years ago
*** Bug 359222 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 8

11 years ago
(In reply to comment #3)
> Need to have the ability to customise the key mapping to account for conflicts
> with other software.
> 

There is a keyconfig extension that provides this functionality.

Updated

11 years ago
Depends on: 361591

Comment 9

11 years ago
One of the things that bugs me about TBird is when I'm reading mail,& I advance through say 3 messages, and then close the message window; the pointer is on the first message, not the last one I read. 

In short; not just the keymappings vary, but default behavior, vary between Eudora and TBird; obviously we need to look at both...

Comment 10

11 years ago
I see the icons attached to this bug, and they are the ones introduced with eudora 6.X. I think that Penelope Users should be able to choose between that icons set and the "Old style" icon sets, as Eudora users can easily do putting in the main program folder the file EudoraOldIcons.epi.

Comment 11

11 years ago
Scott asked for an overview of the patch.

Overview of changes:

Penelope is a Thunderbird extension that changes the layout of the messenger window and compose window, adds the Eudora newmail sound as the default sound, and remaps the key shortcuts on a per window basis using overlays.

Some Eudora functionality not present in Thunderbird has been added:

- Changing the quote level of a selected section
- Selected text URL handlers
- Remove formatting from a selection
- Mailbox and Transfer menus on main menubar

The Windows Eudora icon sets have been added. At some point the Mac icon sets will be added as well. They require a format conversion first.

Comment 12

11 years ago
Can an extension be made that users can directly download and use with Thunderbird 2.0 Beta, and/or instructions be added? I have tried to use this, but it appears to be a patch that needs to be added when Thunderbird is built. 
(Assignee)

Comment 13

11 years ago
(In reply to comment #12)
> Can an extension be made that users can directly download and use with
> Thunderbird 2.0 Beta, and/or instructions be added? I have tried to use this,
> but it appears to be a patch that needs to be added when Thunderbird is built. 
> 

Bugzilla limits the size of files we can attach to bugs, but I have posted the latest Penelope extension for Thunderbird here:

http://eudorabb.qualcomm.com/attachment.php?attachmentid=371

Install just as you would any other Thunderbird extension, via the 'add-ons' interface.

Comments are welcome, either here or on the Eudora forums (http://eudorabb.qualcomm.com/showthread.php?p=29763#post29763).

Matt

Comment 14

11 years ago
Very much appreciated! 

Comment 15

11 years ago
I have posted the latest Penelope extension for Thunderbird here:

http://eudorabb.qualcomm.com/attachment.php?attachmentid=372

Install just as you would any other Thunderbird extension, via the 'add-ons'
interface. This extension should only be used with the nightly builds of the trunk version of thunderbird.

Comments are welcome, either here or on the Eudora forums
(http://eudorabb.qualcomm.com/showthread.php?p=29763#post29763).

- Mark

Comment 16

11 years ago
Eudora's hotkeys are very powerful and should be added to rather than changed. However, Thunderbirds 1-5 and O for labels is better than the Eudora label shortcuts (right-mouse L etc.).

Comment 17

11 years ago
Perhaps if the shortcuts for labels get an added SHIFT key so that they don't interfere with the even-more-powerful 0-for-out, 1-for-in controls.

Comment 18

11 years ago
Windows > Command-M = Minimize 
but 
File > Command-M = Get New Messages

Could you delete the former please as the latter is key to Eudora's functionality. Thank you!

Comment 19

11 years ago
(In reply to comment #17)
> Perhaps if the shortcuts for labels get an added SHIFT key so that they don't
> interfere with the even-more-powerful 0-for-out, 1-for-in controls.
> 

Please create a new bug for the desired label shortcuts as this is supplemental to adding the basic Eudora key maps. I'd like to close this bug.

Thanks,

Mark
Priority: -- → P1

Comment 20

11 years ago
(In reply to comment #18)
> Windows > Command-M = Minimize 
> but 
> File > Command-M = Get New Messages
> 
> Could you delete the former please as the latter is key to Eudora's
> functionality. Thank you!
> 

Minimize is Meta (windows key) +M on windows, not CTRL+M.

However, the CTRL+M functionality seems to be broken right now so I'm looking into it.

- Mark

Comment 21

11 years ago
Oops. CTRL+M is actually minimize all windows (show desktop) on windows.

It appears that ALT+space then N will minimize a window on Windows.

Comment 22

11 years ago
command-M is minimize on OS X. Eliminating that for Eudora would be good. (I don't know why what was in Steve Jobs' head when he had them screw up the command keys.)

Comment 23

11 years ago
I apologize for the second e-mail, but (a) is there a new version of the extension? and (b) can the Wiki be updated, since it shows the last Penelope action as having occured on 11-26-06? 

Comment 24

11 years ago
CTRL + arrow up for previous message
CRTL + arrow down for next message
CTRL + M to get messages
CTRL + R to reply

I use these every two minutes.

Comment 25

11 years ago
(In reply to comment #4)
> Created an attachment (id=246334) [details]
> Initial version of the penelope extension.
> 
> Here is the first patch for the penelope extension. It is the entire extension
> except for the image files and the wav file for the new mail sound. Those files
> are in a separate zip file.
> 
> This patch and the zip file will have to be applied to the Mozilla tree to
> start off contributions to the penelope code. The patch puts files in the
> extensions/penelope directory.
> 
Got this or possibly the later version. Works on Windoze. Can't get it to work in the Linux version of Thunderbird?

Comment 26

11 years ago
Check http://wiki.mozilla.org/Eudora_Keybindings for the state of the keybindings.

Several have been fixed but some issues still remain.

The latest version of the extension is penelope-0.1a19

Comment 27

11 years ago
Using thunderbird 2 with penelope 1a19

crtl+m opens new window to send a new message. However this keyboard combination is stated to retrieve new messages, according to menu bar file,get new...,get all...
(Assignee)

Updated

11 years ago
Assignee: mcharleb → mozilla-bugs
Status: ASSIGNED → NEW

Comment 28

10 years ago
In eudora classic for windows alt-up-arrow and alt-down-arrow move between messages.  I can use the CTRL version but in the spirit of keeping the keys the same - these are missing

Comment 29

10 years ago
In eudora classic for windows, alt-space toggled read/unread status.  I used this one a lot to clean up.

Comment 30

10 years ago
(In reply to comment #29)
> In eudora classic for windows, alt-space toggled read/unread status.  I used
> this one a lot to clean up.
> 
I'm sorry - it was shift-space, not alt-space.
(Assignee)

Updated

10 years ago
Assignee: mozilla-bugs → beckley

Comment 31

10 years ago
I'm marking this bug as fixed because the basic thrust of it (provide an option to select Eudora or Thunderbird keyboard shortcuts) has been met in Penelope 0.1a21.

If you think a particular mapping is broken or not there, then please submit a new bug for the particular shortcut.  Remember to first look to see if a new specific one has already been entered, and vote for it if it has (e.g. Bug 395227 notes that Ctrl+M to check mail isn't working correctly).
Status: NEW → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Assignee: beckley → mozilla-bugs
Component: Key Config Editor → General
QA Contact: mozilla-bugs → general
(Assignee)

Updated

8 years ago
Target Milestone: 0.1 → ---
You need to log in before you can comment on or make changes to this bug.