Mailbox and Transfer menus

RESOLVED FIXED

Status

P1
major
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: mdudziak, Assigned: mcharleb)

Tracking

Details

(Reporter)

Description

12 years ago
This bug is a placeholder for a feature already in the works.

Penelope needs to have Mailbox and Transfer menus that behave like the ones in Eudora.
(Assignee)

Comment 1

12 years ago
These menus are currently working. I'll mark this fixed when the penelope extension finally gets checked in.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

12 years ago
The patch supplied in bug 359231 provides the mailbox and transfer menus.

*** This bug has been marked as a duplicate of 359231 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

12 years ago
Priority: -- → P1
Resolution: DUPLICATE → FIXED
(Assignee)

Comment 3

12 years ago
This bug has been fixed in the latest penelope extension. 

I have posted the latest Penelope extension for Thunderbird here:

http://eudorabb.qualcomm.com/attachment.php?attachmentid=372

Install just as you would any other Thunderbird extension, via the 'add-ons'
interface. This extension should only be used with the nightly builds of the
trunk version of thunderbird.
(Assignee)

Updated

12 years ago
Summary: Placeholder: Mailbox and Transfer menus → Mailbox and Transfer menus
(Assignee)

Updated

12 years ago
Version: 0.1 → Trunk

Comment 4

12 years ago
However these menus only appear to list the folder hierachy to a depth of 1.  I (like many others I suspect) have deeply nested sets of mail folders that they use these menus to access in Eudora.

Comment 5

12 years ago
Sorry, actually it looks like they do end up nested, but with a long delay.  I created a new nested mail box and the menus didn't change, however when I went back several minutes later the nested level had been added.  Is this slow addition a bug?

Comment 6

12 years ago
Another issue related to these menus: they are missing the 'New' menu item, to create new mail box or folder at that level.

I'm not sure I like the idea that folders can also be mailboxes - not the way that things are done in Eudora, but I see this is a feature of other programs, so perhaps its deeply embedded in Thunderbird.
(Assignee)

Comment 7

12 years ago
(In reply to comment #6)
> Another issue related to these menus: they are missing the 'New' menu item, to
> create new mail box or folder at that level.
> 
> I'm not sure I like the idea that folders can also be mailboxes - not the way
> that things are done in Eudora, but I see this is a feature of other programs,
> so perhaps its deeply embedded in Thunderbird.
> 


This is a supported IMAP feature. It would be odd not to support it generally.
(Assignee)

Comment 8

12 years ago
(In reply to comment #5)
> Sorry, actually it looks like they do end up nested, but with a long delay.  I
> created a new nested mail box and the menus didn't change, however when I went
> back several minutes later the nested level had been added.  Is this slow
> addition a bug?
> 

Yes, it likely is a bug. Can you please file a new big for it that describes the scenario you saw. Does restarting Penelope/Thunderbird pick up the change? I think the menu is only populated on window load. That may be the problem.
(Reporter)

Comment 9

12 years ago
(In reply to comment #8)

> Yes, it likely is a bug. Can you please file a new big for it that describes
> the scenario you saw. Does restarting Penelope/Thunderbird pick up the change?
> I think the menu is only populated on window load. That may be the problem.
> 

https://bugzilla.mozilla.org/show_bug.cgi?id=367805 addresses the problem.

Updated

11 years ago
Version: Trunk → 0.1
(Reporter)

Updated

9 years ago
Target Milestone: 0.1 → ---
You need to log in before you can comment on or make changes to this bug.