Last Comment Bug 359281 - IMAP: Option to hide deleted messages in mailboxes
: IMAP: Option to hide deleted messages in mailboxes
Status: RESOLVED DUPLICATE of bug 190974
:
Product: Penelope
Classification: Client Software
Component: Mail Window (show other bugs)
: 0.1
: All All
: P5 enhancement with 5 votes (vote)
: ---
Assigned To: Dale Wiggins
:
Mentors:
Depends on: 190974
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 14:03 PST by Matt Dudziak
Modified: 2008-03-24 15:28 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Matt Dudziak 2006-11-02 14:03:03 PST
Penelope should have an option like the current Eudora to hide deleted messages in IMAP mailboxes. This should be a per-mailbox option.
Comment 1 David 2006-11-26 17:43:11 PST
Is there any other way???
Comment 2 Matt Dudziak 2006-11-27 10:53:40 PST
(In reply to comment #1)
> Is there any other way???
> 

Is there any other way for what, exactly?

The way Thunderbird / Penelope works now is that when you delete an IMAP message, the messages is moved (copied in IMAP lingo) to the Trash mailbox, marked as 'deleted' in the source mailbox, then the source mailbox is expunged, removing the  'marked as deleted' message from the IMAP server (from that mailbox on the IMAP server). This is a lot of chatter back and forth between the client and server, and does not work if you are trying to work 'offline'.

Thunderbird / Penelope also offer you the option to 'Mark it as deleted' and 'Remove it immediately' when you delete an IMAP message. 'Remove it immediately' has a similar problem of being quite chatty with the IMAP server (tell the server to mark the message as deleted, then expunge the mailbox), and also does not work well 'offline'. 'Mark as deleted' is fine, but leaves the message sitting in the mailbox, in view, just marked as being deleted on the IMAP server

This bug is a request to modify (optionally) the 'Mark as deleted' option such that when the message is 'deleted' it is also hidden from view in the mailbox.

This feature would need to include an option like Eudora has to set when the messages that are marked for deletion would actually be deleted. Something like:


( ) When exiting Penelope 
( ) When the percentage of deleted messages exceeds xx % of messages in mailbox
( ) Never auto expunge. Only when manually told to expunge
( ) Immediately (though this is redundant)

Matt
Comment 3 David 2006-11-28 06:59:02 PST
(In reply to comment #2)


[actually delete..]
> 
> ( ) When exiting Penelope 
> ( ) When the percentage of deleted messages exceeds xx % of messages in mailbox
> ( ) Never auto expunge. Only when manually told to expunge
> ( ) Immediately (though this is redundant)

query:
Is there a need/advantage to:
  ( ) every N minutes
?
Comment 4 Matt Dudziak 2006-11-28 10:21:21 PST
(In reply to comment #3)
> (In reply to comment #2)
> 
> 
> [actually delete..]
> > 
> > ( ) When exiting Penelope 
> > ( ) When the percentage of deleted messages exceeds xx % of messages in mailbox
> > ( ) Never auto expunge. Only when manually told to expunge
> > ( ) Immediately (though this is redundant)
> 
> query:
> Is there a need/advantage to:
>   ( ) every N minutes
> ?
> 

That would be a good option as well, though Penelope would of course need to be smart enough not to waste time expunging a mailbox that does not need to be expunged....
Comment 5 Magnus Melin 2006-12-18 11:58:51 PST
I think you got it wrong about the current situation. Thunderbird doesn't expunge after each mark as deleted (though there is a hidden option for that). And it does seem to work quite ok in offline mode too.
Comment 6 Matt Dudziak 2007-01-02 12:47:08 PST
(In reply to comment #5)
> I think you got it wrong about the current situation. Thunderbird doesn't
> expunge after each mark as deleted (though there is a hidden option for that).
> And it does seem to work quite ok in offline mode too.
> 

I believe you are correct. A bit of testing with a packet capture running indicates that messages are NOT expunged immediately when deleted, which is very good. 

Unfortunately, the setting in the Thunderbird preferences for 'when I delete a message: "remove it immediately"' does not actually remove the message immediately, even if the hidden setting "mail.imap.expunge_after_delete" is set to true. That seems like a bug to me. Packet capture does not show message being deleted, and viewing mailbox with another client shows messages as being in mailbox, marked as deleted.

I still believe that Penelope needs a per-mailbox option to 'show deleted messages' (show messages marked as deleted in the mailbox), and ideally a way to 'unmark as deleted', so I'll leave this bug open.

Matt
Comment 7 Magnus Melin 2007-01-03 09:27:24 PST
The pref is only used when you have the delete setting set to "Move it to this folder:". But yeah, maybe it should be used when you choose "Remove it immediately" too...
Comment 8 Magnus Melin 2007-01-03 09:41:36 PST
Come to think of it, using it also with "Remove it immediately" woudln't make much sense... 
Comment 9 Matt Dudziak 2007-01-03 09:52:20 PST
(In reply to comment #8)
> Come to think of it, using it also with "Remove it immediately" woudln't make
> much sense... 
> 

Why wouldn't it make sense? 

To me, 'remove it immediately' implies that the message will be removed from the IMAP server immediately after I delete it in Thunderbird. The only way to do that is to expunge the mailbox after marking as deleted....
Comment 10 Magnus Melin 2007-01-03 10:07:22 PST
I was thinking since in that mode you don't see the deleted mails in the threadpane. 
Though I guess you have a point too. (For reference, the feature was added in bug 265472.)
Comment 11 Matěj Cepl 2007-06-15 05:25:02 PDT
This is DUPLICATE of bug 243075, right?
Comment 12 Matt Dudziak 2007-06-15 10:11:53 PDT
(In reply to comment #11)
> This is DUPLICATE of bug 243075, right?
> 

Yes, it probably is, but I plan to leave it open as we actually plan to 'fix' this for Penelope. We'll annotate the other bugs with the fix when we submit a patch. The Thunderbird folks may or may not decide to incorporate our change.

Thanks, Matt
Comment 13 Jason Lewis 2007-06-27 00:51:53 PDT
Just to add my 2c worth. I think that there should be a button on the tool bar to show or hide deleted messages, so one could turn them on and off as desired very easily from the tool bar.
Comment 14 jmorrison 2008-02-29 16:48:58 PST
Is there some way to work around this with a View? I was banging my head trying to figure which headers were used only to find that TB seems to store it internally, as well as munging the From_ header. I'm not sure if any of this is dependent on my IMAP server.

While we're talking about reducing chatter, how about the option to have the Trash and Junk folders simply be "views" (or saved searches) of the IMAP server.
Comment 15 Magnus Melin 2008-03-01 05:00:51 PST
So this is what's being worked on in bug 190974, no?
Comment 17 Matt Dudziak 2008-03-06 15:09:21 PST
(In reply to comment #16)
> Are these all dupes?
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=190974
> https://bugzilla.mozilla.org/show_bug.cgi?id=359281
> https://bugzilla.mozilla.org/show_bug.cgi?id=243075
> 

They seem to all be essentially the same problem. As Dale and Jeff are submitting patches for bug 190974, I'll mark this a dupe of 190974.

Matt

*** This bug has been marked as a duplicate of bug 190974 ***
Comment 18 Matt Dudziak 2008-03-24 14:29:56 PDT
Changing Severity to keep resolved bugs out of the top of my lists....

Note You need to log in before you can comment on or make changes to this bug.