[IMAP] Can't manage mail by 'deleted' flag

RESOLVED FIXED in mozilla1.9.1a1

Status

MailNews Core
Filters
--
enhancement
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: David Given, Assigned: Dale Wiggins)

Tracking

(Blocks: 2 bugs)

Trunk
mozilla1.9.1a1
Dependency tree / graph
Bug Flags:
blocking-thunderbird3.0a2 +
blocking-thunderbird3 +
wanted-thunderbird3.0a2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 8 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021208 Debian/1.2.7-5
Build Identifier: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021208 Debian/1.2.7-5

I have just migrated from Evolution, where I was used to leaving deleted
messages in my IMAP folders. Evolution would hide the deleted messages for me.

However, not only does Mozilla not allow me to view only non-deleted messages,
it won't even let me sort or filter by whether a message is deleted. 'Message
Status' consists of Read/Unread/Replied/Forwarded; 'Deleted' should be one of
these. The only way of manipulating the 'Deleted' flag is to toggle it with the
'Delete' button. It should be treated like any other mail header.


Reproducible: Always

Steps to Reproduce:
1. Place some messages in an IMAP folder.
2. Set that account to mark-as-deleted.
3. Mark some of them as deleted.
4. There is now no way of sorting the list so that all the deleted messages are
hidden, or shown first (or last).



Expected Results:  
Desired behaviour:

* An option in the View menu; 'Don't show deleted'.
* A new column in the address list to show the state of the deleted flag. Or,
add it to the Message Status column.

This makes the mark-as-deleted trash mode pretty much unusable. In this mode,
all deleting a message does is put a big X through the icon in the address list;
it still appears in the list and takes up mental and screen real estate. Check
out Evolution, which does this properly (if very slowly).

Comment 1

14 years ago
Not really a bug, but a reasonable enhancement request. Couldn't find a dupe and
I think this feature would really make sense. Marking NEW.

-> MailNews/Filters
Severity: major → enhancement
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Filters
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: Can't manage mail by 'deleted' flag → [IMAP] Can't manage mail by 'deleted' flag
Product: MailNews → Core
(Reporter)

Comment 2

12 years ago
I recently had occasion to need this again, and had another look. It turns out
that the View->Messages filters *also* can't select by deleted flag (otherwise I
could just create a filter that only showed non-deleted messages).

The information's there, so it must be pretty simple to add a new filter type
--- how well documented is all this stuff?
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 4

10 years ago
Created attachment 284637 [details] [diff] [review]
Implementation of viewing non-deleted IMAP messages

Here's an implementation of a Mailbox View that filters out deleted messages in IMAP mailboxes.
Assignee: nobody → beckley
Status: NEW → ASSIGNED
Attachment #284637 - Flags: superreview?(bienvenu)
Attachment #284637 - Flags: review?(mscott)

Comment 5

10 years ago
Dale Wiggins <dwiggins@qualcomm.com> wrote the code (I was just submitting it), so I'm reassigning the bug to him.
Assignee: beckley → dwiggins
Status: ASSIGNED → NEW

Comment 6

10 years ago
cool - my preference would be to not show this menu item at all unless it was an imap folder (i.e., hidden, not just disabled), and only show it if the current server is using the imap delete model. Would that be OK?

Comment 7

10 years ago
Created attachment 284895 [details] [diff] [review]
Changes David suggested

This patch implements the suggestions that David made.  The menu item is now hidden if it doesn't apply, and it only applies if the account is currently using the IMAP delete model.
Attachment #284637 - Attachment is obsolete: true
Attachment #284895 - Flags: superreview?(bienvenu)
Attachment #284895 - Flags: review?(mscott)
Attachment #284637 - Flags: superreview?(bienvenu)
Attachment #284637 - Flags: review?(mscott)

Comment 8

10 years ago
Comment on attachment 284895 [details] [diff] [review]
Changes David suggested

great, thx!
Attachment #284895 - Flags: superreview?(bienvenu) → superreview+

Comment 9

10 years ago
Comment on attachment 284895 [details] [diff] [review]
Changes David suggested

>Index: mail/locales/en-US/chrome/messenger/msgViewPickerOverlay.dtd
>Index: mailnews/base/resources/content/mailWindowOverlay.xul
>Index: mailnews/extensions/mailviews/resources/content/msgViewPickerOverlay.xul

This will break SeaMonkey at first sight.
You'll need to change /suite/locales/en-US/chrome/mailnews/msgViewPickerOverlay.dtd as well, I'll have a look at the rest tonight.

Comment 10

10 years ago
Comment on attachment 284895 [details] [diff] [review]
Changes David suggested

you might want to ask one of the seamonkey guys to fix this for seamonkey too - by adding the new string entity to their version of msgViewPickerOverlay.dtd	, or you can do it yourself.
Attachment #284895 - Flags: review?(mscott) → review+
Bug #196035 and bug #304809 seem to depend on this bug. Perhaps they should be added as blockers...

Comment 12

10 years ago
Any update on the seamonkey part, so we can get this in?
QA Contact: laurel → filters

Comment 13

10 years ago
Created attachment 299629 [details] [diff] [review]
supplemental patch for SM (needs attachment 284895 [details] [diff] [review]); for check-in

Basically, SM is just lacking the .dtd, but I included an unbitrotted patch against mailWindowOverlay.xul as well. You can check in this along with your patch and r=me for the overall SM changes.
(Assignee)

Comment 14

10 years ago
Created attachment 300024 [details] [diff] [review]
Original implementation plus Karsten's SeaMonkey addition.

This patch contains the original implementation, changes suggested by David and Karsten's SeaMonkey changes. Hopefully this patch wraps this one up.
Attachment #284895 - Attachment is obsolete: true
Attachment #299629 - Attachment is obsolete: true
Attachment #300024 - Flags: superreview?(bienvenu)
Attachment #300024 - Flags: review?(mnyromyr)

Comment 15

10 years ago
Comment on attachment 300024 [details] [diff] [review]
Original implementation plus Karsten's SeaMonkey addition.

>Index: mailnews/extensions/mailviews/resources/content/msgViewPickerOverlay.js
>===================================================================
>Index: mailnews/extensions/mailviews/resources/content/msgViewPickerOverlay.js
>===================================================================

It's kinda worrying to see the same file patched twice identically. ;-)
Especially since patch (of course) can't apply the second instance...
Attachment #300024 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 16

10 years ago
>It's kinda worrying to see the same file patched twice identically. ;-)
>Especially since patch (of course) can't apply the second instance...

Huh. I didn't generate the initial patch so I'm not sure what happened there. I took the original patch and added the SeaMonkey change.

Comment 17

10 years ago
That was my bad in the second patch where I had added the changes David had suggested.  Not sure how it happened, but the first version of msgViewPickerOverlay.js in the patch is the one with the extra changes, whereas the second version is the original changes.  Just ignore the second one.  :-)

Comment 18

10 years ago
Created attachment 305277 [details] [diff] [review]
Duplicate diff removed

Here's a clean version of the patch with the duplicate file diff removed.
Attachment #300024 - Attachment is obsolete: true
Attachment #305277 - Flags: superreview?(bienvenu)
Attachment #300024 - Flags: superreview?(bienvenu)

Updated

9 years ago
Blocks: 359281

Updated

9 years ago
Duplicate of this bug: 359281

Comment 20

9 years ago
Jeff/Dale, unless I did something wrong, after applying that last patch, I still see View | Not deleted in the view menu for local folders, imap folders, etc. I mean the view drop down menu on the toolbar.

Comment 21

9 years ago
You're right, David.  "Not Deleted" gets hidden from the View->Messages menu, but not from the View popup on the toolbar.  We'll have to fix that.
(Assignee)

Comment 22

9 years ago
Huh, thought I had tested that case. I'll take a look.

Comment 23

9 years ago
Created attachment 311694 [details] [diff] [review]
Fixes View toolbar popup not being updated

This patch adds the code to get the View popup on the toolbar to update before it pops up, so it fixes the problem of the "Not Deleted" item showing up on mailboxes where it doesn't belong.
Attachment #305277 - Attachment is obsolete: true
Attachment #311694 - Flags: superreview?(bienvenu)
Attachment #305277 - Flags: superreview?(bienvenu)

Updated

9 years ago
Duplicate of this bug: 243075

Comment 25

9 years ago
I've been using my own patches from 243075 for years, every time I need to update thunderbird to a new version or platform. I've really been hoping that they would be integrated so that I could run binary releases.

Since the patch here in 190974 speak to the same issue I'm happy to switch. But is this patch on the road to integration? Will it show up in a 2.x as well as 3.x?

Comment 26

9 years ago
This will be available for 3.0 only. (as soon as it get's sr+)

Comment 27

9 years ago
(In reply to comment #26)
> This will be available for 3.0 only. (as soon as it get's sr+)
> 
Any progress on sr+? Seems like its been a while.

Comment 28

9 years ago
I've running this patch for a month now, with no problem. It would be great to have it integrated.

Comment 29

9 years ago
How can I apply this patch to my Seamonkey and Thunderbird installations?

Updated

9 years ago
Flags: wanted-thunderbird3.0a2+
Flags: blocking-thunderbird3+
Whiteboard: [need sr:bienvenu]

Comment 30

9 years ago
Comment on attachment 311694 [details] [diff] [review]
Fixes View toolbar popup not being updated

I tried this out - seems to work right, including with quick searches.
Attachment #311694 - Flags: superreview?(bienvenu) → superreview+

Updated

9 years ago
Whiteboard: [need sr:bienvenu] → checkin-needed

Updated

9 years ago
Whiteboard: checkin-needed → [needs bitrot fixing, then checkin-needed]
Let's get this in a2.
Flags: blocking-thunderbird3.0a2+
(Assignee)

Comment 32

9 years ago
Created attachment 326738 [details] [diff] [review]
Fixed bit rot in last submitted patch

This should address the bit rot issue. No substantive changes.
Attachment #311694 - Attachment is obsolete: true
Attachment #326738 - Flags: superreview?(bienvenu)
Attachment #326738 - Flags: review?(mnyromyr)

Comment 33

9 years ago
Comment on attachment 326738 [details] [diff] [review]
Fixed bit rot in last submitted patch

The file mozilla/suite/locales/en-US/chrome/mailnews/msgViewPickerOverlay.dtd  is missing and your diff prefixes "../mozilla-orig/" won't lead far either...
Attachment #326738 - Flags: review?(mnyromyr) → review-
(Assignee)

Comment 34

9 years ago
Created attachment 326750 [details] [diff] [review]
Fix for bad path info and missing suite change in last patch

Fixed bad path references and missing suite file. continuing r=mnyromyr sr=bienvenu
Attachment #326738 - Attachment is obsolete: true
Attachment #326750 - Flags: superreview+
Attachment #326750 - Flags: review+
Attachment #326738 - Flags: superreview?(bienvenu)
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Whiteboard: [needs bitrot fixing, then checkin-needed]

Comment 35

9 years ago
Comment on attachment 326750 [details] [diff] [review]
Fix for bad path info and missing suite change in last patch

I need to look at this a bit closer, since diffing the diffs gives strange results... (Bugzilla doesn't like it all, kdiff3 finds substantial differences.)
Resetting r/sr for now.
Attachment #326750 - Flags: superreview?(bienvenu)
Attachment #326750 - Flags: superreview+
Attachment #326750 - Flags: review?(mnyromyr)
Attachment #326750 - Flags: review+

Updated

9 years ago
Keywords: checkin-needed

Comment 36

9 years ago
Comment on attachment 326750 [details] [diff] [review]
Fix for bad path info and missing suite change in last patch

this looks ok to me
Attachment #326750 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed

Comment 37

9 years ago
There's still the review pending (comment 35).
Keywords: checkin-needed
Target Milestone: --- → mozilla1.9.1a1

Updated

9 years ago
Whiteboard: [missing review]
Karsten, any chance you can look at this soon, to have it make it in 3.0a2?

Updated

9 years ago
Whiteboard: [missing review] → [needs review mnyromyr]

Comment 39

9 years ago
Comment on attachment 326750 [details] [diff] [review]
Fix for bad path info and missing suite change in last patch

Sorry for the delay. :(
Attachment #326750 - Flags: review?(mnyromyr) → review+

Updated

9 years ago
Keywords: checkin-needed
Whiteboard: [needs review mnyromyr] → [needs checkin]

Updated

9 years ago
Blocks: 444147
Created attachment 328559 [details] [diff] [review]
fix bitrot in previous patch version

Unbitrotted the patch; carrying forward r and sr.
Attachment #326750 - Attachment is obsolete: true
Attachment #328559 - Flags: superreview+
Attachment #328559 - Flags: review+
Patch checked in; thanks Dale!

Checking in mail/base/content/mailWindowOverlay.xul;
/cvsroot/mozilla/mail/base/content/mailWindowOverlay.xul,v  <--  mailWindowOverlay.xul
new revision: 1.253; previous revision: 1.252
done
Checking in mail/locales/en-US/chrome/messenger/msgViewPickerOverlay.dtd;
/cvsroot/mozilla/mail/locales/en-US/chrome/messenger/msgViewPickerOverlay.dtd,v  <--  msgViewPickerOverlay.dtd
new revision: 1.5; previous revision: 1.4
done
Checking in mailnews/base/resources/content/mailWindowOverlay.xul;
/cvsroot/mozilla/mailnews/base/resources/content/mailWindowOverlay.xul,v  <--  mailWindowOverlay.xul
new revision: 1.356; previous revision: 1.355
done
Checking in mailnews/extensions/mailviews/resources/content/msgViewPickerOverlay.js;
/cvsroot/mozilla/mailnews/extensions/mailviews/resources/content/msgViewPickerOverlay.js,v  <--  msgViewPickerOverlay.js
new revision: 1.27; previous revision: 1.26
done
Checking in mailnews/extensions/mailviews/resources/content/msgViewPickerOverlay.xul;
/cvsroot/mozilla/mailnews/extensions/mailviews/resources/content/msgViewPickerOverlay.xul,v  <--  msgViewPickerOverlay.xul
new revision: 1.11; previous revision: 1.10
done
Checking in suite/locales/en-US/chrome/mailnews/msgViewPickerOverlay.dtd;
/cvsroot/mozilla/suite/locales/en-US/chrome/mailnews/msgViewPickerOverlay.dtd,v  <--  msgViewPickerOverlay.dtd
new revision: 1.7; previous revision: 1.6
done
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Keywords: checkin-needed
Whiteboard: [needs checkin]

Comment 42

9 years ago
I'm on version 3.0a2pre (2008071003) and not seeing any additional menus. Where should I look? I have enabled mark as deleted model.

Comment 43

9 years ago
Look in the Folder views widget (in the toolbar) and under View | Messages

Comment 44

9 years ago
I'm not sure if this is a bug or intended behavior (it's behaving the same in TB 2.0 as well), but you don't get the View->Messages menu unless you have the Mail Views control on your toolbar.  You can get that by right-clicking on the toolbar, and selecting Customize.  You may have to scroll until you can see the Mail Views control in the dialog, but then drag it to your toolbar and hit OK in the dialog.  Once you do that you can either change to the Not Deleted view in the Mail Views toolbar control or the View->Messages menu.

Comment 45

9 years ago
Thanks guys, that's do a trick. It have per folder settings, can I override this to all new created folder and others?

Comment 46

9 years ago
(In reply to comment #44)
Not so intended - bug 332802.

(In reply to comment #45)
Bug 277072.

Comment 47

9 years ago
Seems working fine for me, here my observation.
When I delete message it will stay here until I select other folder and come back. Selecting folder with deleted messages where I have them, show every messages for about 1 sec. Is this intended behavior?

Comment 48

9 years ago
(In reply to comment #47)
> When I delete message it will stay here until I select other folder and come
> back.

I am observing the same behaviour, which makes the enhancement not really
usable to me; also, it is different from the behaviour of all other clients.

Is there a way to have TB auto-update the view after deleting a message?

Comment 49

9 years ago
bug 446417 filed according my comment 47
Product: Core → MailNews Core

Comment 50

9 years ago
I'm sorry to post again, but...

I wonder if the current fix really helps all the people out there waiting for this feature for such a long time. The issue (hiding deleted mails in IMAP model) has been around for years now, having a few "duplicate" bugs finally going into this one...

The result is, IMHO, not at all sufficient. It does not work "instantly" as expected and it is not flexible (no customized views with this "deleted-check" possible).

As all older bugs filed seem to have been closed, I would like to add a "wish" again: Why not have the flag "message deleted" as an option in the "customized message views" system, where we can choose it like all other "status" flags to filter and select? AFAIK, there has been a patch allowing just that before in one of the "closed" bugs anyway!

And, still, why does an action like "deleting" not enforce an automatic update of the current view - which would make using possible.

Again: Without at least the latter, the whole "fix" seems no help at all.

Sorry to bother...

Comment 51

9 years ago
I think not automatically updating should be a separate bug since it may not be related. I can go into the Tasks view, type in a task where it says "Click here to add a new task" and add a task, and the task view does not update automatically either. I have to switch away and back before I see the task, even though the task alarm triggers immediately.

Comment 52

9 years ago
This still isn't fixed in the released version.
The diffs uploaded in https://bugzilla.mozilla.org/attachment.cgi?id=328559&action=edit aren't applied the released source as of 2.0.0.18

Comment 53

9 years ago
This fix won't be applied to 2.0 versions.  It's only in 3.0 builds.

Updated

9 years ago
Duplicate of this bug: 247977

Updated

8 years ago
Blocks: 446417
You need to log in before you can comment on or make changes to this bug.