Create a Gmail RDF file for the Account Manager

VERIFIED FIXED in Thunderbird2.0


Account Manager
12 years ago
11 years ago


(Reporter: Scott MacGregor, Assigned: Scott MacGregor)




Firefox Tracking Flags

(Not tracked)




(1 attachment, 1 obsolete attachment)



12 years ago
We should make account creation for gmail accounts really easy. 

The file can be hosted as an extension on addons. Maybe we can get other ISPs to jump in with their own account information.

Here's the documentation how to do this:

Here's the gmail server info:

Comment 1

12 years ago
Created attachment 244970 [details] [diff] [review]
first cut at gmail account settings

Folks can test this by putting this file in the following directory

<directory for thunderbird.exe>\defaults\isp\en-US

Open up the account wizard and you should see an option for creating gmail accounts.

Account Notes:
* Pop3 over ssl
* leave on server
* biff should download new messages
* check for new mail at startup
* remember password
* smtp over ssl on port 587

On the fence on what to do for defaulting to using global inbox. this patch doesn't use global inbox.
*** Bug 275211 has been marked as a duplicate of this bug. ***


12 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 3

11 years ago
Created attachment 250415 [details] [diff] [review]
ship gmail.rdf

This takes the gmail.rdf file I created in the first patch and ships it by default for Thunderbird. 

I removed example.rdf which is obsolete. I added comments for aol.rdf and nswebmail.rdf to suggest not using them as templates as they are obsolete and they use the proprietary redirector types. gmail and dotmac are much better examples. I'm tempted to cvs remove aol.rdf and nswebmail.rdf, what do you think David? Any reason to keep those around?
Attachment #244970 - Attachment is obsolete: true
Attachment #250415 - Flags: superreview?(bienvenu)


11 years ago
Attachment #250415 - Flags: superreview?(bienvenu) → superreview+

Comment 4

11 years ago
I think we might want to consider shipping with an aol.rdf, now that they've opened up their imap server, so I wouldn't remove it. nswebmail.rdf, yeah, that should go... (AOL is still the largest ISP, as I understand it...)

Comment 5

11 years ago
I removed nswebmail.rdf and adjusted the README file when I checked this in.
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 6

11 years ago
fixed on the branch too.
Keywords: fixed1.8.1.2
Verified fixed for with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv: Gecko/20070109 Thunderbird/2.0b1 ID:2007010904
Keywords: fixed1.8.1.2 → verified1.8.1.2
You need to log in before you can comment on or make changes to this bug.