Less-than and greater-than characters are stripped

RESOLVED FIXED in 3.1

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Timwi, Assigned: fligtar)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Apparently I can't use the less-than and greater-than characters in an add-on description. This is a significant loss of functionality. HTML-escaping those characters really isn't hard; there is no need to remove them.

Reproducible: Always

Comment 1

11 years ago
I'm duping this to the bug about the public pages for now - even though you filed this about the developer pages, the same principles apply. 

See also bug 343573.

*** This bug has been marked as a duplicate of 318408 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Version: unspecified → 1.0
(Assignee)

Comment 2

11 years ago
The same principles don't really apply - the public bug was closed because we are going to a forum system that handles this appropriately; the Remora Dev CP currently still has this problem because I haven't gotten to tweaking the cleaning method yet.
Status: RESOLVED → UNCONFIRMED
Depends on: 352560
Resolution: DUPLICATE → ---
(Assignee)

Updated

11 years ago
Assignee: nobody → fligtar
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

11 years ago
Target Milestone: --- → 3.1
This is all tweaked now, by my light testing.
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.