Cannot print the Wikipedia french article on Mercure (the planet)

VERIFIED DUPLICATE of bug 285608

Status

()

Core
Layout: Floats
--
critical
VERIFIED DUPLICATE of bug 285608
12 years ago
11 years ago

People

(Reporter: Zurd, Unassigned)

Tracking

({hang, testcase})

Trunk
hang, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

I cannot Print or "Print to a file" with this web page :
http://fr.wikipedia.org/wiki/Mercure_%28plan%C3%A8te%29

Reproducible: Always

Steps to Reproduce:
1. Go to http://fr.wikipedia.org/wiki/Mercure_%28plan%C3%A8te%29
2. Either "Print", or "Print to a file"

Actual Results:  
Hangs at "Preparing..."

Expected Results:  
Should print.

It happens both on Windows 2000 with Firefox 1.5.0.8 and
with Gentoo, using Bon Echo, aka Firefox 2.0

I printed all the others planets, including the Sun and Pluto
and it worked fine, there's just a problem with Mercure.  So
I ended up printing it with Internet Explorer.
Assignee: nobody → printing
Component: General → Printing
Product: Firefox → Core
QA Contact: general
Version: unspecified → 1.8 Branch
I can reproduce this on OS X trunk.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061109 Minefield/3.0a1
Keywords: hang
OS: Windows 2000 → All
Hardware: PC → All
Version: 1.8 Branch → Trunk
Created attachment 245205 [details]
testcase

The first float needs to be long enough to exceed the page length for this to hang.
This is probably a duplicate of bug 285608, although the testcase is a bit different there. For now, marking as dependent.
Assignee: printing → nobody
Severity: normal → critical
Component: Printing → Layout: Floats
Depends on: 285608
Keywords: testcase
QA Contact: layout.floats
Actually, more likely this is a duplicate of bug 255982.
Depends on: 255982

Comment 5

11 years ago
I can confirm this hang at http://fr.wikipedia.org/w/index.php?title=Mercure_%28plan%C3%A8te%29&oldid=15557885 (permanent URL for the current revision).  The problem is with the right aligned table at the top of the article's wikitext (i.e. {{infobox Planète .... }} followed by right floated image [[Image:Mercury_Earth_Comparison.png]] -- remove either of those and the problem disappears.

This is very similar to another Wikipedia bug 376218.  Both are probably dups of more general bugs.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

11 years ago
Flags: blocking1.9?

Comment 6

11 years ago
The same problem occures on the German wikipedia article "Eiben" (engl.
"Taxus").
Here the link: http://de.wikipedia.org/wiki/Eiben

I was able to reproduce crashed on the following platforms:
Windows 2000 SP 4 - Firefox 1.5
Windows 2000 SP 4 - Firefox 2.0.0.4
Windows XP SP 2 - Firefox 2.0.0.4
Fedora Core 3 - Firefox 1.5

Comment 7

11 years ago
This affects a large number of Wikipedia articles.  See http://meta.wikimedia.org/wiki/Firefox_bugs_affecting_MediaWiki
Duplicate of this bug: 385401
FWIW it also happens in print preview, so it's really easy to test for. 

Updated

11 years ago
Duplicate of this bug: 382573
Flags: blocking1.9? → blocking1.9+

Comment 11

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071105 Minefield/3.0a7pre

Looks like Eli's patch in bug 285608 fixed this. I hang with a build from 2007-06-26-04, but not with today's trunk build using the testcase.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9+
Resolution: --- → DUPLICATE
Duplicate of bug: 285608

Updated

11 years ago
No longer depends on: 285608

Updated

11 years ago
No longer depends on: 255982
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.