Menu titles in menubar remain highlighted

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
trivial
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Brett Koonce, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({pp})

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 (Macintosh; U; PPC)
BuildID:    2000041608

If i click on a menu to select something, the menu remains highlighted in the 
menu bar field.

Reproducible: Always
Steps to Reproduce:
1. click on menu
2. choose something <or click again to not choose anything>
3.

Actual Results:  The menu remains highlighted until I click on something else.

Expected Results:  Unhighlighted the menu.

BTW, this also affects menu scrolling...If you click on the menu bar, then move 
it accross to a new menu, the old one stays highlighted.  This is visually 
confusing.

Comment 1

18 years ago
skoonce - could you elaborate (it might be to early in the morning but I'm not 
understanding this). Are you talking about the Mac menu bar, Mozilla's menus 
(i.e. the 'Bookmarks' pull-down menu in the personal toolbar) or HTML form pop-up 
menus? Also, if you could be a little clearer as to what exactly is going on, 
it'd help.

Sorry to be a bother but the coffee's just not brewing fast enough! :)

Comment 2

18 years ago
I think what's being described can be clrealy reproduced like this:

1) select Tasks->Personal Managers->Cookie Manager->View Stored Cookies (or
whatever you want, really)
2) notice that after the Cookie Manager opens, the mouse is still selecting
menus, and you have to click once to get it to stop.

This happens on Linux (2000041705) too, BTW.

Comment 3

18 years ago
Passing to the XP Toolkit/Widgets: Menus component ... this is probably a DUP of 
one of their submenu problems.
Assignee: joki → pinkerton
Component: Event Handling → XP Toolkit/Widgets: Menus
QA Contact: janc → sairuh
(Reporter)

Comment 4

18 years ago
Whee.  I just tried to take some pictures, and the <command-shift-3> thingy 
doesn't seem to be working.  When I quit this version of mozilla and restarted 
it, the problem disappeared.  So, for now, I guess we'll let it be.

In short, the problem was: After I clicked on the view menu (Or any other for 
that matter), highlighting "view" and bringing up the menu, and then clicked 
again, the "view" text remained highlighted.

If it's a real bug, it'll return. For now, let sleeping dogs lie.
sounds like a dup.

*** This bug has been marked as a duplicate of 23698 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

18 years ago
Created attachment 7657 [details]
A menu of what's going wrong. (Artist's rendition.)
(Reporter)

Comment 7

18 years ago
Whee. I can now reproduce it every time.

Goto http://xmenthemovie.com/ and let the page load. (Mac 2000041608)

Then click on the file menu and move your mouse over to edit, view, go...the 

previous menu stays highlighted until you move your mouse over to the third one.



This problem seems to mess with the mac's interal organs.  I can't take a picture 

with the command-shift-3 trick.



Here's my artists rendition of how the bug looks.

(Reporter)

Comment 8

18 years ago
Important note.  This NOT happening in the Macos, but rather inside Mozilla 
itself.  Mozilla, though, won't let me take a picture of what's going on.
ah! okay...not a dup of bug 23698.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 10

18 years ago
Yeah, it's not a dup. It's in the menu bar, not contextual menus.
This problem is now easy to reproduce, via bug #36067 (which I just found.)  Goto 
http://xmenthemovie.com and then click on your menu bar.  You should see what I'm 
talking about.
weird --i cannot reproduce this using 2000.04.17.06-m15 commerical bits on MacOS
9.0. eli/pink, have you seen this?
Keywords: pp
Summary: Menus remain highlighted → Menu titles in menubar remain highlighted

Comment 12

18 years ago
Ach. Why does this show up as Resolved Duplicate in the bug list?? Stupid 
Bugzilla.

I finally get it (nice pic!). I'll check it out on today's M15 and later on M16. 
If it's involved with bug 36067, then it might also be related to the QT/Flash 
plugins problems?

Comment 13

18 years ago
I can't reproduce this either (nor have I ever seen it). 2000041706 M15 - will 
try M16 binary once posted to the ftp server (as M16 was the version this was 
originally reported on).
(Assignee)

Comment 14

18 years ago
i can't dupe this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

18 years ago
I just put M16, build 04/17/12 on my machine and found this and bug #36067 still 
there.  I also tested it with (04/17/04) M15 and found the same problem. I'm 
using school computers to test this. This bug has appeared on three identically 
configured machines (8.6, b&w g3's).

I propose we mark this bug as being dependent upon #36067.  The question is, what 
about my system configs is messing with everything?
Status: RESOLVED → VERIFIED
skoonce, is this still a problem for you using a recent build? if so, do reopen
this...
(Reporter)

Comment 17

18 years ago
Just tried M16 (04-21-13) and the problem's still there.  If you're really 
looking to fix this, though, know that I'm causing it by way of bug #36067.  This 
is more of an after effect than a bug in itself.   I'm thinking the problem there 
may be with something inside the engine.  This page (xmenthemovie.com) uses 
flash, javascript, and qt (?) together, messing up mozilla on my machines.

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.