Last Comment Bug 360323 - Firefox development conflicting with my environment
: Firefox development conflicting with my environment
Status: RESOLVED INCOMPLETE
:
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English Other (show other bugs)
: unspecified
: All All
: -- major
: ---
Assigned To: Majken Connor [:Kensie]
: Mike Schroepfer
Mentors:
Depends on:
Blocks: lackofsex
  Show dependency treegraph
 
Reported: 2006-11-10 16:45 PST by Majken Connor [:Kensie]
Modified: 2015-06-09 08:38 PDT (History)
28 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Majken Connor [:Kensie] 2006-11-10 16:45:09 PST
Ever since my husband started working for Mozilla he's been committing fewer cycles on his work maintaining our local environment. Debugging steps seem to imply that he has fewer resources available, but closer inspection shows enough resources are available, they're just not being accessed properly.  I think this is a threading issue. Firefox development is buffering resources it might need, but not freeing them up when other processes ask for them.

Steps to reproduce:

1. File bug in component owned by developer. (reproduces best if bug is a blocker, but will also reproduce with less severe bugs.)
2. Place full garbage can beside developer from step 1.

Expected results:

Bug gets fixed and garbage is emptied.

Actual results:

Bug, its regressions, and several other related and unrelated bugs get fixed. Garbage remains untouched even after several requests.

Reproducible: For me, Always, but I wouldn't be surprised if not everyone can see it.

I believe this bug is what has been preventing a fix for bug 95849 as any attempt to fix it while this bug is still happening will cause a regression rendering any other patch ineffective.
Comment 1 Daniel Mota Leite 2006-11-10 18:03:27 PST
ooops, sorry about the accidental "blocking firefox3" flag, trying to remove
Comment 2 Phil Ringnalda (:philor, back in August) 2006-11-10 22:00:12 PST
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&who=mconnor%25steelgryphon.com&whotype=match&sortby=Date&date=explicit&mindate=2006-10-10+00%3A00%3A00&maxdate=2006-11-10+00%3A00%3A00&cvsroot=%2Fcvsroot

Unable to confirm that he's fixed a bug in more than a month; this must be Governance, or some corporate component I've never seen.
Comment 3 Majken Connor [:Kensie] 2006-11-10 23:24:21 PST
So you can see my problem, the resources still aren't released for other tasks.  Don't forget to count reviews and checkins in your search.  Also note I didn't say "bug is fixed by developer."  For the sake of simple and specific steps to reproduce I used filing a bug in step 1, but that could really be replaced with "assign task."
Comment 4 Stefan [:stefanh] 2008-02-17 15:40:10 PST
Is this wfm now? Or has it regressed even further?
Comment 5 Majken Connor [:Kensie] 2008-02-18 00:05:49 PST
There has been some improvement here or there that seem to coincide with some of Firefox 3's performance wins, but new things seem to come along and use up the freed resources. The garbage collection is still not keeping up with demand.  A helper app might be necessary.
Comment 6 Jo Hermans 2008-02-18 03:34:50 PST
(In reply to comment #5)
> There has been some improvement here or there that seem to coincide with some
> of Firefox 3's performance wins, but new things seem to come along and use up
> the freed resources. The garbage collection is still not keeping up with
> demand.  A helper app might be necessary.
> 

Possibly that improvement was caused by some checkins on the 14th. Keep an eye on it to make sure it's not a temporary regression :-) 
Comment 7 Mike Connor [:mconnor] 2008-05-13 11:59:06 PDT
Checked in some changes to GC, and implementation of cat.  Not sure if there's a net positive from those changes as of yet.
Comment 8 Mike Connor [:mconnor] 2008-11-19 16:19:08 PST
Changing assignee, was unable to fix, I believe the reporter is going to fix this herself.
Comment 9 Chris Lawson (gone) 2011-02-02 15:16:14 PST
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.

Note You need to log in before you can comment on or make changes to this bug.