bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Closing tab4 after it was opened from tab1 link, firefox dosent take you back to tab1.

RESOLVED DUPLICATE of bug 345033

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 345033
12 years ago
12 years ago

People

(Reporter: jeroi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.8.1) Gecko/20061010 Firefox/2.0

If I have many tabs open and I am browsing with tab1 or any tab which is not the last tab, and open a new tab from a website link. I just look what that link have and then want to close it and continue to browse with the tab1 website, firefox closes the tab but opens the last tab not the tab what you were browsing.

Reproducible: Always

Steps to Reproduce:
1. Open atleast 2 tabs.
2. Browse with tab1.
3. Click at the webpage some link with midle button to open link in new tab, which will be tab3.
4. Close the tab and you will be at tab2, not tab1.

Actual Results:  
Firefox will show last tab.

Expected Results:  
To show last used tab.

*** This bug has been marked as a duplicate of 345033 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.