Close menu item does not work.

VERIFIED FIXED in M8

Status

SeaMonkey
UI Design
P2
normal
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: leger, Assigned: davidm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using Mar 10 build on Mac 8.5
1) Select Close menu item
2) Nothing happens
3) Using Close box to close windows works great!

beppe, can you assign a QA Contact to check Win32 and Linux please.
(Reporter)

Updated

19 years ago
Severity: major → normal
Priority: P3 → P2
Target Milestone: M3
(Reporter)

Comment 1

19 years ago
Putting on M3 radar for now. Though I would release note this since Close box is
the workaround.

Updated

19 years ago
Assignee: don → davidm
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 2

19 years ago
Re-assigned to davidm@netscape.com and changed platform and OS to All.

David, is this fixable for M3?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

19 years ago
Someone has to implement the close routine in the browser appcore. Someone really
has to setup some infostructure so we don't do the really lame thing of having to
cut& paste code to make windows obey common commands.

Updated

19 years ago
Component: Apprunner → XPApps
Target Milestone: M3 → M4

Comment 4

19 years ago
Changed target milestone to M4 and component to XPApps.

I agree about the command handling problem.

Comment 5

19 years ago
I just verified this one and File | Close is still not working
on both Linux and Windows latest Gecko builds.

Let me know if you want me to try on Mac again.
(Reporter)

Comment 6

19 years ago
Still not working with Mar13 build.  Will Release Note for Dogfood....no worries.

Updated

19 years ago
QA Contact: 3853 → 4144

Comment 7

19 years ago
assigning Petersen as QA contact
(Assignee)

Comment 8

19 years ago
*** Bug 4218 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Target Milestone: M4 → M5
(Assignee)

Comment 9

19 years ago
This isn't going to happen for m4 since until appcores are no longer singletons
calling into the Appcore to destroy the window is going to cause problems. Moving
to m5
(Assignee)

Updated

18 years ago
Target Milestone: M5 → M6
(Assignee)

Comment 10

18 years ago
move to m6 since I haven't had time to invesigate why the program dies when
multiple windows are open

Comment 11

18 years ago
*** Bug 5779 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Target Milestone: M6 → M7
(Assignee)

Comment 12

18 years ago
until bug 6005 is fixed the JS I have written will crash. Moving to m7
(Reporter)

Comment 13

18 years ago
*** Bug 4660 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Depends on: 7792
(Assignee)

Comment 14

18 years ago
Filed a bug about the toolkit not handling multiple windows. Added dependancy

Updated

18 years ago
Target Milestone: M7 → M8

Comment 15

18 years ago
Rather than check in your Javascript code which might crash without Dan's fixes,
let's move this to M8 for now.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

18 years ago
Checked in the JS. It will still be death until bug 7792 gets fixed if you have
more than 1 window.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 17

18 years ago
Checked with June 23rd Build on Mac. Fixed.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.