mouse wheel click jump-scrolls on first click very often

RESOLVED DUPLICATE of bug 351491

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 351491
12 years ago
12 years ago

People

(Reporter: Scott, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

my first mouse-wheel-click inside of any new tab automatically scrolls up a page or so (jump-scroll) instead of opening the link in a new tab. after that first click, the wheel click will function normally.

it's pretty annoying, and new to me in 2.0. (1.5.x doesn't have this problem, nor does IE)....

Reproducible: Sometimes

Steps to Reproduce:
1.Open A couple tabs.
2.scroll down on a page or so
3.use the mouse wheel to click a link

Actual Results:  
It may jump-scroll up instead of opening the link in a new browser window.


I am thinking that perhaps this happens more often when I use "ctrl+tab" "ctrl+shift+tab" to scroll through my different tabs...and maybe the actual window isn't selected at the time or something...but i'm not sure that this is making it occur more or not.

also, I did find the bug reported here as well: https://bugzilla.mozilla.org/show_bug.cgi?id=309365  (BUG ID 309365).  but it says it was resolved....when it was not.
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061109 BonEcho/2.0

I middle-click numerous times on links on the bottom and nothing jumps here.
Please retest with:

- a reinstall in a new empty directory
- Firefox's safe-mode to exclude extension problems
- a new profile 

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
http://forums.mozillazine.org/viewforum.php?f=38
(Reporter)

Comment 2

12 years ago
Ok I tried that (uninstalled, deleted folder, new install.)...didn't seem to work for me. 

But, I noticed another way that this occurs now.  When I went to bugzilla.com, I first clicked the home button on that tab (no particular reason, just force of habit).  But, the page jump-scrolled on that click too!  So perhaps this isn't just related to the middle click, but more in general.
(Reporter)

Comment 3

12 years ago
Ok, I've now found that this happens not only as stated in the bug, and in my 2nd comment.  However, it will happen sometimes if I just click anyhere on the page.  It will randomly jump scroll - but always ONLY once per new page that is loaded.  Again, it seems to happen randomly...  But whether i'm clicking a link, or juts one blank white space, it'll happen.

if I hold the mouse button longer than just a click (on accident it's happened), it will jump scroll, and highlight from where the pointer was to where it scrolled to.  not sure if that will help find the cause or not.

any ideas??
I think this bug is related to bug 359424 but I don't have the privilege to mark it as dupe.
I'm going to guess that this is a dupe of bug 144000 - if you can still reproduce it after going to Tools>Options>Advanced and unchecking the accessibility options, then please reopen this bug.

*** This bug has been marked as a duplicate of 144000 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Oops, I meant bug 351491, of course.

*** This bug has been marked as a duplicate of 351491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.