Closed Bug 36046 Opened 24 years ago Closed 24 years ago

QuickTime movies fail to display

Categories

(Core Graveyard :: Plug-ins, defect, P3)

PowerPC
Mac System 9.x

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: devsin, Assigned: sdagley)

References

()

Details

(Keywords: relnote, Whiteboard: [nsbeta2-][nsbeta3-][egk])

** Thanks to purs0007@tc.umn.edu, who remains the original reporter (see bug 
29206) and the source of most of the information in these new reports. **

-- REVISED FROM BUG 29206 - purs0007@tc.umn.edu --

The above URL points to a page that contains a single <embed>ed quicktime movie. 
The first time it loads, the QuickTime movie flickers and then disappears behind 
a grey box; it's still up and to the left, but only by 30 pixels or so.  If you 
click on the upper half of the grey box, the movie displays (somewhat) and begins 
to play.  If you then hit reload, the movie, which is drawn way too far up and to 
the left, with the top third or so of the movie cut off at precisely the same 
height as the top of the grey rectangle that sits happily where the actual 
picture is supposed to be.  The left edge of the movie goes past (but is not on 
top of) the left edge of the window.  It plays fine, though.

REPRODUCIBLE:  Always

STEPS TO REPRODUCE:
1.  Install the QuickTime browser plugin (latest version 4.1.1) by copying the 
one found in <Macintosh HD:Quicktime Folder> to <Macintosh HD:Mozilla 
Folder:Plugins> (or wherever you have your Mozilla installation).
2.  Visit http://www.apple.com/trailers/fox/x-men/480_trailer.html

ACTUAL RESULTS:  The movie was only partially shown and drawn in the wrong place, 
leaving a grey box where it should have been.

EXPECTED RESULTS:  The movie should be shown completely and in the right place, 
leaving no grey boxes of any kind.

Original report: Opt build 2000022414 for Mac; QuickTime Plugin (for NS 4.x or IE 
4.x) version 4.1 (in Mozilla Folder:Plugins).  iMac DV SE w/Mac OS 9.

Latest test: Mozilla M16 2000041608, Mac OS 9.0.4; QuickTime 4.1.1, QT Plugin 
4.1.1.
Added quicktime keyword. Changed OS to All. Created dependency to bug 29206. 
Added purs0007@tc.umn.edu to Cc.

Thanks again, purs0007.
Depends on: 29206
Keywords: quicktime
OS: Mac System 9.0 → All
thanks, but this is a dup.

*** This bug has been marked as a duplicate of 29206 ***
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
oops...reopening..just realized that this bug is more specific and newer.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
*** Bug 29206 has been marked as a duplicate of this bug. ***
nsbeta2 nomination.
Severity: normal → major
Keywords: nsbeta2
Removing dependency now that official comments are in.

No longer depends on: 29206
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
Reassigning to Steve, who's kindly volunteered to take this on. Thanks Steve!
Assignee: av → sdagley
Status: REOPENED → NEW
*** Bug 44840 has been marked as a duplicate of this bug. ***
Keywords: 4xp
I'm a little hosed on this one at the moment as, in my quest for a build that 
would reliably launch, I updated my tree and now have a build that won't load the 
QT plugin at all.  On the bright side I can consistently launch Mozilla for the 
first time in over a week.  Will sync with bnesse in the AM to get back to the QT 
plugin issue rather than the just getting it running issue.
Status: NEW → ASSIGNED
Whiteboard: [nsbeta2+] → [nsbeta2+] ETA 07/14/2000
BTW, Can I get confirmation this is a Mac specific bug?  The OS:All setting with 
Platform:Macintosh is confusing (not the reporter's fault, the OS: field should 
be driven by Platform: and list only those appropriate)
This is mac only.
OS: All → Mac System 9.0
Adding a [7/17] in Status Whiteboard...will minus on Monday.
Whiteboard: [nsbeta2+] ETA 07/14/2000 → [nsbeta2+] [7/17]ETA 07/14/2000
Remove nsbeta2+ and eta of 7/14 since that day has come and gone; PDT please re-
evaluate.
Add keyword nsbeta3.
Keywords: nsbeta3
clear status whiteboard like I said I was going to...
Whiteboard: [nsbeta2+] [7/17]ETA 07/14/2000
7/14 has come and gone so markingminus. can someone please relnote - vishy
Keywords: relnote
Whiteboard: [nsbeta2-]
We may be able to fix this. Seems like a general Mac plugin problem. I've had 
some success in getting Quicktime to work by turning off double buffering. See 
bug 49743
Now, the movie does not display at all. I see a blank space instead. Using build 
2000092911 branch. Updating summary.
Summary: QuickTime movies fail to display correctly → QuickTime movies fail to display
Yes, I'm not seeing the Quicktime either. Hm...this is weird. It seems to work
on my debug build. I'm wondering if it's #ifdef DEBUG'ed somewhere.

Will check.
see bug 53976. If I rename the plugins folder to what it was before, quicktime 
just works fine (As good as on windows).
Is there any way to fix this for PR3 or is it too late?
cc: av, ekrock.
See related bug 54778 "Nav4 QuickTime plug-in only works in Moz/N6 on Mac if 
plug-ins directory is named "plugins"?!" created to focus on this new problem.
Keywords: rtm
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3-]
Shrir, are we still seeing this bug?

Steve, what's your status on this bug? Do you think you'll be able to fix for
RTM? Or are we thinking that the general double-buffering changes have already
fixed this?

If not, we need to find someone else who might be able to fix this; we want
QuickTime to work for RTM. cc:ing bnesse for possible help or input.
Whiteboard: [nsbeta2-][nsbeta3-] → [nsbeta2-][nsbeta3-][egk]
Yes, Am still seeing this problem. Renaming the folder to 'plugins' makes 
quicktime work fine.2000100910 branch build on mac.
Actually the original bug reoprted here is fixed. So am marking this fixed. Will 
add my comment to bug 54778. Resolved/fixed.
Status: ASSIGNED → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → FIXED
verified (20001009) branch build.
Status: RESOLVED → VERIFIED
OS: Mac System 9.x
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.