Page w/ QT movie interferes with screen capture

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
19 years ago
18 years ago

People

(Reporter: devsin, Assigned: serhunt)

Tracking

Trunk
Future
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
** Thanks to purs0007@tc.umn.edu, who remains the original reporter (see bug 
29206) and the source of most of the information in these new reports. **

-- REVISED FROM BUG 29206 - purs0007@tc.umn.edu --

Having a Mozilla window open to a page that contains a QT plugin interferes with 
the Mac's ability to take a screenshot of any kind, ala command-shift-3 or 
command-shift-4 or even caps-lock-command-shift-4.  All that gets output to the 
resulting PICT file is a jumbled, twisted version of the Mozilla window, minus 
the window frame.  Hiding Mozilla before taking the screenshot alleviates the 
problem, however.

REPRODUCIBLE:  Always

STEPS TO REPRODUCE:
1.  Install the QuickTime browser plugin (latest version 4.1.1) by copying the 
one found in the Quicktime Folder to the mozilla-mac-M16:Plugins directory.
2.  Visit http://www.apple.com/trailers/fox/x-men/480_trailer.html
3.  Attempt to take a screenshot (via one of the above mentioned keyboard 
shortcuts).

ACTUAL RESULTS:  The resulting PICT file (saved to the root level of your hard 
drive) is mangled/distorted.

EXPECTED RESULTS:  The resulting PICT screenshot should be an exact 
representation of your screen at the time it was taken.

Original report: Opt build 2000022414 for Mac; QuickTime Plugin (for NS 4.x or IE 
4.x) version 4.1 (in Mozilla Folder:Plugins).  iMac DV SE w/Mac OS 9.

Latest test: Mozilla M16 2000041608, Mac OS 9.0.4; QuickTime 4.1.1, QT Plugin 
4.1.1.
(Reporter)

Comment 1

19 years ago
Added quicktime keyword. Created dependency to bug 29206. Added 
purs0007@tc.umn.edu to Cc.

Thanks again, purs0007.
Depends on: 29206
Keywords: quicktime
(Reporter)

Comment 2

19 years ago
[SPAM] - I'll be creating an attachment to this bug - a screenshot taken while 
Mozilla is running and viewing http://www.apple.com/trailers/fox/x-men/
480_trailer.html via the keyboard combo command-shift-3. I compared this to a 
screenshot taken (via the same method) with Mozilla at http://
bugzilla.mozilla.org/, which turned out to be normal. (The file is a super-low-
quality-compressed-converted-from-PICT JPEG file.)
(Reporter)

Comment 3

19 years ago
Created attachment 7648 [details]
Mac screenshot of Moz viewing QT movie
(Reporter)

Comment 4

19 years ago
This problem occured while loading http://www.xmenthemovie.com/, a site that 
utilizes Macromedia's Flash, and then again at http://www.nin.com/. It looks like 
this may be a Flash problem and not a QT plugin problem (or a general plugins 
problem).
(Reporter)

Comment 5

19 years ago
Removing dependency now that official comments for bug 36046 are in.
(Reporter)

Comment 6

19 years ago
Removing dependency now that official comments for bug 36046 are in.

No longer depends on: 29206
(Assignee)

Comment 7

19 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
Target Milestone: --- → Future

Updated

19 years ago
Keywords: 4xp
(Reporter)

Comment 8

18 years ago
I'm not seeing this problem on the latest (10/2000) M18 builds. Tried both on 
page with QuickTime movie and on page with Flash file. Resulting screenshots were 
saved as expected. I didn't get a chance to test this against Shockwave or other 
plugin content, but I think this was probably a result of other plugin badness 
that recently got fixed. Marking WFM. Will keep an eye out in case this pops up 
again in the future.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.