If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When email comes in and there is message that "Thunderbird thinks this message might be an email scam" -- no option for sayin it IS or IS NOT a scam.

RESOLVED DUPLICATE of bug 318916

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 318916
11 years ago
3 years ago

People

(Reporter: linda.lloyd, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

When I check my inbox, sometimes there is an email with the message, "Thunderbird thinks this message might be an email scam."  This is on the left side of the screen.  On the right side is a button that says "Not a Scam."  If the message is, in fact, a scam, there is no option to indicate that is actually a scam.  Don't know whether to delete or mark as junk.

Reproducible: Didn't try

Actual Results:  
This would be impossible to try to reproduce, as it is only present when the program thinks a message is a scam.

Comment 1

11 years ago
It isn't currently learning anyway, see bug 320351. This would probably be resolved by bug 328749.

Comment 2

11 years ago
(In reply to comment #1)
> This would probably be resolved by bug 328749.

I don't know if that's true.  It seems that bug is about implementing the capability to use alternate tests for scams, not necessarily about reporting scams.

The "Thinks this might be a scam" is just a warning to keep you from blindly following potentially malicious links in the message.  If you click the Not A Scam button, the only effect is to no longer display that toolbar for that message.

This seems to come up a lot, tho.  Maybe the UI for this needs to be rethought, altho I like the simplicity of the existing scheme.
(Reporter)

Comment 3

11 years ago
I guess my real question is this:  If the incoming message actually IS a scam, how can I identify it as such, so that Thunderbird will know.  Or maybe it doesn't matter if Thunderbird knows or not.

Comment 4

10 years ago
I think that this should be marked as a duplicate of bug 320351 - ie. a full learning system for scams, with positive or negative confirmation by the user. Naturally having "Is" and "Is not" options would be part of that.
Agree?

Comment 5

9 years ago
Actually, I get this one all the time, from a specific email subscription; and even though I always click "not a scam", it still says that each time I receive this email, which is every day.

I have looked all over Thunderbird to see why the program will not permanently accept my designation of this subscription email.
I am not comfortable editing any of the configuration files or .js files, so I would appreciate knowing if this is a "bug" or is it just a programming over-sight...you know?  One that slipped through the cracks?

Seems like it would be simple to fix: it might be that the "not a scam" button
is just not connected to a permanent preference setting?

In any case...just wanted you to know that it most certainly IS repeatable...:-)

Updated

9 years ago
Assignee: mscott → nobody

Comment 6

9 years ago
[Client Software]     Bug 360742 

After some investigation, I resolved my own dilemma...;--)

Understanding how a program code is directed in behavior, is key to identifying a bonifide "bug", from a simple difference in programmer/user perception; as well as, attempting an appropriate fix, if necessary.

In the Thunderbird preference file below, Line 368 illustrates the programmer's attempt to direct how Thunderbird recognizes "SCAMS" in mail messages:
it is told to analyze URLS in messages only for phishing, as its definition of "scam".
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
\Mozilla Firefox\Thunderbird\defaults\pref\all-thunderbird.js

Line 368	// analyze urls in mail messages for scams
Line 369	pref("mail.phishing.detection.enabled", false);

Editing the above file, where "FALSE" = "TRUE", accomplishes the same effect as changing the preference in Thunderbird OPTIONS, Privacy, E-mail Scams. Placing
a tic in the box turns ON (True) the alert.

I submit that Bug 360742   -  When email comes in and there is message that "Thunderbird thinks 
this message might be an email scam" -- no option for sayin it IS or IS NOT a scam. is NOT a true "bug", 
but rather a simple difference in understanding between programmer and user.

If the user elects to turn on scam notification in preferences, the subsequent alert is advising the mail
message MAY contain links to suspected phishing sites.

Only the User can determine if he/she wants this notification, based on understanding the purpose
of the programmer.

IF, on the other hand, the real issue being reported here, is NO "not a scam" BUTTON is available when the alert shows, it would seem prudent to update the version of software being used. If that fails to produce the missing visualization, make an analysis of firewall and or virus scanner permissions to 
determine if the involved scripts are being allowed.

I hope this helps.

Nobody

Comment 7

9 years ago
(In reply to comment #6)
[QUOTE]
If the user elects to turn on scam notification in preferences, the subsequent
alert is advising the mail message MAY contain links to suspected phishing sites.
[/QUOTE]

Fine and dandy, except that is all-or-nothing.  Some senders, I know their mail will not contain a phishing attempt (or other type of scam).  I want to be able whitelist them in the same way I do for loading remote images.  In fact, the same UI would be just right.

Comment 8

9 years ago
I have a similar problem. There's one sender (saved in my Address Book) who's messages are marked as "Thunderbird thinks this might be a scam", although: 

1. The sender is in my Address Book. 
2. The sender is definitely not sending scam
3. I have pressed the "Ignore warning" button (the only one available when this shows up). 

Now, I want to know how can I make Thunderbird learn that sender is NOT a scam, and avoid the same message over and over I get a mail from that sender. 

I have attached the message source of one of those mails.

Comment 9

9 years ago
Created attachment 362597 [details]
The message from the sender Thunderbird always thinks is scam
confirming base on gabriel's comment. He uses Tb3.0b1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Attachment #362597 - Attachment mime type: application/octet-stream → text/plain

Comment 11

9 years ago
As discussed in bug 318916, that wouldn't be a good idea.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318916

Comment 12

4 years ago
This is a duplicate of 320351, not 318916.
Flags: needinfo?(nobody)
Flags: needinfo?(nobody)

Comment 13

3 years ago
It's a duplicate of 398875 as well.
You need to log in before you can comment on or make changes to this bug.