remote content for (custom) thunderbird start page do not show anymore

RESOLVED FIXED in Thunderbird2.0

Status

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: mkmelin, Assigned: mscott)

Tracking

({regression, verified1.8.1.2})

Thunderbird2.0
x86
Linux
regression, verified1.8.1.2
Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Set Thunderbird Start Page Location to http://www.mozilla.org/. Click Go > Mail Start Page. Remote content - at least images but it seems CSS as well - are not showing up anymore.

This broke on branch 2006-11-04 -> 2006-11-05.
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=ThunderbirdTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-11-04+04%3A00%3A00&maxdate=2006-11-05+04%3A00%3A00&cvsroot=%2Fcvsroot

Though this bug should be fixed, on a side note I may add that having a UI option for setting the start page (with a chrome:// url as default!) is *very* odd. This if anything should be and about:config option, I really doubt many people are using it.
(Reporter)

Comment 2

12 years ago
Likely caused by fixes for bug 330443 and/or bug 359479.

Works fine on trunk. 
(Reporter)

Comment 3

12 years ago
This broke on trunk too sometime 2006-11-20 -> 2006-11-23. 
Fallout from bug 357321 perhaps.
(Reporter)

Updated

12 years ago
Flags: blocking-thunderbird2?
(Assignee)

Updated

12 years ago
Target Milestone: --- → Thunderbird2.0
(Assignee)

Updated

12 years ago
Flags: blocking-thunderbird2? → blocking-thunderbird2+
(Assignee)

Comment 4

12 years ago
Created attachment 252101 [details] [diff] [review]
a fix

This allows remote images if the url loaded into the message pane is an http or https url (aRequestingLocation is the message pane url not the requesting location url trying to load the remote image). I think this should be safe while still blocking remote content in nested iframes from a mail message.
(Assignee)

Comment 5

12 years ago
Comment on attachment 252101 [details] [diff] [review]
a fix

so far this has been passing my test cases.
Attachment #252101 - Flags: superreview?(bienvenu)

Updated

12 years ago
Attachment #252101 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1.2
Resolution: --- → FIXED

Comment 6

12 years ago
What about file: URLs? I am guessing here because it's already special cased in http://lxr.mozilla.org/seamonkey/source/mailnews/base/src/nsMsgContentPolicy.cpp#303
(Assignee)

Comment 7

12 years ago
Neil, are you wondering if we should allow a user to set a file url as their start page which in turn has remote images in it? I wonder how common that would be in practice...
(Reporter)

Comment 8

12 years ago
Using a file url and local images doesn't work either, bug 364613. 
The remote content works fine now.
Keywords: fixed1.8.1.2 → verified1.8.1.2

Updated

12 years ago
Duplicate of this bug: 368547
You need to log in before you can comment on or make changes to this bug.