Closed Bug 361358 Opened 14 years ago Closed 12 years ago

203 installation error/cannot install extensions

Categories

(Toolkit :: Add-ons Manager, defect)

x86
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 356370

People

(Reporter: richards1052, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When I attempt to install any extension, I get the following error:

"FF could not install http://releases.mozilla/...textmarker_-0.3.2-fx.xpi
unexpected installation error: -203"

The error console displays this:

Error: e.location.getItemLocation(e.id) has no properties
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsExtensionManager.js
Line: 4050

I have gone to the Unable to Install Extensions pg. & followed every suggestion & workaround for this problem & none helped.


Reproducible: Always

Steps to Reproduce:
1.attempt to install extension xpi file
2.
3.

Actual Results:  
The above error msg. results.

Expected Results:  
Extension should have installed.

I do not know if this is a related problem or not, but I've also noticed that I do not have access to Profile Mgr.  After trying all the suggestions listed to access it, none work.  When I try to access it, instead of going to Profile Mgr. a blank FF browser window opens.

Otherwise, FF appears to be working normally in every other fashion.
In this thread:

http://forums.mozillazine.org/viewtopic.php?t=484236&highlight=

3 other users report the same problem
More related behavior I just noticed.  On my Tools/Add Ons page when I disable or uninstall a plugin, I see a msg. saying the change will be made the next time I open FF.  But when I close the browser & reopen it, the extension has not been disabled or uninstalled.  I was wondering this might have anything to do with the default session mgr. feature.  Might the Add Ons pg. not be registering the new session & somehow be fooled into thinking its the same session even though I logged out & then logged back in?  Just a thought...
Confirming based on the thread posts.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8.1.1?
*** Bug 361133 has been marked as a duplicate of this bug. ***
(In reply to comment #4)
> *** Bug 361133 has been marked as a duplicate of this bug. ***
> 
Thanks for catching that.  I tried searching for a duplicate bug before posting this one, but guess I missed 361133.
I was able to re-install Firefox and repair the problem by uninstalling the application, removing the Firefox directories under Docs and Settings/user name/Application Data and Program Files.

After installing Firefox again and then was able to install both Extensions and Themes with no problems.
Not blocking, but cc'ing :rs and dveditz to see if they can look into it. Doesn't seem hugely common, and possibly related to profiles.
Flags: blocking1.8.1.1? → blocking1.8.1.1-
I just followed Russ' general solution.

Since I was prevented fr. accessing Profile Mgr. to create a new profile I deleted the default profile I'd been using.  Then I was able to access Profile Mgr., create a new profile, & migrate files fr. my old profile folder to my new one.

This did the trick.  On reopening FF, all extensions installed properly & I could successfully install new ones.

It appears that when I installed FF 2 it caused either a conflict with, or corruption of my profile.
In Firefox 2.0-44.3 in SUSE 10.0, I get the same error whenever I try to install a new extension:

"unexpected installation error: -203"

I thought I had worked around this bug when I learned on a forum that some kind of configuration file may have been corrupted during the upgrade to 2.0.  It's been a couple of months, so I cannot remember the filename, but I logged out of Firefox, deleted the file, then restarted Firefox with the idea that when Firefox restarted it would recreate the deleted file with a new, uncorrupted version.  This fix worked for several weeks, but now the bug has returned.
Duplicate of this bug: 403110
Duplicate of this bug: 406826
Duplicate of this bug: 406180
i have the same issues, as a webdesigner this is a big problem. I am running x64 windows XP pro which may shed some light if others are running this programme.
This bug is still on going. I just experienced the problem. What I observed is Firefox corrupts the Profile and then tries to delete the extensions.ini but it doesn't work leading in no extensions working at all.

This occurs in the latest Nightly of Firefox 3 PreBeta4 (Frozen).

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008022806 Minefield/3.0b4pre

Any idea how to fix this problem or prevent it from occurring? 

I've thought up some ideas on my own, but they might so more like dreams to some people but they are possible with a little work. 

Firefox should be able to detect corrupt files (or in this case extenstions.ini missing or corrupt). If it detects such a problem, next time Firefox start it will run in Diagnostics mode (not noticeable to the user). 

In this Diag Mode Firefox will work in the background (not using excessive CPU or memory) and do a complete check of the profile and installation for any corrupt files (like the extensions.ini). 
For this example, say the only corrupt file my Firefox (with diag) finds is the extensions.ini. It will delete the corrupt file and then regenerate it by scanning through installed addons and themes and adding them to the list, and any that are not compatible will be remarked. Then it will tell the user that it detected a corrupt profile but fixed it. If it's unrepairable it will also tell the user this. 
Maybe even by default when it regenerates the ini it will check the installed addons against a whitelist of addons that haven't had severe enough problems in the past say month, then if it has had big problems it will be disabled by default.

Notes:
** When the Diag scans through the installed addons it should also clean up. What I mean by this is any empty folders or obviously uninstalled/removed addons it finds should be totally deleted. E.G. I have uninstalled a few addons and the diag finds empty (obviously uninstalled) folders left behind from uninstalled extensions (in the AppData/Firefox/Profile/Extensions dir)

** The Diagnostics mode altough designed to be totally automatic, the user should be able to force the diagnostics mode by command of Firefox.exe -diag

** Diag Scanner should check the Firefox exes against MD5 hashes of that build. So the MD5 Hashes of your installation should match those on the Firefox Server for your current build (this will work for nightlys too!)

** Firefox should let the user know after the scanning if something was found to be wrong. This notification shouldn't be annoying, but rather should a slider window above the system tray.

What do you guys think? You like my concept?

You know kind of a self auto-repairing browser. That would be cool, no other browser does that!


-Mike
Duplicate of this bug: 411070
Duplicate of this bug: 423100
Duplicate of this bug: 417654
comment 9 --> (In reply to comment #9)
> In Firefox 2.0-44.3 in SUSE 10.0, I get the same error whenever I try to
> install a new extension:
> 


got the same problem with vista ...

--> Setting OS from win XP to all
OS: Windows XP → All
(In reply to comment #14)
> This bug is still on going. I just experienced the problem. What I observed is
> Firefox corrupts the Profile and then tries to delete the extensions.ini but it
> doesn't work leading in no extensions working at all.
> 
> This occurs in the latest Nightly of Firefox 3 PreBeta4 (Frozen).
> 
> Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008022806
> Minefield/3.0b4pre


Same here
Windows vista business
Minefield 3.0b5pre  2008031905

but this problem occured  since 3.0b3 on my computer

when i try to install some add-ons, it fails ... and it failed by trying to update installed add-ons (add-ons where working ie nighlty tester tools 1.3b ... it update to 1.3 final and now it is no more working as upgrade failed ...)

Error console:
Item is null ...
and when i click on the error

      // An item entry is valid only if it is not disabled, not about to
      // be disabled, and not about to be uninstalled.
      var installLocation = this.getInstallLocation(item.id);
in file Error: item is null
Source File: file:///C:/Program%20Files/Mozilla%20Firefox%203/components/nsExtensionManager.js
Line: 3885

(In reply to comment #19)
> Same here
> Windows vista business
> Minefield 3.0b5pre  2008031905
> 
> but this problem occured  since 3.0b3 on my computer
> 
> when i try to install some add-ons, it fails ... and it failed by trying to
> update installed add-ons (add-ons where working ie nighlty tester tools 1.3b
> ... it update to 1.3 final and now it is no more working as upgrade failed ...)
> 
> Error console:
> Item is null ...
> and when i click on the error

You are seeing bug 421396
true ...
by the way, it is now working by 
renaming extensions.log, extensions.rdf and extensions.ini in the profile folder into .bak file
Restarting firefox: all is now working

but i don't know if it can solve also this bug ...
I had what might be a related problem: installing Adblock Plus would result in the message "Adblock Plus 0.7.5.4 could not be installed because it is not compatible with Firefox 3.0" (running 3.0rc1 on macosx 10.4.11-ppc). Deleting extensions.cache and extensions.ini and restarting resolved the problem; interestingly extensions.ini was 0 bytes long before I deleted it.
I had the problem described above installing a theme. I then realized there was not enough disk space at the target location, where the theme content is to be saved finally.
I managed to provide more space and the theme installed without problems.

Therefore I guess, the cause of this problem is related to either user's permissions on the target location OR disk space at the target location. Generally spoken: If it is technically possible to write something to the files target location, the implementation works fine. 

This could also be the reason, why this problem is occuring on different OSes and not commonly but seldomly to users.

Cheers!
I've been having this problem on my Vista Home Premium home laptop, but not on my Vista Ultimate work desktop...bizarre. I tried uninstalling FFX3 and reinstalling it, but it didn't matter. One thing which shouldn't affect it, but may, is that on my work desktop [which doesn't have this problem], I installed FFX3 to C:\Program Files\Mozilla Firefox 3 whereas on my home laptop which does have this problem, I installed FFX3 to the default location. 

On my home laptop, I'm running as a standard user, per Microsoft's recommendation. I tried deleting extensions.log, extensions.rdf and extensions.ini, but that didn't help anything. So I did repetitions of the installation process to see if I could find any pattern. Each time I deleted the old profile, created a new profile, and started from scratch. Here are my results:

-----------------------------------------------------------------
FBG = Firebug 1.2.0 beta 3
GSP = Gmail Space 0.5.94
OPR = Operator 0.9.3
OPV = OperaView 0.6.1
RMN = RetailMeNot 2.2
SGB = Screengrab! 0.95
TMX = Tab Mix Plus dev build (as of June 24, 2008)
WDV = Web Developer 1.1.6
(they installed correctly unless noted with either * or ^)
* = incompletely installed (can't use), or keeps asking to reboot
^ = couldn't install due to -203 error
-----------------------------------------------------------------
Profile 1: SGB GSP TMX FBG WDV^
Profile 2: FBG GSP OPR OPV RMN*
Profile 3: WDV TMX SGB RMN* OPV*
Profile 4: FBG GSP OPR SGB*
Profile 5: FBG GSP OPR TMX*
Profile 6: FBG GSP OPR TMX*
Profile 7: FBG GSP OPR TMX*
Profile 8: FBG GSP OPR WDV*
Profile 9: FBG GSP OPR WDV TMX^
Profile 10: FBG GSP OPR SGB WDV*
Profile 11: FBG GSP OPR SGB*
Profile 12: GSP OPR WDV TMX*
Profile 13: GSP OPR WDV FBG TMX^
Profile 14: GSP OPR WDV FBG*
Profile 15: WDV TMX FBG GSP (this is the profile I'm using)
-----------------------------------------------------------------
As you can see, the only real pattern is that it always occurs on the fourth or fifth add-on. But as you can see from the pairs of 8 & 9, 10 & 11, and 13 & 14, sometimes the same installation order yields different results. I eventually just installed the four add-ons I need most (number 15) and am using that profile.

I hope this data is useful to someone! I don't have the time or the knowledge to proceed with debugging, unfortunately.
I forgot to add that the above data was gathered with the FFX 3.0 release version, although I had the exact same problems with RC2.
Can I make a plea for someone to sort this bug out.  I've used Firefox happily for a number of years with no problems.  Having upgraded to FF3 I now get an error 203.  I have tried every solution and done a lot of reading up.  I've even changed my profile, but whilst the solutions work for 5 minutes, the bug returns.  The nett result is that I cannot update any of my add-ons or themes with my original profile and am unable to install add-ons on my new profile (I managed to install 2, but the bug returned and I cannot install any more add ons).  I have posted twice on Mozalline "error 203, please sort it".  I am now posting on this Forum that someone will sort it once and for all.  Meanwhile, I am using Opera as my default browser.  I shouldn't really have to, should I?
Flags: wanted1.9.0.x?
Flags: blocking1.9.0.1?
This bug has become something of a mess. The error code mentioned could be caused by a large number of different issues so everyone piling in with "me too" is not all that helpful. I'm going to resolve this as a duplicate of bug 356370 which should have fixed what I believe the original reporters problem was.

If others are still seeing this issue, even the original reporter, please do not reopen this report. Instead file a new bug report following the suggestions at http://www.oxymoronical.com/blog/2008/06/Filing-good-Extension-Manager-bugs
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: wanted1.9.0.x?
Flags: blocking1.9.0.1?
Resolution: --- → DUPLICATE
Duplicate of bug: 356370
Product: Firefox → Toolkit
Attached file junk attachment (obsolete) —
You need to log in before you can comment on or make changes to this bug.