CR: Define a prefered langage for contacts for correct spelling checking

RESOLVED DUPLICATE of bug 69687

Status

Thunderbird
Address Book
--
enhancement
RESOLVED DUPLICATE of bug 69687
11 years ago
11 years ago

People

(Reporter: Simon Woods, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

I write most of my mails in German, however communicate with contacts in other countries mostly in english. According to sods law I always have the wrong spelling checker language turned on for the mail that I am currently writing. It would be quite nifty if thunderbird knew which language I prefer to use when talking to certain contacts. The address book would need a prefered language pulldown which either offers those languages which are installed, or all languages that could possibly be available. The later is probably not such a good idea.
Challenges to be solved:
* User has language french, but thunderbird only has engish and german installed. Address book should not automatically overwrite french - maybe I have just not got around to installing the language.
* User has a language which is not present - mail should use some default language - either default or last language?
* During the writing of a mail I change the recipient of the mail to someone with a different language - probably should just leave it the way it was.
* When writing a mail to several recipients with different languages - should use a default language. It would be possible to really go overboard and give each user more than one language allowing thunderbird to find a common denominator between the reciepients, but we probably should leave the writer of the mail at least something to do ;-)
By the way - my company will be providing such language preference information in our corporate directory in the not too distant future which could tie in nicely to this CR.

Reproducible: Always

Comment 1

11 years ago
bug 202207 addresses the per address (book entry) setting. 
bug 69687 for the rest
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
OS: Windows XP → All
Resolution: --- → DUPLICATE
Duplicate of bug: 69687
You need to log in before you can comment on or make changes to this bug.