horizontal lines appearing while scrolling over block elements

RESOLVED DUPLICATE of bug 376124

Status

()

Core
General
RESOLVED DUPLICATE of bug 376124
11 years ago
9 years ago

People

(Reporter: Benjamin Krause, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When scrolling over a html-page, horizontal lines keeps appearing. 
It will not happen, if you scroll fast, but slow scolling (e.g. with arrow keys) created those lines.

Reproducible: Always




might be related to #338861 or #256328


This might be related to the depth of block elements or with floating elements. haven't seen it on top-level block elements or non-floating elements.

However, i can remove these lines by removing the style overflow: auto from these block elements, that have these lines. 

see also:
http://modxcms.com/forums/index.php?topic=4535.msg64637
(Reporter)

Comment 1

11 years ago
Created attachment 246476 [details]
screenshot with some lines
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061213 Minefield/3.0a1 ID:2006121308 [cairo]

WFM

Comment 3

11 years ago
I have noticed (in firefox)that this occurs on elements with css overflow:auto set as a means of causing it to wrap its floated contents.

Comment 4

11 years ago
Lines appear when scrolling over a page with frames: three frames, nested. Look at
 
http://www.larryeubank.com/cheetah/cheetah_MenuFrames.html

and scroll down to see extraneous lines.

Comment 5

11 years ago
Lines have disappeared, temporarily. Did I have some "styles" defined multiple times, and was that a problem? Or possibly ZoneAlarm is inserting JavaScript when I upload the files via FTP? (ZA tends to insert stuff, like "postamble()" at the end of file.)

At any rate, FOR NOW the lines have disappeared.

Comment 6

10 years ago
I'm seeing the lines appear with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070211 Minefield/3.0a3pre, at least when I have Use smooth scrolling turned on. The problem is most noticeable on the checkboxes when I go to change my votes <https://bugzilla.mozilla.org/votes.cgi?action=show_user>.

Comment 7

10 years ago
Occurs for me too on Firefox 2.0.0.3 with Autoscrolling and Smooth Scrolling. Occurs for me when I use the mouse wheel to navigate. Apparently minimizing the window/highlighting the text causes them to disappear, however, using the mouse wheel to scroll down and back up causes them to reappear. Windows 2000 Professional with SP4 and all updates. No ZA, however AVG and Pidgin IM are running in the background. Occurs for me on Wikipedia "Difference between revisions" pages with the highlighted changes.

Comment 8

10 years ago
Created attachment 265326 [details]
Another screenshot of the issue

Comment 9

10 years ago
Confirmed in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070615 Minefield/3.0a6pre

Comment 10

10 years ago
Created attachment 269788 [details]
Yet another screenshot ...

Comment 11

10 years ago
See also bug 376124.

Updated

9 years ago
Duplicate of this bug: 424957

Comment 13

9 years ago
Still occurring in 2.0.0.14.  This should be at the top of fixes, since FireFox prides itself on being standards-compliant.  We're all used to hacking around IE problems, but it's not fun when the browser you count on can't display floats contained by a parent element with overflow:auto.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.9.0 Branch
Is this reproducible in Firefox 3?

/be
Version: 1.9.0 Branch → unspecified

Comment 15

9 years ago
I think this is a dupe of bug 376124, which was fixed months ago in Firefox 3.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376124
You need to log in before you can comment on or make changes to this bug.