Use nsFileProtocolHandler::ReadURLFile in nsIEProfileMigrator::ResolveShortcut

RESOLVED FIXED

Status

()

Firefox
Migration
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: philor, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Bug 69114 gave nsFileProtocolHandler a copy of the code for resolving Windows internet shortcut (.url) URLs that we copied from xpfe's nsBookmarksService.cpp for profile migration. We should switch to using that copy instead of maintaining (or not) our own, though possibly not until bug 361857 is fixed. That probably depends on whether our current copy works any better.

(This bug is actually a duplicate of bug 248538, but nobody figured that out before it went completely off the rails, so I'm starting over with all the bugs it became, so I can close it.)
(Reporter)

Updated

11 years ago
Depends on: 361857
fixed by the new migrator
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 710895
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.