Fixed positioning broken w/ GFX scrollbars

VERIFIED FIXED in M18

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: olaf, Assigned: Eric Vaughan)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed/absolute position bug, URL)

(Reporter)

Description

18 years ago
This is probably related to bug 5195 and bug 21476, but there is more to it than
described in those reports. The page above consists of two DIVs fixed-positioned
side by side like in the Demo 12 example, but here the box on the right is of
fixed size and the other one is scrollable. With GFX scrollbars, the scrollbar
is drawn under (obscured by) the right-side DIV. This means either the size is
miscalculated, or the scrollbar is placed outside the box, instead of inside it.
It works with native scrollbars. (See also the "Software" link, which leads to a
bigger page with the same layout.)
Also, the page isn't painted completely until it gets resized. This also works
better (but still not entirely right) with native scrollbars.
Build 2000041612 under Linux.

Comment 1

18 years ago
Probably a DUP, but reassigning to Eric
Assignee: troy → evaughan

Comment 2

18 years ago
Marking confirmed.  It looks like the fixed positioned DIV is too wide (I think
the scrollbars should be fit within the margin-box of the DIV, which should
shrink the DIV, since that's what we do with scrollbars for the viewport (and, I
assume, other things).)

Attaching to tracking bug that should help see if it's a duplicate.
Blocks: 38639
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

18 years ago
targeting
Whiteboard: fixed/absolute position bug
Target Milestone: --- → M18
(Assignee)

Comment 4

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
Lokks correct in the July 14th builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.