Tabindex attribute not working with A, BUTTON, or INPUT elements.

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
a year ago

People

(Reporter: Chris Petersen, Assigned: Blake Ross)

Tracking

({access, html4, regression})

Trunk
access, html4, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixinhand], URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Build:2000041806
Expect Results: Pressing the tab key should apply focus to the element specified 
by the tabindex value assigned.
What I got: Pressing the tab key doesn't apply focus on the next element in the 
tab order.

Steps to reproduce:
Anchor problem:
1) Open the url in NS6.
2) The file contains five anchor each that have a tabindex value assigned.
3) Attempt to place focus on the 3rd link (the first tabindex value).
4) The link never gets focus so you can press the tab key.

Button problem:
1) Open the attached button test case in NS6.
2) The file contains four buttons each that have a tabindex value assigned.
3) Place focus on the first button (the first tabindex value).
4) After this is done, press the tab key.
5) Focus is not moved to the next element in the tab order. 

Input problem:
1) Open the attached input test case in NS6.
2) The file contains four input fields each that have a tabindex value assigned.
3) Place the cursor in the fisrt field.
4) Press the tab key.
5) Focus is not moved to the next input element (field 4) in the tab order.
(Reporter)

Comment 1

18 years ago
Created attachment 7699 [details]
A series of buttons that use tabindex.
(Reporter)

Comment 2

18 years ago
Created attachment 7700 [details]
A series of input fields that use tabindex.

Comment 3

18 years ago
I think this goes to rods for fixing.
Assignee: rickg → rods

Comment 4

18 years ago
Tom, I have tried to decypher the tabbing code and I am not having any luck, I 
think you or saari are much better prepared for figuring this out than I am.
Assignee: rods → joki
(Reporter)

Comment 5

18 years ago
Tabindex should be working since users will commonly tab throught the order of 
form elements. Marking nsbeta2.
Keywords: nsbeta2

Comment 6

18 years ago
This is a regression, this used to work.  cc'ing hyatt and saari as likely 
candidates.
Summary: Tabindex attribute not working with A, BUTTON, or INPUT elements. → (regression)Tabindex attribute not working with A, BUTTON, or INPUT elements.

Comment 7

18 years ago
*** Bug 2642 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
Added TEXTAREA to the list of broken tabindexs
[moving regression from summary to keywords]
Keywords: regression
Summary: (regression)Tabindex attribute not working with A, BUTTON, or INPUT elements. → Tabindex attribute not working with A, BUTTON, or INPUT elements.

Comment 10

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.
Whiteboard: [nsbeta2-]

Comment 11

18 years ago
Nominating for nsbeta3.  Fix in hand.
Status: NEW → ASSIGNED
Keywords: nsbeta3
Whiteboard: [nsbeta2-] → [nsbeta2-] [fixinhand]

Comment 12

18 years ago
*** Bug 46139 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
Marking nsbeta3+...
Whiteboard: [nsbeta2-] [fixinhand] → [nsbeta2-][fixinhand][nsbeta3+]

Comment 14

18 years ago
The two attachments work, but the url test case (the one with links on it) does 
not show focus rectangle around the links, so I can't tell whether this bug is 
fixed for links.  We are not going to spend more time on this bug pre Netscape 6 
ship.

This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration, but do not clear 
the nsbeta3- nomination.
Target Milestone: --- → Future

Updated

18 years ago
Whiteboard: [nsbeta2-][fixinhand][nsbeta3+] → [nsbeta2-][fixinhand][nsbeta3-]

Comment 15

18 years ago
*** Bug 49892 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
*** Bug 49967 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
*** Bug 49982 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
*** Bug 50089 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
*** Bug 50045 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
*** Bug 50216 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
Testing build 2000-09-04-08 on MacOS 9.0.4.

http://slip/projects/marvin/html/button_tabindex.html

Visiting this link it seems that it is working partially.  Tabbing normally (i.e. 
from URL field) doesn't take the focus to the buttons, but once you click on the 
frame containing the buttons the Tab key indeed takes you through the right 
order.  Can't go back, since Shift-Tab isn't implemented, but at least it works 
in one direction.  Just some food for thought.

Comment 22

18 years ago
FYI-
http://slip/projects/marvin/html/a_tabindex.html is working in Linux 6.2 2000-09-
27-10.

Comment 23

18 years ago
When will this work? And how long do kids, older people and disabled people have
to wait for this kind of support?If this is labeled 'future', then for a lot of
human mankind this browser is HISTORY!
Keywords: access, html4, mozilla1.0

Comment 24

18 years ago
*** Bug 67404 has been marked as a duplicate of this bug. ***

Comment 25

18 years ago
Be sure to check bug 67404 and its testcase after fixing this for shift-tab...

The "button" testcase on this bug doesn't work for me for tab *or* shift-tab, 
btw.
clearing milestone, nominating for beta1. what the status on this --ie, why not
check it in now? thx!
Keywords: nsbeta2, nsbeta3 → nsbeta1
Whiteboard: [nsbeta2-][fixinhand][nsbeta3-] → [fixinhand]
Target Milestone: Future → ---
joki, i assume your fixinhand is in your local tree --could you pls attach it
here? thx!
(Assignee)

Comment 28

18 years ago
taking...
Assignee: joki → blakeross
Status: ASSIGNED → NEW
(Assignee)

Comment 29

18 years ago
Created attachment 24340 [details] [diff] [review]
[patch] button tabindex
(Assignee)

Comment 31

18 years ago
Fix checked in.  Links and textfields should be working already.  You still 
have to click for this to work, and shift-tab still isn't reliable, but those 
are separate bugs.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 32

18 years ago
Where should we dup shift-tab bugs to?? Bug 67404 isn't fixed with this patch
but is a dup of this bug.
(Reporter)

Comment 33

18 years ago
Marking verified in the March 23rd build.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
When anchor tag is within a table caption. The tabindex won't work for firefox.
Chrome and Ie both have worked.
You need to log in before you can comment on or make changes to this bug.