If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to create custom view for 'unread' and/or something else.

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Matt Dudziak, Assigned: Scott MacGregor)

Tracking

Trunk
All
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
The problem is that it is not possible to create a custom view for 'unread' and something else. For example, I like to mark messages that need attention as 'unread' (uncheck 'read' for the message). This causes the message to appear in bold in the mailbox as expected. The problem is that I cannot create a custom view that will show these messages, as 'unread' is not an option in the dialog where views are created.


To reproduce:

- View a mailbox that has some unread messages in it.
- Select View->Messages->Customize...
- Create a new view. For the view, match 'any' then attempt to enter 'Status is unread'.
- Note there is no 'unread' option available.
- Note that 'Status is New' is NOT the same as 'Status is unread'

In my case, I have created a view:
Match ANY
Age in days is less than 2
Status is New

This does not display unread messages older than 2 days as I would expect. It only displays 'new' messages older than 2 days (as well as all messages less than 2 days old, of course). In order to get this to work, I have to do:

Match ANY
Age in days is less than 2
Status isn't Read
Status isn't Replied
Status isn't Forwarded

Since Thunderbird has a concept of 'unread', which for some reason differs from 'new', the user should be able to create a view that matches 'unread' status.
(Reporter)

Comment 1

11 years ago
Whoops.

Match ANY
Age in days is less than 2
Status isn't Read
Status isn't Replied
Status isn't Forwarded

Does not work as it displays all the message since I am using 'ANY'. Can't use 'ALL' as I need the view to show unread messages older than 2 days. Really need a way to test for 'Status is unread'

Comment 2

11 years ago
status isn't read is equivalent to "unread", so the functionality is present, if I understand correctly.
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> status isn't read is equivalent to "unread", so the functionality is present,
> if I understand correctly.
> 

No, 'status isn't read' is not equivalent to 'unread'.

A forwarded message 'isn't read'...

Using 'status isn't read' will show forwarded/replied messages, which is not what I want. I specifically want 'unread' messages.

Comment 4

11 years ago
status isn't read only shows me unread; it doesn't show me read+forwarded messages.

Or do you not want to see unread, forwarded messages? If that's the case, the summary should probably change...
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> status isn't read only shows me unread; it doesn't show me read+forwarded
> messages.
> 
> Or do you not want to see unread, forwarded messages? If that's the case, the
> summary should probably change...
> 

I guess 'not read' does what I want...

It's a bit counter-intuitive, but it works....

Comment 6

11 years ago
=> WFM per reporter's comment 5.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.