Status

()

defect
VERIFIED DUPLICATE of bug 278860
13 years ago
13 years ago

People

(Reporter: danielpsantos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Deleting the next folder under "C:\Documents and Settings\[...]\Application Data\Mozilla\Firefox\Profiles" that contains user data, results that the user cannot start fireFox any more. When starting fireFox a message arises "FireFox is already running, but not responding [...]". 
The solution I found to solve this is deleting the folders "[...]\Firefox\Profiles" under "C:\Documents and Settings\[...]\Application Data\Mozilla\". So the next time I start FireFox it will prompt to import or not the IE data. 
As this folders contain data to FireFox the minimum a program is assumed to do in such situation is to give a more specific error message so the user can know what is wrong. In my case I deleted those folders to get free from a virus.

Reproducible: Always

Steps to Reproduce:
1.Delete the next folder(s) under "C:\Documents and Settings\[...]\Application Data\Mozilla\Firefox\Profiles"
2.Start Mozilla FireFox. A message window appears. Browser will not appear.
3.Look at the Windows process manager. Try to close the message window and look at the Windows process manager again. Try to launch FireFox again. Monitor all these operations on Windows process manager. 

Actual Results:  
Mozilla FireFox browser does not appear.

Expected Results:  
Should (at the minimum) give a more detailed message to the user like "Some user data files may be corrupted. Your preferences and other user data may be lost. Please delete the folder '[...]\Firefox\Profiles' so Mozilla FireFox can prompt you to rebuild user data structure."
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
no patch given -> clearing fixed
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.