Sunbird crashes when adding an icalendar file on an https server

RESOLVED DUPLICATE of bug 331404

Status

Calendar
General
--
critical
RESOLVED DUPLICATE of bug 331404
11 years ago
11 years ago

People

(Reporter: sam morris, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006 Sunbird/0.3

When trying to subscribe to an icalendar file on an https server, Sunbird crashes. Calendars on regular http servers work fine.

Reproducible: Always

Steps to Reproduce:
1. Try to subscribe to a calendar on an https server
2. Crash!




The https server is using a certificate signed by an authority that Mozilla does not know about. If you can point me to a publicly-accessible icalendar file on an https server then I can try it out.

I can set up a dummmy calendar on our system if you want to try to reproduce it with our servers. We use Sunbird on several other systems (on Windows and Linux) and it doesn't crash however.
(Reporter)

Comment 1

11 years ago
Created attachment 247851 [details]
Windows crash log output

Short debugging info:

AppName: sunbird.exe	 AppVer: 0.3.0.0	 ModName: msvcr80.dll
ModVer: 8.0.50727.42	 Offset: 000176d9
(Reporter)

Comment 2

11 years ago
I also tried the 2006-12-06 nightly and got the crash. Sunbird also crashed if I tried to access the new Advanced section of Sunbird's preferences.

Comment 3

11 years ago
According to Bug 330271 Comment #75 and following comments this is caused by
the problem reported in Bug 331404. Resolving as duplicate.

Unfortunately the fix for Bug 331404 is not yet contained in Sunbird (or
Firefox or Thunderbird). You can use the tools that are attached in bug 331404
to fix your system or wait for a future release that contains the fix.

PS.: Please use the search next time (to find e.g. Bug 357709)

*** This bug has been marked as a duplicate of 331404 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.