crash when loading an https url (e.g. after trying to check for updates) [@msvcr80.dll]

RESOLVED DUPLICATE of bug 331404

Status

()

--
blocker
RESOLVED DUPLICATE of bug 331404
13 years ago
7 years ago

People

(Reporter: mak, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(5 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060312 Firefox/1.6a1

After starting firefox I click on the menu item "help/check for updates". Then the "Microsoft Problem Agent" starts with the following problemsignature: AppName: firefox.exe	 AppVer: 1.9.20060.31205	 ModName: msvcr80.dll
ModVer: 8.0.50727.42	 Offset: 000176d9

Talkback doesn't start. Also every 10 minutes the same action suddenly takes place (even when firefox is opened, but not used). This seems to be activated by the automatic update function. Setting app.update.auto to false and 
app.update.enabled to false stopps it. I get this failure since starting with the firefox cairo builds. The same firefox version build without cairo works fine.

Reproducible: Always

Comment 1

13 years ago
Does your build not have Talkback or do you not have it enabled?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Does your build not have Talkback or do you not have it enabled?
> 

I'm using the zip-build. And the strange thing is, that talkback is shown as enabled in the extensions-windows. But it never starts and I don't know why. Safemode shows the same results.
(Reporter)

Comment 3

13 years ago
Created attachment 215168 [details]
Error Message

I have now manually turned on talkback, but it doesn't give any error. I've made a screenshot.
(Reporter)

Comment 4

13 years ago
Another thing that makes the same crash is clicking on a link that should open a https-link in an new tab. Clicking on http-links, everything works fine.

Updated

13 years ago
Component: GFX: Thebes → Software Update
Product: Core → Firefox
QA Contact: thebes → software.update

Comment 5

13 years ago
Do you run Fx on a Pentium M processor? I ask this because I read about crashes on a laptop in a thread on MozillaZine (http://forums.mozillazine.org/viewtopic.php?t=402655) and a user of my 3rd party builds is also reporting a crash in msvcr80.dll (fault address 0x000176d9) on a Pentium M.
My primary development machine has a Pentium M, btw; I'm not sure that it's directly CPU related.
(Reporter)

Comment 7

13 years ago
Yes, one machine is a Pentium M, but the other is an athlon XP 3000.
Marcel, is this still an issue?
(Reporter)

Comment 9

12 years ago
(In reply to comment #8)
> Marcel, is this still an issue?

Yes, unfortunately more than before. Until the end of june the crash occurred only when trying to check for updates. After coming back from holiday, end of july, I tried a new trunk build and now the crash occurs 2 seconds after starting minefield (just tried with todays trunk build). I'm starting with an fresh clean profile (also in safe mode) an after starting he asks me, if i want minefield as my default browser and before I can click "no" (or "ok") the mircosoft problem agent comes and tells me the problem with "msvcr80.dll... Reproducable. 
(Reporter)

Comment 10

12 years ago
Created attachment 232568 [details]
ms problem agent

This is a screen shot of the crash

Comment 11

12 years ago
that's totally useless.

you'll need to find someone who has a symboled build. there's an old minefield available from http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg which i've been using quite happily. if you can crash that, we can get something done. 
(Reporter)

Comment 12

12 years ago
Ok, I tried it and crashed with update checking (because its an old build). This was the only thing it wrote after entering "kp". Does this help?

ChildEBP RetAddr  
037afe64 7c91e9c0 ntdll!KiFastSystemCallRet
037afe68 7c8025db ntdll!ZwWaitForSingleObject+0xc
WARNING: Stack unwind information not available. Following frames may be wrong.
037afecc 7c802542 kernel32+0x25db
037afee0 300194cb kernel32+0x2542
037afefc 30015589 nspr4+0x194cb
037aff14 30015682 nspr4+0x15589
037aff2c 00f8b853 nspr4+0x15682
037aff50 30015e4b necko+0xb853
037aff68 7c92b686 nspr4+0x15e4b
50000161 00000000 ntdll!RtlAllocateHeapSlowly+0x113b
(Reporter)

Comment 13

12 years ago
And another one:

ChildEBP RetAddr  
03abfe44 7c91e9c0 ntdll!KiFastSystemCallRet
03abfe48 7c8025db ntdll!ZwWaitForSingleObject+0xc
03abfeac 7c802542 kernel32!WaitForSingleObjectEx+0xa8
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\nspr4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\nspr4.dll - 
03abfec0 300194cb kernel32!WaitForSingleObject+0x12
WARNING: Stack unwind information not available. Following frames may be wrong.

Comment 14

12 years ago
it doesn't look like you followed the instructions to tell windbg how to get symbols for the firefox. (i presume you downloaded the referenced build but did not configure windbg to point to mcsmurf's symbol server.)
Don't get confused by the 404, it probably looks for a index.html in that folder, but there is none. But I can tell you that the symbols exist there. Maybe I'll upload a new build in the next few days, but for the Reporter the older build seems to crash, too.

Comment 17

12 years ago
we can change the page to tell you that you can't browse the directory, symbol server directories are generally not browsable, microsoft's isn't. the last thing web servers want to do is spend all their time giving all their symbols to search engines which can't do anything remotely useful with them. (there's a note in windbg's help that explains this, but it's ok for us to add a note to mdc.)
(Reporter)

Comment 18

12 years ago
(In reply to comment #14)
> it doesn't look like you followed the instructions to tell windbg how to get
> symbols for the firefox. (i presume you downloaded the referenced build but did
> not configure windbg to point to mcsmurf's symbol server.)

It downloaded nearly 36MB symbols, so I think it worked. That is what is standing in the window after starting. I think it should be right?

Symbol search path is: SRV*h:\symbols*http://www.mcsmurf.de/mozilla/ff-symbols/;SRV*h:\symbols*http://msdl.microsoft.com/download/symbols
0:000> .symfix+ h:\symbols
0:000> .reload /f
Reloading current modules
.*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\xpcom_core.dll
.*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\plc4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\plc4.dll - 
.*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\plds4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\plds4.dll - 
.*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\js3250.dll
..*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\xul.dll
.*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\nspr4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\nspr4.dll - 
 

Comment 19

12 years ago
if you downloaded the build from mcsmurf's server too, then it shouldn't say
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for 
D:\Programme\fftest\firefox\...
(Reporter)

Comment 20

12 years ago
(In reply to comment #19)
> if you downloaded the build from mcsmurf's server too, then it shouldn't say
> *** ERROR: Symbol file could not be found.  Defaulted to export symbols for 
> D:\Programme\fftest\firefox\...

It shouldn't but it does. I worked with mcsmurf's build and thats what it said.   

Comment 21

12 years ago
try
!sym noisy
.reload /f

(attach that output here)
(Reporter)

Comment 22

12 years ago
.*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\xpcom_core.dll
DBGHELP: xpcom_core - private symbols & lines 
         h:\symbols\xpcom_core.pdb\2BE8B4153B5A4BEEAFF5A86C63CC77041\xpcom_core.pdb
.
DBGHELP: No debug info for D:\Programme\fftest\firefox\plc4.dll.  Searching for dbg file
SYMSRV:  h:\symbols\plc4.dbg\445E3A448000\plc4.dbg not found
SYMSRV:  http://www.mcsmurf.de/mozilla/ff-symbols//plc4.dbg/445E3A448000/plc4.dbg not found
DBGHELP: D:\Programme\fftest\firefox\plc4.dbg - file not found
DBGHELP: D:\Programme\fftest\firefox\symbols\dll\plc4.dbg - path not found
DBGHELP: D:\Programme\fftest\firefox\dll\plc4.dbg - path not found
DBGHELP: D:\Programme\fftest\firefox\plc4.dbg - file not found
DBGHELP: D:\Programme\fftest\firefox\plc4.dll missing debug info.  Searching for pdb anyway
DBGHELP: Can't use symbol server for plc4.pdb - no header information available
DBGHELP: D:\Programme\fftest\firefox\plc4.pdb - file not found
DBGHELP: plc4.pdb - file not found
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\plc4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\plc4.dll - 
DBGHELP: plc4 - export symbols
.
DBGHELP: No debug info for D:\Programme\fftest\firefox\plds4.dll.  Searching for dbg file
SYMSRV:  h:\symbols\plds4.dbg\445E3A3F7000\plds4.dbg not found
SYMSRV:  http://www.mcsmurf.de/mozilla/ff-symbols//plds4.dbg/445E3A3F7000/plds4.dbg not found
DBGHELP: D:\Programme\fftest\firefox\plds4.dbg - file not found
DBGHELP: D:\Programme\fftest\firefox\symbols\dll\plds4.dbg - path not found
DBGHELP: D:\Programme\fftest\firefox\dll\plds4.dbg - path not found
DBGHELP: D:\Programme\fftest\firefox\plds4.dbg - file not found
DBGHELP: D:\Programme\fftest\firefox\plds4.dll missing debug info.  Searching for pdb anyway
DBGHELP: Can't use symbol server for plds4.pdb - no header information available
DBGHELP: D:\Programme\fftest\firefox\plds4.pdb - file not found
DBGHELP: plds4.pdb - file not found
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\plds4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\plds4.dll - 
DBGHELP: plds4 - export symbols
.*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\js3250.dll
DBGHELP: js3250 - private symbols & lines 
         h:\symbols\js3250.pdb\E8C4A921402548ACBFECF624712B96E51\js3250.pdb
.
DBGHELP: firefox - private symbols & lines 
         h:\symbols\firefox.pdb\6C057483A9C34769987B520F290AC1E91\firefox.pdb
.*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\xul.dll
DBGHELP: xul - private symbols & lines 
         h:\symbols\xul.pdb\42CFCF452AEB4C53831273C0979C79FD1\xul.pdb
.
DBGHELP: No debug info for D:\Programme\fftest\firefox\nspr4.dll.  Searching for dbg file
SYMSRV:  h:\symbols\nspr4.dbg\445E3A3E29000\nspr4.dbg not found
SYMSRV:  http://www.mcsmurf.de/mozilla/ff-symbols//nspr4.dbg/445E3A3E29000/nspr4.dbg not found
DBGHELP: D:\Programme\fftest\firefox\nspr4.dbg - file not found
DBGHELP: D:\Programme\fftest\firefox\symbols\dll\nspr4.dbg - path not found
DBGHELP: D:\Programme\fftest\firefox\dll\nspr4.dbg - path not found
DBGHELP: D:\Programme\fftest\firefox\nspr4.dbg - file not found
DBGHELP: D:\Programme\fftest\firefox\nspr4.dll missing debug info.  Searching for pdb anyway
DBGHELP: Can't use symbol server for nspr4.pdb - no header information available
DBGHELP: D:\Programme\fftest\firefox\nspr4.pdb - file not found
DBGHELP: nspr4.pdb - file not found
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\nspr4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\nspr4.dll - 
DBGHELP: nspr4 - export symbols
.
DBGHELP: WS2HELP - public symbols  
         h:\symbols\ws2help.pdb\537CE830EFE94FE3A92C95153BDB71462\ws2help.pdb
.
DBGHELP: WS2_32 - public symbols  
         h:\symbols\ws2_32.pdb\07AC08831007408D919E0CCF1EA499BF2\ws2_32.pdb
.
DBGHELP: WSOCK32 - public symbols  
         h:\symbols\wsock32.pdb\E7B6C17E43604822813D3B65499B6C0F2\wsock32.pdb
.
DBGHELP: WINMM - public symbols  
         h:\symbols\winmm.pdb\4FC9F179964745CAA3C78D6FADFC28322\winmm.pdb
.
DBGHELP: ole32 - public symbols  
         h:\symbols\ole32.pdb\683B65B246F4418796D2EE6D4C55EB112\ole32.pdb
.
DBGHELP: VERSION - public symbols  
         h:\symbols\version.pdb\180A90C40384463E82DDC45B2C8AB76E2\version.pdb
.
DBGHELP: msvcrt - public symbols  
         h:\symbols\msvcrt.pdb\A678F3C30DED426B839032B996987E381\msvcrt.pdb
.
DBGHELP: USER32 - public symbols  
         h:\symbols\user32.pdb\EE2B714D83A34C9D88027621272F83262\user32.pdb
.
DBGHELP: ADVAPI32 - public symbols  
         h:\symbols\advapi32.pdb\455D6C5F184D45BBB5C5F30F829751142\advapi32.pdb
.
DBGHELP: RPCRT4 - public symbols  
         h:\symbols\rpcrt4.pdb\BEA45A721DA141DAA3BA86B3A20311532\rpcrt4.pdb
.
DBGHELP: GDI32 - public symbols  
         h:\symbols\gdi32.pdb\C0EA66BE00A64BD7AEF79E443A91869C2\gdi32.pdb
.
DBGHELP: SHLWAPI - public symbols  
         h:\symbols\shlwapi.pdb\494A934F78DE4C69AB6369CB140A304E2\shlwapi.pdb
.
DBGHELP: MSVCR80 - private symbols & lines 
         h:\symbols\msvcr80.i386.pdb\0032F3038CEC44DE93524B831BA31D301\msvcr80.i386.pdb
.
DBGHELP: kernel32 - public symbols  
         h:\symbols\kernel32.pdb\FB334FB28FA34128BDE9229285BE4C2F2\kernel32.pdb
.
DBGHELP: ntdll - public symbols  
         h:\symbols\ntdll.pdb\36515FB5D04345E491F672FA2E2878C02\ntdll.pdb
.
DBGHELP: SHELL32 - public symbols  
         h:\symbols\shell32.pdb\6744E3D041704F519BD5D4D56E5388A72\shell32.pdb
(Reporter)

Comment 23

12 years ago
Ok, on my notebook it looks better. Is it this what you need?

ChildEBP RetAddr  
0012fdd8 7c91e89a ntdll!KiFastSystemCallRet
0012fddc 7c81cd96 ntdll!ZwTerminateProcess+0xc
0012fed8 7c81cdee kernel32!_ExitProcess+0x62
0012feec 78131720 kernel32!ExitProcess+0x14
0012fef4 781319ee MSVCR80!__crtExitProcess(int status = 2014517814)+0x14 [f:\rtm\vctools\crt_bld\self_x86\crt\src\crt0dat.c @ 683]
0012ff2c 78131a36 MSVCR80!doexit(int code = 0, int quick = 0, int retcaller = 0)+0xac [f:\rtm\vctools\crt_bld\self_x86\crt\src\crt0dat.c @ 596]
0012ff3c 00401201 MSVCR80!exit(int code = 2088857559)+0xd [f:\rtm\vctools\crt_bld\self_x86\crt\src\crt0dat.c @ 398]
0012ffc0 7c816fd7 firefox!__tmainCRTStartup(void)+0x155 [f:\rtm\vctools\crt_bld\self_x86\crt\src\crtexe.c @ 549]
0012fff0 00000000 kernel32!BaseProcessStart+0x23

Comment 24

12 years ago
yes and no. i don't know why you don't have symbols for nspr but you have symbols for firefox. the stack trace is very strange, it looks like a clean exit .
(Reporter)

Comment 25

12 years ago
I've now saved the first error messages after loading the programm on my notebook. Maybe the symbol files are not on mcsmurf's-Server?

0:000> .sympath SRV*http://www.mcsmurf.de/mozilla/ff-symbols/
Symbol search path is: SRV*http://www.mcsmurf.de/mozilla/ff-symbols/
0:000> .symfix+ c:\symbols
0:000> .reload /f
Reloading current modules
.*** WARNING: Unable to verify checksum for C:\fftest\firefox\xpcom_core.dll
.*** WARNING: Unable to verify checksum for C:\fftest\firefox\plc4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\fftest\firefox\plc4.dll - 
.*** WARNING: Unable to verify checksum for C:\fftest\firefox\plds4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\fftest\firefox\plds4.dll - 
.*** WARNING: Unable to verify checksum for C:\fftest\firefox\js3250.dll
..*** WARNING: Unable to verify checksum for C:\fftest\firefox\xul.dll
.*** WARNING: Unable to verify checksum for C:\fftest\firefox\nspr4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\fftest\firefox\nspr4.dll - 
................

 

(Reporter)

Comment 26

12 years ago
ChildEBP RetAddr  
037afe64 7c91e9c0 ntdll!KiFastSystemCallRet
037afe68 7c8025db ntdll!ZwWaitForSingleObject+0xc
037afecc 7c802542 kernel32!WaitForSingleObjectEx+0xa8
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\nspr4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\nspr4.dll - 
037afee0 300194cb kernel32!WaitForSingleObject+0x12
WARNING: Stack unwind information not available. Following frames may be wrong.
037afefc 30015589 nspr4!PR_MD_WAIT_CV+0x8b
037aff14 30015682 nspr4!PR_GetPrimordialCPU+0x79
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\components\necko.dll
037aff2c 00f8b853 nspr4!PR_WaitCondVar+0x22
037aff50 30015e4b necko!nsIOThreadPool::ThreadFunc(void * arg = 0x01b6c520)+0x4a [h:\mozilla\tree-main\mozilla\netwerk\base\src\nsiothreadpool.cpp @ 255]
037affac 78132a36 nspr4!PRP_TryLock+0x4cb
037affb4 7c80b50b MSVCR80!_threadstartex(void * ptd = 0x00000000)+0x66 [f:\rtm\vctools\crt_bld\self_x86\crt\src\threadex.c @ 326]
037affec 00000000 kernel32!BaseThreadStart+0x37

Comment 27

12 years ago
that looks better.

fwiw mcsmurf did some investigating. I think the conclusion was that only debug builds of nspr (and not symboled builds of gecko) result in symbol files that he can ship. iirc a similar problem applies for nss (actually iirc nss is worse).

Now that it looks like you have something useful. when it crashes, after you've done the sympath/reload sybmols, try:

!analyze -v -f

my guess from this stack trace is that the main thread managed to shut down before a network thread. or something fun like that. we'll see.
(Reporter)

Comment 28

12 years ago
ChildEBP RetAddr  
0013c9b0 7c91e89a ntdll!KiFastSystemCallRet
0013c9b4 7c801e36 ntdll!ZwTerminateProcess+0xc
0013c9c4 7813881b kernel32!TerminateProcess+0x20
0013cd00 781476d9 MSVCR80!_invoke_watson(wchar_t * pszExpression = 0x00000000 "", wchar_t * pszFunction = 0x00000000 "", wchar_t * pszFile = 0x00000000 "", unsigned int nLine = 0, unsigned int pReserved = 0)+0xe6 [f:\rtm\vctools\crt_bld\self_x86\crt\src\invarg.c @ 185]
0013cd54 7813400c MSVCR80!__loctotime64_t(int yr = 1601, int mo = 1, int dy = 1, int hr = 9, int mn = 52, int sc = 26, int dstflag = -1)+0x40 [f:\rtm\vctools\crt_bld\self_x86\crt\src\dtoxtm64.c @ 67]
0013cd90 7813422f MSVCR80!__time64_t_from_ft(struct _FILETIME * pft = 0x0013cdc0)+0x5a [f:\rtm\vctools\crt_bld\self_x86\crt\src\findf64.c @ 253]
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\freebl3.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\freebl3.dll - 
0013cef0 040d1bee MSVCR80!_findnext64i32(int hFile = 58079880, struct _finddata64i32_t * pfd = 0x0013cf24)+0xe7 [f:\rtm\vctools\crt_bld\self_x86\crt\src\findf64.c @ 189]
WARNING: Stack unwind information not available. Following frames may be wrong.
0013cf68 7c936abe freebl3!FREEBL_GetVector+0xbee
00160000 00000000 ntdll!RtlFreeHeapSlowly+0x5c2
0:000> !analyze -v -f
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

Event is not an exception

Failure could not be analyzed

Last event: 78c.630: Exit process 0:78c, code c000000d
  debugger time: Fri Aug 11 11:44:11.312 2006 (GMT+2)
(Reporter)

Comment 29

12 years ago
ChildEBP RetAddr  
02b6fe54 7c91e9c0 ntdll!KiFastSystemCallRet
02b6fe58 7c8025db ntdll!ZwWaitForSingleObject+0xc
02b6febc 7c802542 kernel32!WaitForSingleObjectEx+0xa8
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\nspr4.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\nspr4.dll - 
02b6fed0 300194cb kernel32!WaitForSingleObject+0x12
WARNING: Stack unwind information not available. Following frames may be wrong.
02b6feec 30015589 nspr4!PR_MD_WAIT_CV+0x8b
02b6ff04 30015682 nspr4!PR_GetPrimordialCPU+0x79
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox\components\strgcmps.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programme\fftest\firefox\components\strgcmps.dll - 
02b6ff1c 02a22f1a nspr4!PR_WaitCondVar+0x22
00000000 00000000 strgcmps!NSGetModule+0x1f15
0:009> !analyze -v -f
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

Event is not an exception

Failure could not be analyzed

Last event: b78.318: Exit process 0:b78, code c000000d

Comment 30

12 years ago
ok. comment 28 is a bug 331404, which i thought was fixed. you'll have to check w/ mcsmurf about the relative build date (do read that bug).

i wonder.

use windbg, file>open executable (or whatever), select cmd.exe (?)
tell it to debug spawned processes.

start.

run firefox from there.

ideally you should end up w/ windbg debugging a number of processes, maybe we'll get luckier?

also, when it says that it didn't crash, you can try:

!analyze -v -hang instead

but what's puzzling me is that it claims the app exited already... anyway, we'll see where this goes (my weekend starts *now*, i'll be back in 48-72hrs).
(Reporter)

Comment 31

12 years ago
(In reply to comment #30)
> use windbg, file>open executable (or whatever), select cmd.exe (?)
> tell it to debug spawned processes.

where do I tell to debug spawned processes? I only see "child processes", but this doesn't work.
He meant that, yeah (to be exactly it's "Debug child processes also"). I also uploaded a new build which has now NSPR and NSS symbols included.
(Reporter)

Comment 33

12 years ago
Ok, with the new build I now get the startup-crashes. Does this help more?

0:008> kp
ChildEBP RetAddr  
0252fcc0 7c91e9c0 ntdll!KiFastSystemCallRet
0252fcc4 7c8025cb ntdll!ZwWaitForSingleObject+0xc
0252fd28 7c802532 kernel32!WaitForSingleObjectEx+0xa8
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox2\nspr4.dll
0252fd3c 300194db kernel32!WaitForSingleObject+0x12
0252fd58 30015579 nspr4!_PR_MD_WAIT_CV(struct _MDCVar * cv = 0xffffffff, struct _MDLock * lock = 0x00000000, unsigned int timeout = 0)+0x8b [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\md\windows\w95cv.c @ 282]
0252fd70 30015672 nspr4!_PR_WaitCondVar(struct PRThread * thread = 0xffffffff, struct PRCondVar * cvar = 0x00000000, struct PRLock * lock = 0x01d3fbcc, unsigned int timeout = 0x300194db)+0x59 [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\threads\combined\prucv.c @ 205]
0252fd88 0049d5e9 nspr4!PR_WaitCondVar(struct PRCondVar * cvar = 0xffffffff, unsigned int timeout = 0)+0x22 [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\threads\combined\prucv.c @ 551]
0252fef0 0049d71c firefox!ProcessAsyncMessages(void)+0x45 [h:\mozilla\tree-main\mozilla\storage\src\mozstorageasyncio.cpp @ 1522]
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox2\xpcom_core.dll
0252fefc 002ae485 firefox!AsyncWriteThread::Run(void)+0x9 [h:\mozilla\tree-main\mozilla\storage\src\mozstorageasyncio.cpp @ 475]
0252ff1c 002857f7 xpcom_core!nsThread::ProcessNextEvent(int mayWait = 1, int * result = 0x0252ff38)+0x95 [h:\mozilla\tree-main\mozilla\xpcom\threads\nsthread.cpp @ 483]
0252ff30 002ae38e xpcom_core!NS_ProcessNextEvent_P(class nsIThread * thread = 0x00000001, int mayWait = 1)+0x27 [h:\mozilla\tree-main\mozilla\firefox-build2\xpcom\build\nsthreadutils.cpp @ 225]
0252ff50 30015e3b xpcom_core!nsThread::ThreadFunc(void * arg = 0x01d3fab0)+0x5c [h:\mozilla\tree-main\mozilla\xpcom\threads\nsthread.cpp @ 251]
0252ff6c 30017eed nspr4!_PR_NativeRunThread(void * arg = 0x78132a36)+0xdb [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\threads\combined\pruthr.c @ 458]
0252ff74 781329aa nspr4!pr_root(void * arg = 0x78132a36)+0xd [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\md\windows\w95thred.c @ 120]
0252ffac 78132a36 MSVCR80!_callthreadstartex(void)+0x1b [f:\rtm\vctools\crt_bld\self_x86\crt\src\threadex.c @ 348]
0252ffb4 7c80b683 MSVCR80!_threadstartex(void * ptd = 0x00000000)+0x66 [f:\rtm\vctools\crt_bld\self_x86\crt\src\threadex.c @ 326]
0252ffec 00000000 kernel32!BaseThreadStart+0x37

Comment 34

12 years ago
ok options:
1. .dump /ma /u something.dmp
and make something.dmp available

2. kv
   !analyze -v -f
   !locks -v
[that's (!ntsdexts.locks) extension]

probably next would be !critsec or !cs, but that's a bit more than i want to think about. there's actually tolerable online help for windbg, to use one of those two things you'll probably want view>locals and view>processes and threads and view>call stack
Assignee: nobody → vladimir
Component: Software Update → Storage
Product: Firefox → Toolkit
QA Contact: software.update → storage
[h:\mozilla\tree-main\mozilla\nsprpub\pr\src\threads\combined\prucv.c @ 205]
0252fd88 0049d5e9 nspr4!PR_WaitCondVar(struct PRCondVar * cvar = 0xffffffff,
unsigned int timeout = 0)+0x22
[h:\mozilla\tree-main\mozilla\nsprpub\pr\src\threads\combined\prucv.c @ 551]
0252fef0 0049d71c firefox!ProcessAsyncMessages(void)+0x45
[h:\mozilla\tree-main\mozilla\storage\src\mozstorageasyncio.cpp @ 1522]

If PR_WaitCondVar is being called with cvar of 0xffffffff, I'm not sure what's going on -- that variable is initialized to null, and is assigned using PR_NewCondVar, and the assignment is null checked.  So I've no idea where that -1 is coming from.

Comment 36

12 years ago
The value of the 'timeout' argument to PR_WaitCondVar is
also wrong.  It should be PR_INTERVAL_NO_TIMEOUT (0xffffffffUL).

Comment 37

12 years ago
please be wary of optimizers. if the sources say that a given value isn't going to happen, then there's probably an optimizer at work. if we get a dmp file, anyone w/ windbg can check locals for the calling frame to verify (or the asm).
(Reporter)

Comment 38

12 years ago
Another one and the dump-file is here: http://www.kohelet.at/fftest/fftrunk1_04C4_2006-08-15_18-39-55-828_149C.zip

0:010> kp
ChildEBP RetAddr  
034efe68 7c91e9c0 ntdll!KiFastSystemCallRet
034efe6c 7c8025cb ntdll!ZwWaitForSingleObject+0xc
034efed0 7c802532 kernel32!WaitForSingleObjectEx+0xa8
*** WARNING: Unable to verify checksum for D:\Programme\fftest\firefox2\nspr4.dll
034efee4 300194db kernel32!WaitForSingleObject+0x12
034eff00 30015579 nspr4!_PR_MD_WAIT_CV(struct _MDCVar * cv = 0xffffffff, struct _MDLock * lock = 0x00000000, unsigned int timeout = 0)+0x8b [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\md\windows\w95cv.c @ 282]
034eff18 30015672 nspr4!_PR_WaitCondVar(struct PRThread * thread = 0x244c8b00, struct PRCondVar * cvar = 0x08413904, struct PRLock * lock = 0xc8830474, unsigned int timeout = 0x41c7c3ff)+0x59 [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\threads\combined\prucv.c @ 205]
034eff30 008da5fa nspr4!PR_WaitCondVar(struct PRCondVar * cvar = 0x244c8b00, unsigned int timeout = 0x8413904)+0x22 [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\threads\combined\prucv.c @ 551]
034eff50 30015e3b firefox!nsCertVerificationThread::Run(void)+0x4a [h:\mozilla\tree-main\mozilla\security\manager\ssl\src\nscertverificationthread.cpp @ 142]
034eff6c 30017eed nspr4!_PR_NativeRunThread(void * arg = 0x78132a36)+0xdb [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\threads\combined\pruthr.c @ 458]
034eff74 781329aa nspr4!pr_root(void * arg = 0x78132a36)+0xd [h:\mozilla\tree-main\mozilla\nsprpub\pr\src\md\windows\w95thred.c @ 120]
034effac 78132a36 MSVCR80!_callthreadstartex(void)+0x1b [f:\rtm\vctools\crt_bld\self_x86\crt\src\threadex.c @ 348]
034effb4 7c80b683 MSVCR80!_threadstartex(void * ptd = 0x00000000)+0x66 [f:\rtm\vctools\crt_bld\self_x86\crt\src\threadex.c @ 326]
034effec 00000000 kernel32!BaseThreadStart+0x37
0:010> .dump /ma /u fftrunk1.dmp
Creating fftrunk1_04C4_2006-08-15_18-39-55-828_149C.dmp - mini user dump
Dump successfully written
(Reporter)

Comment 39

12 years ago
Created attachment 233832 [details]
result of !locks -v

(In reply to comment #34)
> 2. kv
>    !analyze -v -f
>    !locks -v

Comment 40

12 years ago
The stack trace in comment 38 also has incorrect argument values.
For example, the 'timeout' argument to PR_WaitCondVar, _PR_WaitCondVar, and _PR_MD_WAIT_CV is passed through unchanged, but the stack trace
shows that the value of 'timeout' changes from 0x8413904 to
0x41c7c3ff and finally to 0.

Comment 41

12 years ago
0:000> ~
.  0  Id: 149c.1384 Suspend: -1 Teb: 7ffaf000 Unfrozen

Ok. the problem is simple. the main thread and almost all the other threads quit. My guess is that autoupdate is being mean and not letting gecko spin down properly.

Note that the optimizer is what's causing the stack traces to be unhelpful.

Things are consistent enough if you check locals.

The reason it changes to 0 is because after
    DWORD msecs = (timeout == PR_INTERVAL_NO_TIMEOUT) ?
            INFINITE : PR_IntervalToMilliseconds(timeout);
timeout is not a used variable, and therefor its register can be borrowed.
current instruction is:
    rv = WaitForSingleObject(thred->md.blocked_sema, msecs);
and after that instruction, msecs is not used, so i can't really see it either.

similarly for the calling frame. As long as each thread that ends up here proves that it tries to listen for shutdown, this is a bug in the updater not gracefully spinning down gecko.
Assignee: vladimir → nobody
Component: Storage → Software Update
Product: Toolkit → Firefox
QA Contact: storage → software.update
This could be the same issue as bug 343988 as the auto update url is https.

Comment 43

12 years ago
*** Bug 352438 has been marked as a duplicate of this bug. ***

Comment 44

12 years ago
(In reply to comment #43)
> *** Bug 352438 has been marked as a duplicate of this bug. ***

I reported Bug 352438 - crashing on startup - and have done some extensive troubleshooting over the last few days trying to pinpoint where exactly the Start-Up Bug was introduced (as experienced on my computer, anyhow) and also how it differs from this Bug (on updates) and also Bug 343988 (on https access).

I have no idea what is 'wrong', but seem to have tracked at least part of it down to the introduction of/changes to anti-phishing.

I've made a few lengthy posts detailing my progress and musings over on Mozillazine, to avoid unnecessary Bug spam. But I think I may finally be on to something. Take a look: http://forums.mozillazine.org/viewtopic.php?p=2490261#2490261

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: msvcr80.dll crashes after trying to check for updates → crashes after trying to check for updates [@msvcr80.dll]
(Reporter)

Comment 45

12 years ago
I think it's not only a firefox problem. I have downloaded thunderbird from here: 
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-trunk/, which seems to be a VC8 build, while normal thunderbird trunks are build with VC6 (explained in: https://bugzilla.mozilla.org/show_bug.cgi?id=343053#c11).

And the VC8-thunderbird crashes with the same error as explained in this bug here.
Thunderbird is in the process of moving from VC6 (from patrocles) to VC8 (from tb-win32-tbox). The first VC8 nightly was today.
(In reply to comment #46)
> Thunderbird is in the process of moving from VC6 (from patrocles) to VC8 (from
> tb-win32-tbox). The first VC8 nightly was today.

Sorry, jumped the gun here. These two builds are VC6:
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2006-09-29-06-trunk/
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2006-09-30-06-trunk/

These are ones are VC8:
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2006-09-29-11-trunk/
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2006-09-30-03-trunk/

VC8 nightlies have been disabled for the moment.

Comment 48

12 years ago
Should this be a blocker? On on PC I'm unable to start latest nightly builds of Firefox and on the other it works just fine.
Keywords: crash

Comment 49

12 years ago
(In reply to comment #48)
> Should this be a blocker? On on PC I'm unable to start latest nightly builds of
> Firefox and on the other it works just fine.
> 

Latest trunk of Seamonkey won't install at all. This is 10/11/2006 trunk builds. The last one I had was 10/06/2006 trunk and that installed just fine, so it happened between then and now.
Possible...SeaMonkey Windows trunk builds now use VC8 instead of VC6.

Comment 51

12 years ago
found it: Bugzilla Bug 356462 SeaMonkey full installer does not run on > Windows XP anymore
(Reporter)

Comment 52

12 years ago
With todays build (/pub/mozilla.org/thunderbird/nightly/2006-10-28-03-trunk/thunderbird-3.0a1.en-US.win32.zip) thunderbird now also crashes with this bug.

Comment 53

12 years ago
I see this too. It's clear to me this is caused by the update of the anti-phishing list.

Deleting components\nsSafebrowsingApplication.js causes the browser to start up fine. Then it still crashes when loading any https URL (including simply 'https://').
(In reply to comment #53)
> I see this too. It's clear to me this is caused by the update of the
> anti-phishing list.
> 
> Deleting components\nsSafebrowsingApplication.js causes the browser to start up
> fine. Then it still crashes when loading any https URL (including simply
> 'https://').
> 
So, if you go to Tools->Options->Security and you uncheck

|Tell me if the site I'm visiting is a suspected forgery|

the problem goes away ?

Comment 55

12 years ago
(In reply to comment #54)
> So, if you go to Tools->Options->Security and you uncheck
> |Tell me if the site I'm visiting is a suspected forgery|
> the problem goes away ?

I can't tell - it crashes (at same address that it does when loading a https URL) when I click on the "Security" tab.

Can I disable it in about:config?
(In reply to comment #55)
> (In reply to comment #54)
> > So, if you go to Tools->Options->Security and you uncheck
> > |Tell me if the site I'm visiting is a suspected forgery|
> > the problem goes away ?
> 
> I can't tell - it crashes (at same address that it does when loading a https
> URL) when I click on the "Security" tab.
> 
> Can I disable it in about:config?
> 
set browser.safebrowsing.enabled to false to disable the feature

Comment 57

12 years ago
(In reply to comment #56)
> set browser.safebrowsing.enabled to false to disable the feature

Then no, setting it to false still crashes on https URLs and still crashes on startup if I restore nsSafebrowsingApplication.js.

Comment 58

12 years ago
I get the exact same problem. I can only run Minefield after removing nsSafebrowsingApplication.js.

Is the reason to this problem known yet? I may help with system specs that might possibly be related.

Comment 59

12 years ago
I am seeing a very similar bug being reported with Sunbird 0.3 (based off the trunk). The Sunbird bug either crashes on startup or when checking for updates, crashes at the same DLL address as this bug, and doesn't generate a talkback report. The Sunbird crash seems to have something to do with https access. Is this bug regarding a general crash when attempting https access? And should I use it to dupe this Sunbird behavior against?

The Sunbird bugs:357709, 357106, 359669 plus these, which have already been dupe'd or marked invalid: 358818, 358778
Upping severity, because this also affects Sunbird and probably other Toolkit apps.
Severity: critical → blocker

Updated

12 years ago
Flags: blocking-firefox3?

Updated

12 years ago
Blocks: 360892
Could someone who experiences this crash try setting the environment variable MOZ_AIRBAG=1 and running your browser with that?  I'd like to see if airbag can catch this exception.  If so, we should be able to get a stacktrace at some point.

Comment 62

12 years ago
I've set MOZ_AIRBAG to 1 as a system-wide environment variable (through System Properties) and tried using Help->Check for Updates. The browser just crashed exactly as before, as far as I can tell. Anything specific I should be looking for?

Using Windows XP SP2 Home, fully patched, with IE6.

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/2006110704 Minefield/3.0a1
(a reflow branch build)
Daniel: obviously you didn't get Crash Reporter showing up, or you would have noticed that.  Thanks.  This could be an uncatchable exception, as described here:
https://connect.microsoft.com/feedback/ViewFeedback.aspx?FeedbackID=101337&SiteID=210

Comment 64

12 years ago
(In reply to comment #63)
> Daniel: obviously you didn't get Crash Reporter showing up, or you would have
> noticed that.  Thanks.  This could be an uncatchable exception....

Sorry for the bugspam, but recent posts here seem indicate that we're going in circles here. The first 40 or so posts in this Bug document the debugging efforts as a result of no the crash not triggering a FF Talkback report or Windows exception that would be normally caught in DrWatson.

Posts 53 onwards are rehashing things discussed in Comment#44 and within the links it contains: Bug 352438 (which I'd filed and was marked a dupe of this Bug) and also the MozillaZine topic in which I discussed and (unsuccessfully) troubleshooted the issue with other users. In the forum thread it was suggested by 1 user to change some user_prefs to disable various automatic updates and security security settings - suspected of triggering the crash -- but all were disabled to no avail.

I'd also documented the exact builds/dates when the startup crash first appeared, and pinpointed the nsSafebrowsingApplications.js file and a codechange that seemed to be the culprit (as using the previous day's file allowed Minefield to start without crashing). And I also noted how having now started Minefield without crashing, it would crash on updates and secure websites.

We are unfortunately no further ahead in this Bug thread (months later).

We also seem to be no further ahead than we were in the forum thread about finding what is different from one machine that works to another similar one that does not. I think that is key if this is going to be resolved.
As long as no person with decent debugging knowledge can reproduce this problem here, it's difficult to fix the bug...
This bug is filed against the wrong component.  The issue here has little to do with either automatic update or anti-phishing expept that they both happen to use https.  The issue is that for people who experience this issue, and most people do not, any attempt to use https results in this crash.  This includes entering any https url in the location bar.  This bug belongs in core somewhere, rather than in Firefox, as bug 360892 is about the exact same issue in SeaMonkey.

This bug is actually a dupe of bug 343988 as far as I can tell.
*** Bug 343988 has been marked as a duplicate of this bug. ***
Component: Software Update → General
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: software.update → general
Flags: blocking1.9?
Summary: crashes after trying to check for updates [@msvcr80.dll] → crash when loading an https url (e.g. after trying to check for updates) [@msvcr80.dll]
Perhaps an NSS debug build would be helpful.
I deployed the MS VC++ 2005 redistribuable package on my machine and still experiment this with Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.9a1) Gecko/20061123 SeaMonkey/1.5a

Then it doesn't seem to be related to some depencencies not being included in the installation package.

Then why windows developpers can't reproduce this ? There are no windows developpers ? :-)

Comment 70

12 years ago
Doesn't happen to me. 
This really has to go before 1.9a1
Too many people can't test because of this
Target Milestone: --- → mozilla1.9alpha
oops, been commenting in the wrong bug, sorry for the bugspam
Target Milestone: mozilla1.9alpha → ---
trace from running within windbg (if this output can mean anything to anyone)
Scenario:
Startup
Choose the active selected profile
Go to a https url 
Crashes

CommandLine: "D:\Program Files\mozilla.org\SeaMonkey\seamonkey.exe"
Symbol search path is: D:\Program Files\Debugging Tools for Windows\w2kfre
Executable search path is: 
ModLoad: 00400000 00425000   seamonkey.exe
ModLoad: 78460000 784e2000   ntdll.dll
ModLoad: 61180000 611a9000   D:\Program Files\mozilla.org\SeaMonkey\nspr4.dll
ModLoad: 78ed0000 78f35000   C:\WINNT\system32\ADVAPI32.dll
ModLoad: 77e70000 77f2f000   C:\WINNT\system32\KERNEL32.dll
ModLoad: 770c0000 7712f000   C:\WINNT\system32\RPCRT4.dll
ModLoad: 74fd0000 74fd9000   C:\WINNT\system32\WSOCK32.dll
ModLoad: 74fb0000 74fc4000   C:\WINNT\system32\WS2_32.DLL
ModLoad: 78000000 78045000   C:\WINNT\system32\MSVCRT.DLL
ModLoad: 74fa0000 74fa8000   C:\WINNT\system32\WS2HELP.DLL
ModLoad: 77540000 77571000   C:\WINNT\system32\WINMM.dll
ModLoad: 77e00000 77e69000   C:\WINNT\system32\USER32.DLL
ModLoad: 77f40000 77f7c000   C:\WINNT\system32\GDI32.dll
ModLoad: 610a0000 6113b000   D:\Program Files\mozilla.org\SeaMonkey\MSVCR80.dll
ModLoad: 61250000 61258000   D:\Program Files\mozilla.org\SeaMonkey\plc4.dll
ModLoad: 7ce30000 7d07d000   C:\WINNT\system32\SHELL32.dll
ModLoad: 70a70000 70ad6000   C:\WINNT\system32\SHLWAPI.dll
ModLoad: 71710000 71794000   C:\WINNT\system32\COMCTL32.dll
(244.a24): Break instruction exception - code 80000003 (first chance)
eax=00000000 ebx=00131f04 ecx=00000009 edx=00000000 esi=7ffdf000 edi=00131f78
eip=7847193c esp=0012f984 ebp=0012fc98 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000202
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll - 
ntdll!DbgBreakPoint:
7847193c cc              int     3
0:000> g
ModLoad: 67f80000 67f87000   C:\WINNT\system32\serwvdrv.dll
ModLoad: 75960000 75967000   C:\WINNT\system32\mmdrv.dll
ModLoad: 61370000 61376000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\xpcom.dll
ModLoad: 61390000 613f3000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\xpcom_core.dll
ModLoad: 61260000 61267000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\plds4.dll
ModLoad: 7cd20000 7ce0f000   C:\WINNT\system32\ole32.dll
ModLoad: 77810000 77817000   C:\WINNT\system32\VERSION.dll
ModLoad: 75950000 75956000   C:\WINNT\system32\LZ32.DLL
ModLoad: 18800000 1882f000   C:\Program Files\UltraMon\RTSUltraMonHook.dll
ModLoad: 10000000 1000d000   C:\WINNT\System32\tabhook.dll
ModLoad: 72c60000 72cef000   C:\WINNT\system32\CLBCATQ.DLL
ModLoad: 779a0000 77a3b000   C:\WINNT\system32\OLEAUT32.dll
ModLoad: 60260000 60282000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\embedcomponents.dll
ModLoad: 60ef0000 60f62000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\js3250.dll
ModLoad: 777f0000 7780e000   C:\WINNT\system32\WINSPOOL.DRV
ModLoad: 79450000 79460000   C:\WINNT\system32\MPR.DLL
ModLoad: 76b00000 76b3e000   C:\WINNT\system32\comdlg32.dll
ModLoad: 60770000 60780000   D:\Program Files\mozilla.org\SeaMonkey\components\jsd3250.dll
ModLoad: 60dd0000 60e05000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\xpc3250.dll
ModLoad: 60980000 60990000   D:\Program Files\mozilla.org\SeaMonkey\components\msgMapi.dll
ModLoad: 60fd0000 61008000   D:\Program Files\mozilla.org\SeaMonkey\msgbsutl.dll
ModLoad: 61380000 61390000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\xpcom_compat.dll
ModLoad: 01260000 01266000   D:\Program Files\mozilla.org\SeaMonkey\components\qfaservices.dll
ModLoad: 01270000 01295000   D:\Program Files\mozilla.org\SeaMonkey\components\FULLSOFT.DLL
ModLoad: 60150000 60162000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\caps.dll
ModLoad: 609f0000 60a6d000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\necko.dll
ModLoad: 60fb0000 60fc1000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\mozz.dll
ModLoad: 60e70000 60e7e000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\xppref32.dll
ModLoad: 20b00000 20b45000   C:\WINNT\system32\imon.dll
ModLoad: 69a00000 69a1d000   C:\WINNT\system32\NTMARTA.DLL
ModLoad: 77940000 7796c000   C:\WINNT\system32\WLDAP32.dll
ModLoad: 750d0000 750e0000   C:\WINNT\system32\SAMLIB.dll
ModLoad: 77be0000 77bf1000   C:\WINNT\system32\NTDSAPI.dll
ModLoad: 77970000 77994000   C:\WINNT\system32\DNSAPI.DLL
ModLoad: 7ccc0000 7cd10000   C:\WINNT\system32\NETAPI32.DLL
ModLoad: 78fb0000 78fbf000   C:\WINNT\system32\Secur32.dll
ModLoad: 75140000 75146000   C:\WINNT\system32\NETRAP.dll
NOD32 protected [MSAFD Tcpip [TCP/IP]]NOD32 protected [MSAFD Tcpip [UDP/IP]]NOD32 protected [MSAFD Tcpip [RAW/IP]]NOD32 protected [RSVP UDP Service Provider]NOD32 protected [RSVP TCP Service Provider]ModLoad: 74f50000 74f6e000   C:\WINNT\system32\msafd.dll
ModLoad: 74f90000 74f97000   C:\WINNT\System32\wshtcpip.dll
ModLoad: 60660000 60686000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\i18n.dll
ModLoad: 77310000 77323000   C:\WINNT\system32\iphlpapi.dll
ModLoad: 774f0000 774f5000   C:\WINNT\system32\ICMP.dll
ModLoad: 772f0000 77307000   C:\WINNT\system32\MPRAPI.dll
ModLoad: 77380000 773b0000   C:\WINNT\system32\ACTIVEDS.DLL
ModLoad: 77350000 77373000   C:\WINNT\system32\ADSLDPC.DLL
ModLoad: 77820000 7782e000   C:\WINNT\system32\RTUTILS.DLL
ModLoad: 783c0000 78451000   C:\WINNT\system32\SETUPAPI.DLL
ModLoad: 78d20000 78d85000   C:\WINNT\system32\USERENV.DLL
ModLoad: 774b0000 774e4000   C:\WINNT\system32\RASAPI32.dll
ModLoad: 77490000 774a1000   C:\WINNT\system32\rasman.dll
ModLoad: 77500000 77522000   C:\WINNT\system32\TAPI32.dll
ModLoad: 77330000 77349000   C:\WINNT\system32\DHCPCSVC.DLL
ModLoad: 60bd0000 60bdd000   D:\Program Files\mozilla.org\SeaMonkey\components\suitetypeaheadfind.dll
ModLoad: 602c0000 605ad000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\gklayout.dll
ModLoad: 60ed0000 60ee1000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\gkgfx.dll
ModLoad: 61320000 61362000   D:\Program Files\mozilla.org\SeaMonkey\thebes.dll
ModLoad: 66410000 66464000   C:\WINNT\system32\USP10.dll
ModLoad: 61010000 61097000   D:\Program Files\mozilla.org\SeaMonkey\MSVCP80.dll
ModLoad: 606a0000 606c9000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\imglib2.dll
ModLoad: 60b20000 60b3b000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\rdf.dll
ModLoad: 60d80000 60d88000   D:\Program Files\mozilla.org\SeaMonkey\components\windowds.dll
ModLoad: 600e0000 600f1000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\appshell.dll
ModLoad: 600b0000 600d6000   D:\Program Files\mozilla.org\SeaMonkey\components\appcomps.dll
ModLoad: 60620000 60656000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\gkwidget.dll
ModLoad: 75e00000 75e1a000   C:\WINNT\system32\IMM32.dll
ModLoad: 60b10000 60b20000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\profile.dll
ModLoad: 60e20000 60e2b000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\xpcom_compat_c.dll
ModLoad: 60180000 60191000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\chrome.dll
ModLoad: 602a0000 602b1000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\gkgfxthebes.dll
ModLoad: 18900000 18903000   C:\Program Files\UltraMon\Resources\en\RTSUltraMonHookRes.dll
ModLoad: 601c0000 601f0000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\docshell.dll
ModLoad: 60a80000 60a8d000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\oji.dll
ModLoad: 60f70000 60f83000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\jsj3250.dll
ModLoad: 60ab0000 60ab9000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\pipboot.dll
ModLoad: 60d20000 60d2f000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\webbrwsr.dll
ModLoad: 60800000 60868000   D:\Program Files\mozilla.org\SeaMonkey\components\msgbase.dll
ModLoad: 60aa0000 60aa7000   D:\Program Files\mozilla.org\SeaMonkey\components\perms.dll
ModLoad: 601b0000 601ba000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\cookie.dll
ModLoad: 60c00000 60cbe000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\uconv.dll
ModLoad: 605b0000 605e6000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\gkparser.dll
ModLoad: 60760000 6076f000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\jar50.dll
ModLoad: 6b0e0000 6b0e5000   C:\WINNT\system32\msimg32.dll
ModLoad: 60b80000 60b89000   D:\Program Files\mozilla.org\SeaMonkey\components\sroaming.dll
ModLoad: 60170000 6017e000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\chardet.dll
ModLoad: 60130000 60146000   D:\Program Files\mozilla.org\SeaMonkey\components\bookmark.dll
ModLoad: 60bf0000 60bf8000   D:\Program Files\mozilla.org\SeaMonkey\components\txmgr.dll
ModLoad: 60940000 60975000   D:\Program Files\mozilla.org\SeaMonkey\components\msglocal.dll
ModLoad: 60750000 6075a000   D:\Program Files\mozilla.org\SeaMonkey\components\intlapp.dll
ModLoad: 60b60000 60b7b000   D:\Program Files\mozilla.org\SeaMonkey\components\srchsvc.dll
ModLoad: 601f0000 60257000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\editor.dll
ModLoad: 607c0000 607db000   D:\Program Files\mozilla.org\SeaMonkey\components\mork.dll
ModLoad: 60ac0000 60afc000   C:\Program Files\Fichiers communs\mozilla.org\GRE\1.9a1_2006112809\components\pipnss.dll
ModLoad: 61280000 6129c000   D:\Program Files\mozilla.org\SeaMonkey\smime3.dll
ModLoad: 611b0000 6120d000   D:\Program Files\mozilla.org\SeaMonkey\nss3.dll
ModLoad: 612a0000 612e9000   D:\Program Files\mozilla.org\SeaMonkey\softokn3.dll
ModLoad: 612f0000 61312000   D:\Program Files\mozilla.org\SeaMonkey\ssl3.dll
ModLoad: 60e90000 60ec2000   D:\Program Files\mozilla.org\SeaMonkey\freebl3.dll
ModLoad: 7ca00000 7ca23000   C:\WINNT\system32\rsaenh.dll
ModLoad: 79570000 795fd000   C:\WINNT\system32\CRYPT32.dll
ModLoad: 77400000 77411000   C:\WINNT\system32\MSASN1.dll
(244.a24): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=1890ffff ebx=1890000c ecx=18910006 edx=fffff000 esi=00001000 edi=1890ffff
eip=77e97e1a esp=0012d860 ebp=0012d890 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00010246
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\WINNT\system32\KERNEL32.dll - 
KERNEL32!IsBadReadPtr+0x4d:
77e97e1a 8a10            mov     dl,byte ptr [eax]          ds:0023:1890ffff=??
0:000> g
(244.a24): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=1890ffff ebx=1890000c ecx=18910006 edx=fffff000 esi=00001000 edi=1890ffff
eip=77e97e1a esp=0012d860 ebp=0012d890 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00010246
KERNEL32!IsBadReadPtr+0x4d:
77e97e1a 8a10            mov     dl,byte ptr [eax]          ds:0023:1890ffff=??
0:000> g
(244.a24): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=1890ffff ebx=1890000c ecx=18910006 edx=fffff000 esi=00001000 edi=1890ffff
eip=77e97e1a esp=0012d680 ebp=0012d6b0 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00010246
KERNEL32!IsBadReadPtr+0x4d:
77e97e1a 8a10            mov     dl,byte ptr [eax]          ds:0023:1890ffff=??
0:000> g
(244.a24): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=1890ffff ebx=1890000c ecx=18910006 edx=fffff000 esi=00001000 edi=1890ffff
eip=77e97e1a esp=0012d680 ebp=0012d6b0 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00010246
KERNEL32!IsBadReadPtr+0x4d:
77e97e1a 8a10            mov     dl,byte ptr [eax]          ds:0023:1890ffff=??
0:000> g
eax=00000005 ebx=610a4148 ecx=00000064 edx=00000000 esi=00000001 edi=00000000
eip=78468e77 esp=0012d500 ebp=0012d59c iopl=0         nv up ei ng nz na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000286
ntdll!NtTerminateProcess+0xb:
78468e77 c20800          ret     8
Would anyone here who experiences this problem like to try the tools over on bug 331404 and see if this is the same issue?  It's a crash on SSL initialization due to really old files in the windows system32 dir.  There's a findold.exe program attached that should show you if you would hit the problem.

Comment 76

12 years ago
hrm, when you get to the access violation, you should do:

!analyze -v -f
Created attachment 247066 [details]
windbg trace on win 2000 on startup + https opening

My symbols doesn't seem to be exactly up to date, couldn't find the right ones.

Yes I'm a weak windows debugger :-)

Comment 78

12 years ago
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

.symfix+ c:\symbols
.reload /f

would deal w/ that warning

but this stack is perfectly fine for investigating (i don't need a new one)
Timeless

I'm trying to make it better, thanks for your patience :-)
see Attachment 247066 [details]  
However the symbols I could find don't exactly match my system patch level...

Note that an exception also occurs during startup, before any URL opening

(thanks)
the trace was done with seamonkey trunk built on november 28th
Blocks: 357106
(In reply to comment #79)
> Timeless
> 
> I'm trying to make it better, thanks for your patience :-)
> see Attachment 247066 [details] [edit]  
> However the symbols I could find don't exactly match my system patch level...
> 
> Note that an exception also occurs during startup, before any URL opening
> 
> (thanks)
> 

That is because on startup, Firefox makes an https connection to google to get the updates to the known phishing sites list.

Comment 82

12 years ago
(In reply to comment #75)
> Would anyone here who experiences this problem like to try the tools over on
> bug 331404 and see if this is the same issue?  It's a crash on SSL
> initialization due to really old files in the windows system32 dir.  There's a
> findold.exe program attached that should show you if you would hit the problem.

Yes, it did solve for me!

C:\WINDOWS\system32\iacenc.dll has invalid Create time: 1774-08-29 13:22:31 UTC
C:\WINDOWS\system32\iacenc.dll has invalid Write  time: 1774-08-29 13:22:31 UTC
C:\WINDOWS\system32\iyvu9_32.dll has invalid Create time: 1774-08-29 13:22:31 UTC
C:\WINDOWS\system32\iyvu9_32.dll has invalid Write  time: 1774-08-29 13:22:31 UTC

Just touching the files did not seem to solve the problem, though; I've deleted and then recreated them, to force resetting the creation time, and right now I'm writing from a Minefield build through HTTPS :)

*** This bug has been marked as a duplicate of 331404 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
No longer blocks: 357106
No longer blocks: 360892
OK, it solved the problem for me also, 
C:\WINNT>findold
C:\WINNT\system32\MFC30.DLL    has invalid Write  time: 1601-01-01 07:52:26 UTC
C:\WINNT\system32\MYODBC.DLL   has invalid Write  time: 1601-01-01 07:52:26 UTC

BUT
the other bug is supposed to be fixed in which builds ?
It doesn't seem to be checked in the code used to build current trunk builds of SeaMonkey, since it still crashes

Additionally, I still see errors when running with the debugger, see new attachment
Created attachment 247078 [details]
windbg trace after removing old files still some issues
bug 331404 is fixed on NSS trunk, which is not what you get when you build an application from trunk, so the fix isn't in nightly builds yet.
Flags: blocking1.9? → blocking1.9+
(Assignee)

Updated

7 years ago
Crash Signature: [@msvcr80.dll]
You need to log in before you can comment on or make changes to this bug.