When using OCSP "Error establishing an encrypted connection to 102.112.2o7.net. Error Code: -5990."

RESOLVED DUPLICATE of bug 363452

Status

NSS
Libraries
--
major
RESOLVED DUPLICATE of bug 363452
12 years ago
12 years ago

People

(Reporter: Ulrich Windl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20060911 SUSE/1.0.6-0.1 SeaMonkey/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20060911 SUSE/1.0.6-0.1 SeaMonkey/1.0.6

A few days ago, seamonkey is very slow when connecting to https sites like eBay signin. After some waiting time a popup windows appears containing messages like Error establishing an encrypted connection to 102.112.2o7.net. Error Code: -5990."

Reproducible: Always

Steps to Reproduce:
1. Try https://signin.ebay.de/

Actual Results:  
"Error establishing an encrypted connection to signin.ebay.de. Error Code: -5990."
"The operation timed out when attempting to contact signin.ebay.de."

Expected Results:  
A sucessful connection, or a useful error message.
When viewing CA certificates, expired certificates should be marked in some way (red color maybe)

Turning off OCSP validation of certificates makes the problem go away.
(Reporter)

Comment 1

12 years ago
Created attachment 247956 [details]
Screen shot of the popup window (PNG, 16 color indexed)

Updated

12 years ago
Assignee: dveditz → nobody
Component: Security → Libraries
Product: Mozilla Application Suite → NSS
QA Contact: seamonkey → libraries
Another bug citing a negative decimal error code.

http://landfill.mozilla.org/mxr-test/nspr/source/pr/include/prerr.h#77
  77 /* I/O operation timed out */
  78 #define PR_IO_TIMEOUT_ERROR                      (-5990L)



*** This bug has been marked as a duplicate of 363452 ***
Blocks: 107491
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

12 years ago
This bug had been reported as a duplicate of bug 363452, but that master report deals with a timeout issue for some verisign server. As the server seems to be responding again (says the master report), I'm afraid that bug will be closed soon without further action. However I think the error message should be improved at least.
You need to log in before you can comment on or make changes to this bug.