Closed Bug 363512 Opened 16 years ago Closed 16 years ago

remove base-64 encoding functions in favor of built-ins

Categories

(Firefox :: Search, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 3 alpha2

People

(Reporter: Gavin, Assigned: asaf)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 326854 is adding the DOM-standard btoa/atob functions to JS components' global objects, so we can just use those directly instead of our (slower) JS implementation.
*** Bug 364514 has been marked as a duplicate of this bug. ***
Assignee: nobody → mano
Target Milestone: --- → Firefox 3 alpha2
Attached patch patch (obsolete) — Splinter Review
Attachment #249280 - Flags: review?(gavin.sharp)
Comment on attachment 249280 [details] [diff] [review]
patch

bah
Attachment #249280 - Attachment is obsolete: true
Attachment #249280 - Flags: review?(gavin.sharp)
Attached patch patchSplinter Review
Attachment #249281 - Flags: review?(gavin.sharp)
Status: NEW → ASSIGNED
Priority: -- → P3
Attachment #249281 - Flags: review?(gavin.sharp) → review+
mozilla/browser/components/feeds/src/FeedWriter.js 1.32
mozilla/browser/components/search/nsSearchService.js 1.93
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Depends on: 412990
You need to log in before you can comment on or make changes to this bug.