Insert Image from local hard drive doesn't work

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Peter Reynolds, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

Inserting an image (inline image) from the local hard drive using the Insert Image function doesn't work for me.  When trying to send I just get a continuous "attaching" message which never stops, or the message is sent without any images.

I can insert an image from an Internet URL.

There are loads of discussions of this on Mozillazine forums, e.g.
http://forums.mozillazine.org/viewtopic.php?t=455863
but none refer to a Bugzilla bug or give a solution.

I am using Thunderbird 3 Alpha 1 (trunk nightly) for Windows XP, but have experienced the same problem whatever version of Thunderbird I have used in the past.  So much so that I usually put pics somewhere on the net then insert then inline from there.

Reproducible: Always

Comment 1

12 years ago
wfm

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a1) Gecko/20061215 Thunderbird/3.0a1 ID:2006121503
(Reporter)

Comment 2

12 years ago
Here is a list of other threads that cover this problem, none of them with useful answers IMHO:

http://forums.mozillazine.org/viewtopic.php?t=497650
http://forums.mozillazine.org/viewtopic.php?t=494963
http://forums.mozillazine.org/viewtopic.php?t=451987
http://forums.mozillazine.org/viewtopic.php?t=463368

It has also been discussed on
news://news.mozilla.org:119/mozilla.test.multimedia
in October 2006 (the thread does not appear on Google Groups for some reason)

Comment 3

12 years ago
This has been a bug for as long as I have been using Thunderbird (about a year now) and was even a bug in Netscape prior to this. I always take the easy way out and attach the image, but sometimes the email would make more sense if it were inline with it.

Even more strange...
I just tested inserting images and it worked fine, with replying or new messages, but when I actually want to do that, it doesn't work, so the email message itself seems to be having an effect on it.

Comment 4

12 years ago
I think this is a dupe of bug 319818.
(Reporter)

Comment 5

12 years ago
Mike

Ok yes I think you are right, but will PM the other 13 people who reported the problem on Mozillazine, just to make sure.

I just sent a message with two images.  I had an interruption half way through composing - baby fell off bed :( - and when I cam back to put in the second image and accompanying text the image didn't display in the message (unlike the first image).  However I went ahead and sent the message without reference to Drafts, and the message arrived with both images.

Thanks for your help on this and sorry for posting a new bug, but this certainly needs fixing.

Peter
(Reporter)

Comment 6

12 years ago
At bug 319818 people are suggesting all kinds of technical workarounds.  Those should not be necessary.  People should be able to put images in a new message, see them display, save a draft, go back to it, add text, and send the message.

At present added images display erratically, causing people to Save, check the Drafts folder to see whether the images have in fact appeared, and then edit the draft.  Using the draft causes the "attaching" problem.

I'm not convinced that all images actually get sent, even if you don't do any saving and re-editing.  I'm pretty sure I have sent messages directly in the past (without using Drafts) and the images have not arrived. Sometimes I've done it several times over, before putting an image on the internet and taking it from there instead (that always works); or sending an attachment (that always works too).

Best wishes

Peter

Comment 7

12 years ago
I've just solved the problem I was having with a similar issue based on the advice in this post:
http://forums.mozillazine.org/viewtopic.php?p=2622611&sid=461495a4fdde1a6763283068ab863e9c

Briefly, try this:
(1) Add your own email address to your address book.
(2) In the entry for your name, click the box "Allow remote images in HTML mail".
(3) Close and reopen TB. 
(4) Don't hate me if it doesn't work.

By the way, in my experience, the images were always sent. The problem was that I was only getting the image holder (red dot) in my compose window.

Comment 8

12 years ago
from my standpoint it's NOT a dup. If the view is that they are both image issues and therefore related ok, biut not a dup. Alos my issue happens on OS X

Comment 9

12 years ago
The problem of hanging with "attaching" is the dupe.

The problem of the "red dot appears in compose window" is bug 343933.

*** This bug has been marked as a duplicate of 319818 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

12 years ago
I'm reopening this because some people are definitely finding that, on occasions, images don't send, when they have not saved to Drafts or edited from Drafts.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 11

12 years ago
Further reason why this is not a duplicate - the "attaching" problem stops you sending completely.  This problem allows you to send a message but the images are, on occasions, not received, even if visible in the message before sending.

Comment 12

12 years ago
I don't think it's at all reasonable for you to maintain a bug that was opened for your symptom -- which, you said, was the same as the bug I duped it to -- based on reports from "other people."  The rule is: one bug per issue, one issue per bug.


(In reply to comment #11)
> Further reason why this is not a duplicate - the "attaching" problem stops
> you sending completely.  

That is merely a further reason for me to believe you can't read, as the "cannot send" symptom is explicitly stated at the bug to which I duped this.

Don't expect to see more action on this.
(Reporter)

Comment 13

12 years ago
No, you're misreading what I'm saying:

I'm saying there are two bugs (when I started this bug I didn't know about bug 319818 - and nor did any of the 13 other people who were discussing this on various threads at Mozillazine):

1) Bug 319818: the "attaching" bug which stops one sending the message completely
2) Bug 363990: 
* part solved by 319818 (but how do I deal with this)
* part solved for some people perhaps by the "Allow remote images in HTML
mail" - but I don't see any difference - my first inline image displays, the second one has a red dot and square
BUT
* part unsolved in that some messages 
(a) have red dot and square (not bug 319818 which stops sending completely)
(b) in some cases allow sending (which bug 319818 does not) but do not send the picture (whether displayed or not)
* and then there is the issue of whether the image comes from the hard drive or from the internet - if the image comes from the net it displays and sends just fine, and I think you can edit around it in drafts too

OK I've perhaps done this badly - in saying that Inline images is broken and mixing up various bugs.  I've patiently ignored the problem for a year or more, assuming that a new version would at some time bring a solution.  Maybe we'll just close this down and let 319818 get fixed (when will that be?) - but surely inserting inline images from a hard drive is a major thing that ordinary people do with email, and all the issues that are stopping people doing this smoothly in Thunderbird should be solved.  Someone told me they had left Thunderbird and Firefox because of issues like these.

I also find it interesting that you Mike did exactly the same thing on bug 319818 (decide it was a dupe of something else and then change your mind).

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.