Email address lookup fails if case difference between "to:" field and address book entry domains

RESOLVED DUPLICATE of bug 129393

Status

RESOLVED DUPLICATE of bug 129393
12 years ago
9 years ago

People

(Reporter: mjnomaps, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.13) Gecko/20060414
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.13) Gecko/20060414  Thunderbird 1.5.0.8 (20061025)

Email address lookup is case sensitive. If you have an entry in your address book such as NotMe@nowhere.com, and reply to email or compose new email to notme@nowhere.com, Thunderbird will not find the entry.

Reproducible: Always

Steps to Reproduce:
1.  Add a new email address to your address book, such as NotMe@nowhere.com and specify "Prefers to receive messages formatted as:" --> HTML
2.  Compose new email to notme@nowhere.com.  Notice the address appears in red, as if TB doesn't know about the name.  Compose the mail using html, such as italics.
3.  Click send.  

Actual Results:  
Name not found, so Thunderbird will ask to send it as plain text, even though you specified "prefers html".  Also fails if domain has case difference.

Expected Results:  
email address  should be found in address book regardless of case.

See RFC 2821
Well, RFC 2821 clearly says "The local-part of a mailbox MUST BE treated as case sensitive". (Though rfc 2822 may be more appropriate here.)





*** This bug has been marked as a duplicate of 129393 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Well, RFC 2821 clearly says "The local-part of a mailbox MUST BE treated as
> case sensitive". (Though rfc 2822 may be more appropriate here.)

Yes, that's true.  But it also says "Mailbox domains are not case sensitive." 
Yet the Thunderbird address book treats DOMAINS as case sensitive.  I guess my prior example wasn't a good choice.  

So let me try again:  If you have an extant address such as notme@nowhere.com, and compose mail to notme@NOWHERE.COM, or notme@Nowhere.com, the lookup will fail due to case sensitive matching on the domain.   

 

Summary: Email address lookup fails if case difference between "to:" field and address book entry → Email address lookup fails if case difference between "to:" field and address book entry domains
Can you try 2.0 beta 1? I tried adding me@UPPERDOMAIN to the address book. When filling in address me@upperdomain in to field it autocompletes to me@UPPERDOMAIN. Using todays 2.0 nightly build.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Can you try 2.0 beta 1? I tried adding me@UPPERDOMAIN to the address book. When
> filling in address me@upperdomain in to field it autocompletes to
> me@UPPERDOMAIN. Using todays 2.0 nightly build.

I installed Version 2 beta 1 (20061206), which may be a slightly older version than the one you tried.  

If I create a name 'nobody@Nowhere.Com' and specify 'prefers html' and address a new message to 'nobody@nowhere.com', it will try to autocomplete to the address book entry.  But if I fully specify the address ('nobody@nowhere.com'), Thunderbird will present the format choice dialog (html vs text), which I infer to mean that it doesn't know about the addressee.   It also fails due to domain case mis-match if the case of the domain is the reverse; e.g. address book entry 'notme@nothere.com' with addressee of 'notme@NotHere.com'.   

So this bug seems to be still alive and kicking in V2beta1.

To the best of my knowledge this bug still exists in the main code.  To get it
fixed please go to bug 129393 and click the vote button to raise its level of importance.
You need to log in before you can comment on or make changes to this bug.