All users were logged out of Bugzilla on October 13th, 2018

Java applets do not load

VERIFIED WORKSFORME

Status

P3
blocker
VERIFIED WORKSFORME
19 years ago
8 years ago

People

(Reporter: shrir, Assigned: edburns)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

(Reporter)

Description

19 years ago
Java is not working on today's windows build (2000041909m16). I used a custom 
install and selected "Sun Java" to be sure.
The above page does not load the applet on top right.

Updated

19 years ago
Summary: Java applets do not load → Java applets do not load

Comment 1

19 years ago
This must be related to mac java not working, no? I find it *highly* improbable
that two individual java problems appeared on the same day on different
platforms. I believe this is somewhere in the glue mozilla has to the jvms.
h'm, methinks this is different from bug 36381, where it actually *crashed* on
Mac. here, the applets are simply not loading (winNT and linux).
(Reporter)

Comment 3

19 years ago
Linux...I don't think java support is in there yet.
heh, that would explain it... :-)

Comment 5

19 years ago
Add nsbeta2 keyword
Whiteboard: nsbeta2

Comment 6

19 years ago
*** Bug 37077 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
adding myself to the cc list

Comment 8

19 years ago
Adding myself to cc. Under Windows98, Java install never completes.
That is also part of the problem. 

Comment 9

19 years ago
I'll re-assign this bug to Ed Burns, but he is away on other business until May
16.  Under the circumstances, I'd say it's doubtful we'll be able to do anything 
about this for M16.  If this turns out to be the result of yet another API 
change that came without notification, I'll be unhappy.
If anybody out there can list exactly what changes were made between yesterday 
and today, that would be helpful to this bug's diagnosis (assuming that Java 
worked in yesterday's build).
Assignee: drapeau → edburns

Comment 10

19 years ago
Uh, a clarification on my last comment: by "yesterday" I meant "the day before 
this bug was filed, i.e., 4/18/2000," by "today" I meant "the day this bug was 
filed, i.e., 4/19/2000."

Comment 11

19 years ago
Moving nsbeta2 nomination from Status Summary to Keywords field.  This is where 
the nomination belongs.  NOT Status Summary...my query won't pick it up that 
way.
Keywords: nsbeta2
Whiteboard: nsbeta2
(Reporter)

Comment 12

19 years ago
I did some search and found that there were some checkins done by Ed Burns on 
04/18 around 14:58 to the '/mozilla/java/webclient/' directory related to bug 
32011. Am not sure about whether these checkins made the difference or not but 
felt like this might help.
(Reporter)

Comment 13

19 years ago
Latest update: I tried the following and applets run on today's windows 
(2000051108)
1. Install seamonkey without 'java' selected
2. Then manually installed just the 'jre131.exe' from the "xpi" folder
3. Note thatI did not install the jre patch file at all.
4. Loaded the java.sun.com page and could see applets load fine.

Does this mean that we do not have to install the patch for the jre at all?
As far as I know there was no notification for this. I can still see the patch 
file 'jre13patch.zip' in the xpi folder. Am not closing this bug since this 
needs details from edburns. Thnx.

Am not closing this bug,

Comment 14

19 years ago
Added ssu@netscape.com to cc list

Comment 15

19 years ago
For those people using PR1, the patch is needed. 
When I tried shrir's suggestion, my Beta 1 Java stopped functioning.
For those peopl e using both Beta 1 (for stability) and current builds on the
same Windows system, it isnecessary to swicth between the patched version
and the non-patched version. Right now, I just copy the patch files into the JRE's
bin an dlib directories and use the npjava*.dlls from the patched version for Beta 1
and the non-ptached npjava*.dlls for current M16 builds. 

Ed made a number of checkins before he went on vacation. Is this the way he envisioned his
changes to work? Or the fixes are not still complete?

Comment 16

19 years ago
We'll discuss this issue at tomorrow's (Tuesday's) OJI engineering meeting.  If
you're interested in calling in, please send email to drapeau@eng.sun.com
(that's me) and I can give you the dial-in number.
(Assignee)

Comment 17

19 years ago
The changes I made, in the java/webclient directory, are not related to OJI in
any way.  The OJI people haven't made any checkins in a very long time, so I
don't think it's us who broke this.  I will investigate, but not until next
Monday, 22 May 2000.
Status: NEW → ASSIGNED
Agree that Java broken-->nsbeta2. Java on b2 list. 
(Reporter)

Comment 19

19 years ago
Note(Reminder): After this bug is fixed, will retest bug 27077(resolved/fixed 
for now) as part of verification process to catch any regressions.

Comment 20

19 years ago
Are there any improvements on the way regarding this bug? Today's build
is still not getting applets to work.

Comment 21

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Assignee)

Comment 22

19 years ago
Tried this on bug 24487, it works.  Marking worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 23

19 years ago
I used the yesterday's win-installer version, still applet areas are coming up 
empty, and java console shows no indication that applets are loading. I used 
Beta1's java dlls to be sure. edburns@acm.org, which build have you used to get 
java.sun.com to work?? and this bug is totally different from bug 24487. There 
is no crash involved here; applets just dont load up.
(Assignee)

Comment 24

19 years ago
Dear Bora,  Please See George Drapeau's 05/27/00 comments on bug

http://bugzilla.mozilla.org/show_bug.cgi?id=32105

George explains why you can't get access to a working java plugin right now.
(Reporter)

Comment 25

19 years ago
Verified that this is working with today's windows build again (with the new 
installer and patch for jre checked-in). Build used: 2000053108
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.