Last Comment Bug 365113 - wrong location of send and draft folder in local folders
: wrong location of send and draft folder in local folders
Status: RESOLVED FIXED
: fixed1.8.1.1
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: David :Bienvenu
:
:
Mentors:
Depends on:
Blocks: 197228
  Show dependency treegraph
 
Reported: 2006-12-27 04:59 PST by tonda kavalec
Modified: 2007-01-10 13:51 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (2.74 KB, patch)
2006-12-28 12:30 PST, David :Bienvenu
mscott: superreview+
Details | Diff | Splinter Review
prefs.js (4.18 KB, text/plain)
2007-01-02 12:02 PST, tonda kavalec
no flags Details

Description tonda kavalec 2006-12-27 04:59:33 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20061224 SeaMonkey/1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20061224 SeaMonkey/1.1

In new profile, create first email-account and send an email. The copy will be saved into local folders > Send instead of account_name@domain.xxx > Send

The change is not possible: after changing settings and restart, it happend nothing.



Reproducible: Always

Steps to Reproduce:
1. create first email-account
2. send an email

Actual Results:  
Copy of sent email apears in Local Folders > Sent

Expected Results:  
Copy of sent email apears in account_name@domain.xxx > Send
Comment 1 tonda kavalec 2006-12-27 05:01:25 PST
"In a new profile, default location of sent and draft folders is in local folders by default, and can't be changed"
Comment 2 tonda kavalec 2006-12-27 12:58:40 PST
This regressed on the 1.8 branch between 2006112800 and 2006112901.
Comment 3 David :Bienvenu 2006-12-27 13:05:08 PST
yes, this was caused by the fix for bug 197228 - unless I can fix this some other way, I'll probably have to back out that change.
Comment 4 David :Bienvenu 2006-12-27 13:49:33 PST
hmm, I had the change not sticking problem once, but after that I couldn't recreate it...I was able to reproduce the wrong default, however.
Comment 5 David :Bienvenu 2006-12-28 12:30:48 PST
Created attachment 249881 [details] [diff] [review]
proposed fix

Treat all servers like imap, where we allow deferred creation of special folders.

Later, I can get rid of needToBuildSpecialFolderURIs, at least on the trunk. I'll do that separately.
Comment 6 David :Bienvenu 2006-12-28 13:54:18 PST
fixed on trunk and 1.8.1 branch.
Comment 7 tonda kavalec 2006-12-29 15:53:52 PST
does not work for me.

build: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20061229 SeaMonkey/1.1

ofcourse clear profile!
Comment 8 tonda kavalec 2007-01-02 09:29:27 PST
David, I have tried to validate you fix in TB2.0b1pre from: http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/thunderbird-2.0b1pre.en-US.win32.installer.exe

Result: The bug is present! After! sending an email apears "Sent" in Local Folders > Sent

Does not work! 
Comment 9 David :Bienvenu 2007-01-02 09:32:21 PST
Unfortunately, this works on all builds on all machines that I can try, so I'm unable to reproduce the problem anymore. Can anyone else verify that the problem is fixed, or still exists?
Comment 10 tonda kavalec 2007-01-02 09:36:23 PST
And second the Folder "Sent" apears only if you send a message.
Comment 11 David :Bienvenu 2007-01-02 09:38:50 PST
> And second the Folder "Sent" apears only if you send a message.

that's the desired behavior. We create it on demand. I don't understand why it's getting created for you when you send a message if you're unable to set the account to use that Sent folder.
Comment 12 Mike Cowperthwaite 2007-01-02 10:46:23 PST
It's not clear from comment 8 & 10 whether the 'sent' folder is being created under Local Folders or the account.

I opened a new profile and created a POP account (not deferred) with 2b1-1223 (before the patch); only the Inbox and Trash folders were created.  In Account Settings | Copies & Folders, for the account, the three settable folders were all shown as:  (*) "xxxx" folder on : Local Folders

I closed the program, installed and started 2b1-0102.  Account Settings of the existing account read the same.  But when I created a second account, the Copies & Folders settings on the new account were
  (*) "xxxx" folder on : <account>

With the new version, the account created on the previous version continued to show "on: Local Folders" but that setting was created at the account creation time and stored in prefs.js, right?  So no reason to expect it to be different.

But with either the older or newer version, it's possible to manually set the folder to be under the account, rather than under Local Settings; the bug here, as far as I can tell, is about the initial settings, in a new account, for the three folders.  That's working as expected for me, with the latest patch.

For each folder, the alternate folder-picker, which allows you to specify any folder, only shows existing folders.
Comment 13 David :Bienvenu 2007-01-02 10:51:09 PST
Thx, Mike - that's the behavior I would expect.
Comment 14 tonda kavalec 2007-01-02 12:02:19 PST
Created attachment 250195 [details]
prefs.js

Sorry I do not understand enought English for such discussions. 

I created an accoung tonda.kc@centrum.cz in a new profile, nothing else. Please check the pfefs.js file. If it correspond to that, especially the location of Sent a Drafts.
Comment 15 David :Bienvenu 2007-01-02 12:07:09 PST
those prefs look correct - it looks like they put sent mail in the sent folder of the new account.
Comment 16 tonda kavalec 2007-01-02 12:17:33 PST
So what can I do? I tested a lot of builds -  branch 1.1 and 1.5 and did not notice any bugs, because I did not created new accaunts in a new profile but used the old ones.

Comment 17 tonda kavalec 2007-01-02 12:22:09 PST
David, I used that bad profile with wrong located folders on the SM2006.11.28 and the folders appered correct! And then I changed to the 2007. 1.1 again and the folders are correct located! Woaw! 

I hope you can understand this terrible English.
Comment 18 David :Bienvenu 2007-01-02 12:27:38 PST
I think I understand what you're saying, but I don't know why it would behave that way. 

I guess we'll see if other people have problems...
Comment 19 Michael Wolf 2007-01-04 01:45:24 PST
I think I know the reason for your issue. In the Account Wizard of SM 1.1 the option "Global Inbox (Local folders account)" is unchecked by default now. Seems that most people wanted to have their mail in the account folder and not in the local folders. Until SM 1.1b the Global Inbox option was checked by default and the users had to change the setting later.
Comment 20 tonda kavalec 2007-01-04 06:23:32 PST
Hi Wolf, you are right, but my setting was/is correct. The checkbox apear unchecked! What shoul I do please? I have never used global ingox. The desizion was correct - unchecked = default
Comment 21 tonda kavalec 2007-01-06 17:53:43 PST
Correct behavior on: 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070106 SeaMonkey/1.5a
Comment 22 Magnus Melin 2007-01-09 10:40:38 PST
tonda: are you saying this works fine for you now on trunk? Latest sm 1.1 too?
Comment 23 tonda kavalec 2007-01-09 10:47:49 PST
margus: yes
Comment 24 Mike Cowperthwaite 2007-01-09 10:52:29 PST
Before this gets WFM'd, I want to follow up on comment 12.  I've been running with my identities all pointing to Local Folders/Templates.  I've had to run TB 1.5 a couple of times, and when I did, the Templates folders under the accounts were all re-created.  Then when running 2b1 or 3a1 versions afterwards, those new folders still appear "special" -- have the templates-folder icon, and can't be deleted or renamed -- despite the fact that no identity has those folders in use.
Comment 25 David :Bienvenu 2007-01-10 13:16:32 PST
Hi Mike, point taken, but that's a slightly different issue - this bug is simply about not creating those folders by default...
Comment 26 Mike Cowperthwaite 2007-01-10 13:51:59 PST
You're right; I opened bug 366609 for the issue in comment 24.

Note You need to log in before you can comment on or make changes to this bug.