don't show users in the cc list in the ccable list

REOPENED
Unassigned

Status

()

Bugzilla
Creating/Changing Bugs
REOPENED
11 years ago
4 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
precondition:
vist a bugzilla that's misconfigured to use the cc chooser instead of the input field or completion widget

steps:
1. file a bug and cc yourself to it
2. load the bug and try to select yourself in the ccable list (this is the list of everyone you can add to the cc list)

expected results:
you shouldn't be in the list because you're already on the cc list.

actual results:
you can select yourself even though it's absolutely pointless.

The real goal is to remind yourself that the person you're looking for is already cc'd.
(Reporter)

Comment 1

11 years ago
Created attachment 250020 [details] [diff] [review]
wastefully learn about already cc'd to avoid listing them
Assignee: create-and-change → timeless
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #250020 - Flags: review?

Comment 2

11 years ago
Please resubmit this patch on bug 303643.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 303643

Updated

11 years ago
Attachment #250020 - Flags: review?
(Reporter)

Comment 3

11 years ago
no way. bugs with patches win. do *NOT* resolve bugs with patches as duplicates of bugs without patches. this is *not* the way to get drive by patchers to have their work integrated.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

11 years ago
Duplicate of this bug: 303643
OS: Windows XP → All
Hardware: PC → All
Comment on attachment 250020 [details] [diff] [review]
wastefully learn about already cc'd to avoid listing them

This won't work. First note that this template is used for more than CC list. Secondly this template has not been given a bug object. Also, I don't think there's a need to create temp variable skip_cc but instead operate directly on bug.cc output. Additionally you should make sure IF still passes when user in value (the selected option) is already in CC list.
Attachment #250020 - Flags: review? → review-

Updated

4 years ago
Assignee: timeless → create-and-change
You need to log in before you can comment on or make changes to this bug.