Closed Bug 365231 Opened 14 years ago Closed 12 years ago

Find as you type hijacking forms, inputs, address bar, etc.

Categories

(Toolkit :: Find Toolbar, defect)

1.8 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 331831

People

(Reporter: bramus, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Firefox 2.0.0.1 ID:2006120418

Don't know if this bug is related to / a dubplicate of bugs #78928, #268359 and #155436, but here goes.

Every now and then I notice that I cannot type anything in the addres bar, nor in form inputs (both textareas and input elements) and this since the upgrade to Firefox 2.0 (and more recently Firefox 2.0.0.1).

Whenever the bug occurs (at random, can't really tell how to reproduce) I can set the cursor to focus a certain element, yet cannot use a shortcut to for example paste some text. When I start typing something, I noticed that "find as you type" pops up (which is enabled in the options) ...  

To regain the ability to change input fields, I must open and close the options dialog. From then on the fields behave as they normally would.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
Don't know ... one session a site is fine, the next session it's not.



I first though that it was the firebug extension that screwed up, yet when having it disabled the problem remains.

Above that the issue is there on both my pc at home and at work (both win xp sp2 nl and latest firefox build).

Also placing this under critical since the browser actually becomes useless when it happens (unless you know the trick to reset it all).
Argh, setting wrong dependency..
No longer blocks: 220900
I am seeing this as well on 2.0.0.1.  Hopefully it is fixed by the landing of Bug 220900.
Nope, 220900 didn't fix this.

Steps to Reproduce:

1) Close all instances of Firefox.
2) Launch Firefox and open a site that takes a while to load.  I use my personalized Google homepage, as it contains quite a bit of tabs and takes a couple seconds to load.
3) Before the page finishes loading, start typing, you will notice the Find As You Type Bar pop up.  That's all well and good, but now try typing within in a form field and you will see the problem.

In short, the best way to reproduce this is to start typing in a textbox before the page has finished loading.
I'm having this problem too and it's driving me insane. It's also caused the other members of my family to switch away from Firefox.  This is on Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I had thought it might be a profile issue, so I tried it with a new profile and the problem still exists.

This bug hijacks ALL keyboard input to find-as-you-type (including hitting space to page down).

The work around is to invoke the Downloads window with Cmd-J and then immediately close the window. Then click in the web page (if you're trying to use space to page down) or in the form input box to begin typing.

This is a HUGE deterrent from using firefox because most users have no idea what's going on or how to fix it. To them, firefox "just doesn't work" but IE will.
I just had this problem as well in 2.0.0.6. (But it disappeared just now, fortunately, maybe after I opened the about-box to check my version...) Generally filling out forms work, but no short cuts, and not typing slash (/) as that invokes type-as-you-find.
Now I got this again, and indeed, opening the about box (Help->About Mozilla Firefox) does remove the problem! Strange...
I also frequently experience this problem.

I find that if I minimise and unminimise Firefox I am able to type again.

Ty Williams, if this is a serious problem for your family, I suggest that you turn off 'Find As You Type' until the bug is fixed.
Component: General → Find Toolbar
Product: Firefox → Toolkit
QA Contact: general → fast.find
Version: unspecified → 1.8 Branch
Yes, those do look like the same.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 331831
You need to log in before you can comment on or make changes to this bug.