Update browser/toolkit copyright dates to 2007

VERIFIED FIXED

Status

()

Firefox
General
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: philor, Assigned: philor)

Tracking

({verified1.8.0.10, verified1.8.1.2})

Trunk
verified1.8.0.10, verified1.8.1.2
Points:
---
Bug Flags:
blocking1.8.1.2 +
blocking1.8.0.10 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

11 years ago
Created attachment 250077 [details] [diff] [review]
Trunk v.1

The "one bug for every product and locale and branch" system of updating to a new year doesn't seem to work out perfectly (note that last year's bug 322172 is still open, and the 1.8 branch got updated in May), so I'm hoping that splitting the job up a bit will make it easier. Trunk patch now, 1.8 branch and 1.8.0 branch as I whittle out the missing files and do less aggressive changes in the locales.
Attachment #250077 - Flags: review?(gavin.sharp)
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
Flags: blocking1.8.1.2?
Flags: blocking1.8.0.10?
Comment on attachment 250077 [details] [diff] [review]
Trunk v.1

r=me with glossary.xhtml fixed to reference platformStrings.dtd as discussed on IRC
Attachment #250077 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 2

11 years ago
Created attachment 250078 [details] [diff] [review]
Trunk v.2

Gavin's right, just because glossary.xhtml's hard to get to doesn't mean I should turn it into a yellow screen of death.
Attachment #250077 - Attachment is obsolete: true
Attachment #250078 - Flags: review?(gavin.sharp)
Comment on attachment 250078 [details] [diff] [review]
Trunk v.2

Yes, that! :)
Attachment #250078 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 4

11 years ago
browser/app/macbuild/Contents/Info.plist.in 1.14
browser/app/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in 1.2
browser/app/nsBrowserApp.cpp 1.34
browser/app/application.ini 1.4
browser/base/content/credits.xhtml 1.26
browser/locales/en-US/chrome/browser/aboutDialog.dtd 1.7
browser/locales/en-US/chrome/help/platformStrings.dtd 1.10
browser/locales/en-US/chrome/help/accessibility.xhtml 1.3
browser/locales/en-US/chrome/help/cookies.xhtml 1.15
browser/locales/en-US/chrome/help/customization.xhtml 1.25
browser/locales/en-US/chrome/help/download_manager.xhtml 1.24
browser/locales/en-US/chrome/help/firefox_welcome.xhtml 1.18
browser/locales/en-US/chrome/help/forieusers.xhtml 1.19
browser/locales/en-US/chrome/help/glossary.xhtml 1.6
browser/locales/en-US/chrome/help/menu_reference.xhtml 1.49
browser/locales/en-US/chrome/help/mouse_shortcuts.xhtml 1.14
browser/locales/en-US/chrome/help/popup.xhtml 1.16
browser/locales/en-US/chrome/help/prefs.xhtml 1.53
browser/locales/en-US/chrome/help/shortcuts.xhtml 1.48
browser/locales/en-US/chrome/help/tabbed_browsing.xhtml 1.20
browser/locales/en-US/chrome/help/using_firebird.xhtml 1.42
toolkit/locales/en-US/chrome/global/about.dtd 1.4
toolkit/content/license.html 1.7
toolkit/locales/en-US/chrome/mozapps/help/welcome.xhtml 1.6
toolkit/mozapps/update/src/updater/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in 1.2
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

11 years ago
Created attachment 250080 [details] [diff] [review]
1.8 branch v.1

Pretty much the same as the last, other than one file that doesn't exist and another that had a different name, and hard-coded years in help for less l10n thrashing, but the more review I get, the better off I am.
Attachment #250080 - Flags: review?(gavin.sharp)
Attachment #250080 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

11 years ago
Attachment #250080 - Flags: approval1.8.1.2?
(Assignee)

Comment 6

11 years ago
Created attachment 250117 [details] [diff] [review]
1.8.0 branch v.1

Last one, only different in that the unused Mac strings are in UTF-16 binary files instead of .strings.in, accessibility.xhtml, license.dtd and license.xhtml weren't involved, and about.xhtml had dates in, and in that it's getting hard to find someone who can build 1.8.0 to help test.
Attachment #250117 - Flags: review?(gavin.sharp)
Attachment #250117 - Flags: approval1.8.0.10?
Attachment #250117 - Flags: review?(gavin.sharp) → review+

Updated

11 years ago
Flags: blocking1.8.1.2?
Flags: blocking1.8.1.2+
Flags: blocking1.8.0.10?
Flags: blocking1.8.0.10+
Comment on attachment 250080 [details] [diff] [review]
1.8 branch v.1

approved for 1.8 branch, a=dveditz for drivers
Attachment #250080 - Flags: approval1.8.1.2? → approval1.8.1.2+
Comment on attachment 250117 [details] [diff] [review]
1.8.0 branch v.1

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #250117 - Flags: approval1.8.0.10? → approval1.8.0.10+
(Assignee)

Comment 9

11 years ago
browser/app/macbuild/Contents/Info.plist.in 1.11.4.3
browser/app/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in 1.1.2.2
browser/app/nsBrowserApp.cpp 1.31.2.4
browser/base/content/credits.xhtml 1.10.4.15
browser/locales/en-US/chrome/browser/aboutDialog.dtd 1.5.8.2
browser/locales/en-US/chrome/help/accessibility.xhtml 1.1.2.4
browser/locales/en-US/chrome/help/cookies.xhtml 1.12.4.3
browser/locales/en-US/chrome/help/customization.xhtml 1.19.2.6
browser/locales/en-US/chrome/help/download_manager.xhtml 1.17.4.7
browser/locales/en-US/chrome/help/firefox_welcome.xhtml 1.16.2.2
browser/locales/en-US/chrome/help/forieusers.xhtml 1.17.8.2
browser/locales/en-US/chrome/help/glossary.xhtml 1.2.4.4
browser/locales/en-US/chrome/help/menu_reference.xhtml 1.31.2.19
browser/locales/en-US/chrome/help/mouse_shortcuts.xhtml 1.9.8.5
browser/locales/en-US/chrome/help/popup.xhtml 1.13.4.3
browser/locales/en-US/chrome/help/prefs.xhtml 1.34.2.20
browser/locales/en-US/chrome/help/shortcuts.xhtml 1.34.4.14
browser/locales/en-US/chrome/help/tabbed_browsing.xhtml 1.13.4.7
browser/locales/en-US/chrome/help/using_firebird.xhtml 1.29.2.16
toolkit/locales/en-US/chrome/global/license.dtd 1.2.18.6
toolkit/content/license.html 1.1.2.6
toolkit/locales/en-US/chrome/mozapps/help/welcome.xhtml 1.4.2.2
toolkit/mozapps/update/src/updater/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in 1.1.2.2
Keywords: fixed1.8.1.2
(Assignee)

Comment 10

11 years ago
browser/app/macbuild/Contents/Info.plist.in 1.11.12.2
browser/app/macbuild/Contents/Resources/English.lproj/InfoPlist.strings 1.6.4.2.4.3
browser/app/nsBrowserApp.cpp 1.31.2.2.4.2
browser/base/content/credits.xhtml 1.10.4.2.2.2
browser/locales/en-US/chrome/browser/aboutDialog.dtd 1.5.16.2
browser/locales/en-US/chrome/help/cookies.xhtml 1.12.12.2
browser/locales/en-US/chrome/help/customization.xhtml 1.19.2.1.2.2
browser/locales/en-US/chrome/help/download_manager.xhtml 1.17.4.2.2.2
browser/locales/en-US/chrome/help/firefox_welcome.xhtml 1.16.10.2
browser/locales/en-US/chrome/help/forieusers.xhtml 1.17.16.2
browser/locales/en-US/chrome/help/glossary.xhtml 1.2.4.1.2.2
browser/locales/en-US/chrome/help/menu_reference.xhtml 1.31.2.4.4.3
browser/locales/en-US/chrome/help/mouse_shortcuts.xhtml 1.9.8.2.2.2
browser/locales/en-US/chrome/help/popup.xhtml 1.13.12.2
browser/locales/en-US/chrome/help/prefs.xhtml 1.34.2.6.2.3
browser/locales/en-US/chrome/help/shortcuts.xhtml 1.34.4.7.2.2
browser/locales/en-US/chrome/help/tabbed_browsing.xhtml 1.13.4.2.4.2
browser/locales/en-US/chrome/help/using_firebird.xhtml 1.29.2.2.4.2
toolkit/locales/en-US/chrome/mozapps/help/welcome.xhtml 1.4.10.1
toolkit/mozapps/update/src/updater/macbuild/Contents/Resources/English.lproj/InfoPlist.strings 1.1.12.1
toolkit/content/about.xhtml 1.8.16.2
Keywords: fixed1.8.0.10

Comment 11

11 years ago
What do we do with the localizations here?

Just leave as is as we did before on the MOZILLA_1_8_0_BRANCH?

Comment 12

11 years ago
v.fixed on Trunk and both branches for enUS.

Axel:  If we need to update the dates for l10n, let's get a bug filed to track the locales.  Not sure who makes that call, but we should find out from someone like cbeard or pkim.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.0.10, fixed1.8.1.2 → verified1.8.0.10, verified1.8.1.2

Updated

11 years ago
Duplicate of this bug: 369060
(In reply to comment #12)
> Axel:  If we need to update the dates for l10n, let's get a bug filed to track
> the locales.  Not sure who makes that call, but we should find out from someone
> like cbeard or pkim.

Did this check get made ? At least one person noticed that the localized builds are still 2006:
  http://forums.mozillazine.org/viewtopic.php?p=2751284#2751284
You need to log in before you can comment on or make changes to this bug.