mail with attachments not showing (IMAP)

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
12 years ago
11 years ago

People

(Reporter: hicks.kingtom, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 2 beta 1 (20061206)

email that have attachments don't display when they are clicked on. 

The email messages show up in the normal way when TB is first opened, but when double clicked to open the message the attachment icon disappears, and the message does not display at all (as if receiving a blank message). 

I have checked the message source, and this displays *properly*, with all headers + base 64 encoded parts. Also note that it doesn't matter if I try to view the message as simple HTML/plain text

Reproducible: Always

Steps to Reproduce:
1.Open TB
2.Double click on message with attachment

Actual Results:  
blank message window displays, attachment icon disappears, 
view source displays all message parts as plain text.

Expected Results:  
message displays in window + shows attachment

Using home IMAP server, http://www.intellegit.com/software/messenger/ server edition.  messages without attachments display ok.

Comment 1

12 years ago
this works for me - do you have the folder (INBOX?) configured for offline use?

an imap protocol log might help - http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

also, does anything show up on the error console when you do this?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> this works for me - do you have the folder (INBOX?) configured for offline use?
> 
Yes, although it appears that the messages affected haven't been downloaded before to tunderbird (have looked at them using another program) 
> an imap protocol log might help -
> http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

too big to attach, uploaded(minus email addresses ;-) to: www.hicks.f2s.com/TEST/log of IMAP_1.txt, but looks pretty normal to my quick glance.
> also, does anything show up on the error console when you do this?
no?
I have a feeling that TB is being asked to display a message, doesn't have it stored locally, so downloads the message but fails to update the message window.(or fails to realize that the message has finished downloading, so dose not display it) 

Comment 3

11 years ago
Thomas, still see this problem with newer version?
(Reporter)

Comment 4

11 years ago
Well, I no longer have access to the systems involved, so probably best to close this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.