All users were logged out of Bugzilla on October 13th, 2018

Problem with backward compatibility with existing plug-in binaries (sans LiveConnect) on mac

VERIFIED DUPLICATE of bug 35351

Status

()

P3
critical
VERIFIED DUPLICATE of bug 35351
19 years ago
14 years ago

People

(Reporter: shrir, Assigned: serhunt)

Tracking

({shockwave})

Trunk
PowerPC
Mac System 9.x
shockwave
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

(Reporter)

Description

19 years ago
Logging this as a seperate bug from bug 35914. 
Since shockwave player cannot be installed on mac (bug 35915) , I added the 
'Np-PPC-Dir-Shockwave' plugin file manually in mozilla's plugins folder. Then 
trying to visit the above url crsahed mozila (bug 36568).

From Erick Krock's email:
 "This is a bug with backward compatibility with existing plug-in binaries (sans 
LiveConnect)--a key goal of the Mozilla plug-in API. "
(Reporter)

Comment 1

19 years ago
platform : Mac
Hardware: PC → Macintosh
Keywords: shockwave
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18
Shockwave crasher-->nsbeta2. SW is on b2 criteria. But we need to make sure this 
isn't just a problem with how SW was installed/configured. Shrir--let's see if 
MM SW contacts can help here.
Keywords: nsbeta2
(Reporter)

Comment 3

19 years ago
I will try this again with a good build on mac and if it does not work, will 
contact shickwave. Thanks!

Comment 4

19 years ago
[nsbeta2+]
Whiteboard: [nsbeta2+]
(Reporter)

Comment 5

19 years ago
Marking this as dup of 35351, per mail from tstampfli@macromedia.com

" Bug #36569 is actually the same as bug #35351. See the note in the 
bug description for #35351 from Dan Sadowski - when Shockwave calls 
one of the function pointers passed in from the browser, Mozilla 
crashes.
-Tracy "


*** This bug has been marked as a duplicate of 35351 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

19 years ago
verif dup
Status: RESOLVED → VERIFIED
OS: All

Comment 7

14 years ago
fixing null OS field
OS: All → Mac System 9.x
You need to log in before you can comment on or make changes to this bug.