file download, save file button greyed out in file dialog

RESOLVED DUPLICATE of bug 353407

Status

()

--
major
RESOLVED DUPLICATE of bug 353407
12 years ago
10 years ago

People

(Reporter: eric.gold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

after clicking on a file download link if the anchor element has target=_blank and the mime/file type is set to application/octet-stream results in the save file button being greyed out.

Reproducible: Always

Steps to Reproduce:
1.web server sets the content type of file to application/octet-stream
2.anchor element has set target=_blank or _new
3.click on link
Actual Results:  
file window is rendered with a greyed out save file button and a cancel button

Expected Results:  
save file button should not be greyed out
Duplicate of Bug 284579, Bug 264492 or Bug 355968?
Please dupe this bug to the appropriate one.

Comment 2

12 years ago
(In reply to comment #1)
> Duplicate of Bug 284579, Bug 264492 or Bug 355968?
> Please dupe this bug to the appropriate one.
> 

I am getting the same thing, and it is not a duplicate of any of the ones you mentioned.

In my case, it happens when I use javascript:window.open on an .exe link, and Firefox (2.0.0.1) is set to open new windows in new _TABS_.  The Save File button is grayed out and you have to click it once to activate it.  THEN you have to click it again to initiate the actual save.

If you change your settings back so new pages should open in new windows (Tools > Options > Tabs), then do a window.open for an .exe--

A [blank] new window opens, the Save dialog box comes up, the blank window closes, and THEN the Save File button becomes active.

(When it opens in a new tab, the Save File button won't become active until you click it once.)

Comment 3

12 years ago
I can confirm comment #2: The browser.link.open_newwindow setting affects this behavior. If set to 2 (Open in new window), the Ok button is enabled, if set to 3 (Open in new tab, the default), the Ok button is disabled. Defocussing the dialog and focusing it again enables the Ok button.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> I can confirm comment #2: The browser.link.open_newwindow setting affects this
> behavior. If set to 2 (Open in new window), the Ok button is enabled, if set to
> 3 (Open in new tab, the default), the Ok button is disabled. Defocussing the
> dialog and focusing it again enables the Ok button.
> 

You have confirmed the behavior which is great, but do you agree that this is a bug?

Comment 5

12 years ago
Well, who am I to decide that ;-)
But yes, IMHO this behavior is wrong. One could argue that this is some kind of security feature to prevent you from inconsiderately clicking Ok. The problem is just that discoverability is really bad. In other words - a "normal user" has no chance of finding out what to do here (just explained this to a colleague and this is a software company!).
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> Well, who am I to decide that ;-)
> But yes, IMHO this behavior is wrong. One could argue that this is some kind of
> security feature to prevent you from inconsiderately clicking Ok. The problem
> is just that discoverability is really bad. In other words - a "normal user"
> has no chance of finding out what to do here (just explained this to a
> colleague and this is a software company!).
> 

As a newbie to this forum, what is the next step here, when and who will fix this?

Comment 7

12 years ago
Check out http://www.mozilla.org/bugs/, especially the last section "Life Cycle Of A Bug". In short, the next step is for someone with the appropriate bugzilla user rights to confirm that this is actually a new bug and not a duplicate of some other case as suggested above.
Afterwards - but still more or less independent from that - someone needs to find the implementation problem, find a way to solve it, and create a patch. When and who is - for Firefox being open source - completely open. If you feel able, go ahead. Although having a patch does not guarantee that this is solved, it certainly doesn't hurt ...

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353407
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.