Closed Bug 365847 Opened 13 years ago Closed 13 years ago

{inc}incremental reflow problems with nowrap non-ASCII text (Bugzilla attachment page links move when you click them)

Categories

(Core :: Layout: Block and Inline, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dbaron, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Attachments

(1 file)

I'm seeing incremental reflow problems recomputing intrinsic widths for nowrap text with non-ASCII characters in it.  This appears to be a regression from the reflow branch landing, but I'm hoping roc's text frame work might fix it.

Original steps to reproduce:
 1. load https://bugzilla.mozilla.org/showdependencytree.cgi?id=300030&maxdepth=1&hide_resolved=1 at a window width narrow enough that the bug summary at the very top of the page wraps
 2. click on the link "Bug 300030" at the very top of the page

Actual results: table moves around, wrapping on the left side before "Bug 300030"

Expected results: table should not move, and the text on the left, "Bugzilla@Mozilla – Dependency tree for Bug 300030" should never wrap.

I'll attach a simplified testcase as well.
Attached file simplified testcase
The testcase contains expected results; in current builds the word "Bug" wraps to a new line after the dash.

A reftest reference rendering for this would involve replacing the script and onload with a style attribute that does the same thing.
Summary: {inc}incremental reflow problems with nowrap non-ASCII text → {inc}incremental reflow problems with nowrap non-ASCII text (Bugzilla attachment page links move when you click them)
Duplicate of this bug: 374861
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Keywords: testcase
It looks like new-textframe fixes this.
Depends on: 333659
Flags: in-testsuite?
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070621 Minefield/3.0a6pre

FIXED by the new textframe landing.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.