Closed Bug 366407 Opened 15 years ago Closed 12 years ago

Group by date: Wrong headline after deleting an attachment

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: peterswegberg, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.2pre) Gecko/20070107 Thunderbird/2.0b1 ID:2007010703

I use the button "G" to sort my messages by day. The headline of a group is changing after deleting an attachment. 


Reproducible: Always

Steps to Reproduce:
1.Group emails by date.
2.Delete an attachment of an email in the first group "heute" (german localization)

Actual Results:  
The first group is labeled as "Ältere Nachrichten" 

Expected Results:  
No change of the label is expected.
Version: unspecified → 2.0
(In reply to comment #0)
> Steps to Reproduce:
> 1.Group emails by date.
> 2.Delete an attachment of an email in the first group "heute" (german
> localization)
> Actual Results:  
> The first group is labeled as "Ältere Nachrichten" 

I am also working on a German localization (Version 1.5.0.10 (20070221)), and I CANNOT reproduce this bug. But I am 99% sure that this is another case of bug 315144: Pressing delete on an attachment within the mail window deletes message instead of attachment. With message grouping active (press G), if you place focus on any attachment of last message below group header "today", then press <del> expecting to delete the attachment, TB 1.5 will falsely delete the message instead. If it's the last single msg under "today", the header "today" will disappear and "older messages" or whatever will become the last header, thus giving the impression that the header "changed". In fact, it's a case of data loss... Just another reason to fix bug 315144 asap (it's in the pipe) and include the fix in TB2!

Requesting marking as duplicate of bug 315144.
I don't believe this is a duplicate of bug 315144.  I have observed this bug frequently on two different installations of Thunderbird, from version 1.5 onwards (at least).  I believe it has something to do with sorting by date, in particular, and grouping on that.  There seem to be several scenarios where the subject of the messsage within a group gets used as the group header, rather than "Today".  I haven't seen it for the other group headers, but I suspect that's because most of the traffic occurs in "today" group.  I think it has to do with deleting or moving an e-mail.  I have several rules configured to move mail out of the inbox, so I think what happens is the date flips to the next day, then an e-mail comes in, that gets deleted or moved, then another comes in that doesn't get deleted, and somehow the group header gets confused.  Or maybe the e-mail order is the other way around - first mail stays in the mailbox, then the second mail gets deleted/moved, and that's when the header gets munged.
I think there's a relationship to bug315144, but only in the sense that it's related to an email getting deleted/moved, and not to the specific attachment delete bug.
Assignee: mscott → nobody
I suggest this bug be resolved "worksforme" (or perhaps "incomplete"?).

This bug was originally reported against TB2 Beta 1.
The screenshot of attachment 350445 [details] dates back to Nov. 2008, whereas current version is 2.0.0.21 (20090302).

Again: worksforme, i. e. I cannot reproduce the bug with the German localization of the current version 2.0.0.21 (20090302), nor with the current US-EN nightly of TB3, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090608 Shredder/3.0b3pre.

The steps of comment #0 are perhaps not precise enough: whereas the steps say we need to DELETE the attachment, the screenshot of attachment 350445 [details] says DETACH, which are two similar, yet differenct scenarios (-> incomplete). I tried both yet the bug didn't occur.

Comment #2 is reported against TB "version 1.5 onwards", and I reckon it's too vague in terms of confirming this bug as it doesn't really refer to the precise scenario/steps of comment #0. Blame it on the misleading tracks of my comment comment #2, which doesn't reflect the original scenario close enough, either.

Michael Peters, do you still see the bug after upgrading to the latest version of TB, currently 2.0.0.21 (20090302)? Use Help > About Thunderbird to check for the version no., and Help > Check for Updates to upgrade if necessary.
If you still see the bug, please reopen this bug.

In the meantime, I suggest this bug be resolved "worksforme".
It makes no difference to detach or to delete an attachment. Perhaps it´s a profile-problem or something else. I tried the Tb3 Beta 2 and the problem has gone.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.