Closed Bug 366427 Opened 13 years ago Closed 11 years ago

use enchant instead of hunspell for spellchecking

Categories

(Core :: Spelling checker, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 422399

People

(Reporter: serkan, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; tr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 

Enchant can use many backends (including myspell) which makes it more flexible.
Using it in firefox would be better than myspell.


Reproducible: Always
I believe that the plan is to change to hunspell as per bug 319778
Assignee: nobody → mscott
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker
Version: unspecified → Trunk
mscott, WONTFIX?
Enchant isn't a spell checker, it's a wrapper for backends like MySpell, Hunspell and others. What's the benefit?
http://www.abisource.com/projects/enchant/
The benefit is to use the best spell checker available for a given language.

For example for English that would be Aspell, for Finnish that would be Voikko.
Bug 364035 made it possible to use other spellcheck engines like Voikko.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: use enchant instead of myspell for spellchecking → use enchant instead of hunspell for spellchecking
Assignee: mscott → nobody
Given bug 364035 and bug 391039, I'm marking this WONTFIX. If someone wants to use enchant, there shouldn't be anything stopping them at this point.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
there's still no developer document for doing that. (Correct me if I'm wrong)
Bug 364035 has the dev-doc-needed keyword set on it. Feel free to step up to the plate :)
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 422399
You need to log in before you can comment on or make changes to this bug.