Closed Bug 367113 Opened 13 years ago Closed 13 years ago

wrong message if profile folder is deleted

Categories

(Toolkit :: Startup and Profile System, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 278860

People

(Reporter: koekoekpeter, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

If I start firefox -p and I try start an account which (root) folder is completely deleted, firefox says "firefox is already running" and that it can't start.

Reproducible: Always

Steps to Reproduce:
1. create extra account called temp in folder c:\temp using firefox -p
2. start up using this account
3. exit firefox and delete c:\temp
4. try to start the account 'temp' using firefox -p
Actual Results:  
if you try to start the account temp using firefox -p firefox reports that firefox is already running

Expected Results:  
Either report that the profile is missing or create a new folder automatically.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278860
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.