If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attached JPEG (appledouble) displays inline OK but does not save to disk or open properly.

RESOLVED DUPLICATE of bug 361401

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 361401
11 years ago
10 years ago

People

(Reporter: Steven Hunter, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 1.5.0.9 (20061207)

An email was sent, using Apple's Mail.app, with a JPEG file attached. Thunderbird correctly displays the JPEG inline in the Message Window. However if you double-click on the JPEG in the attachments area of the message window, to save or open it, the resulting file is reported as being corrupt by image editing programs (eg: Preview, GraphicConverter 5.9, and Photoshop CS2).

Reproducible: Didn't try

Steps to Reproduce:
Have not tried to reproduce it, but if requested I can probably do so.



Things of note:
1. The JPEG is encoded by Mail.app with a Content-type of "application/applefile", which seems odd to me.
2. Using IMAP, the same email viewed with Win32 Thunderbird [1.5.0.4 (20060516)] decodes properly. The icon for it in the attachments area shows it as an MS Word document (likely due to #1). Despite this, it does open with the default JPEG/JPG program (likely because Windows puts much more faith in file extensions than OSX does).
3. It is possible to drag-and-drop the JPEG from the message window to the desktop which results in a viable file.
4. We have seen this on an Intel iMac and a MacBook Pro. Both are running under 10.4.8.

More information available upon request.

Comment 1

11 years ago
A sample message would be useful -- save it as a .EML file and attach it to this bug, or forward it to me as an attachment (not inline) if the content is too sensitive to post.
Summary: Attatched JPEG displays inline OK but does not save to disk or open properly. → Attached JPEG (appledouble) displays inline OK but does not save to disk or open properly.
(Reporter)

Comment 2

11 years ago
Sent an example via email.

Comment 3

11 years ago
The "reported as corrupt" issue with appledouble attachments has been reported for programs running on Intel Macs -- bug 353529 / bug 361401.  No solution as yet.


> 1. The JPEG is encoded by Mail.app with a Content-type of
> "application/applefile", which seems odd to me.

It's actually:
  multipart/appledouble
    part1: application/applefile     <-- Mac resource fork
    part2: image/jpeg                <-- actual image
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 361401
You need to log in before you can comment on or make changes to this bug.