Need Edit HTML Source window

VERIFIED DUPLICATE of bug 14526

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 14526
18 years ago
17 years ago

People

(Reporter: Akkana Peck, Assigned: Charles Manske)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Our current Insert HTML Source dialog (in the insert menu) is cool in that if
something is selected, the source of that part of the dialog will be loaded into
the dialog when it's brought up.

Several of us agreed at the last editor team meeting that this wasn't very
discoverable, and in any case it's ugly (it's fine as a little dialog, but lousy
for editing entire documents).

We need several changes to give us usable source editing:

1. Make it look more like an editor window.  Ideally, it should look a lot like
the plaintext editor (TextEditorAppShell.xul) -- maybe even use that same xul
file, if possible -- including using normal-size CSS fonts, not the microscopic
fonts that UE insists on using for dialogs.

2. It should probably be somewhere else, like under the Edit menu -- probably
leave the existing little InsertSource dialog where it is, and then let the
marketing/UE people fight about where each one should go.

3. If the selection is collapsed when the dialog is brought up, then instead of
coming up blank (like the insert source dialog), it should get the contents of
the whole document (i.e. it shouldn't include the "selection only" flag when
calling the output routines).
(Assignee)

Comment 1

18 years ago
I already have a bug (14526) to implement a Page Source editor. The plan is to
integrate it into the existing UI as another "tabbed" view. It would copy all
of the document and paste the html-formated output into an iframe. Editing
that would be in a "text editor" mode. Switching back to another "Edit Mode"
would copy the source HTML and paste it back into the normal editor.
Does that fulfill what you describe here? If yes, lets dup this and copy your
comments from here, which help define the task.

(Reporter)

Comment 2

18 years ago
That sounds fine.  Marking as dup, will copy the comments and cc over to the
other bug.

*** This bug has been marked as a duplicate of 14526 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
verified in 4/24 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.