Please build NIGHTLY versions with debugging symbols.

RESOLVED WONTFIX

Status

Firefox Build System
General
--
enhancement
RESOLVED WONTFIX
12 years ago
3 months ago

People

(Reporter: David A. Cobb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2pre) Gecko/20070118 Minefield/3.0a2pre
Build Identifier: 

The nightly builds of Thunderbird and Firefox (and whatever) are used for finding bugs.  This would be much easier if they were built with debugging symbols embedded.

Yes, I can probably build my own -- but then I'm reporting bugs against a configuration different from the one others will be looking at.  If the released build has symbols, we are all looking at the same configuration.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

12 years ago
Nightlies (and releases) on Mac have symbols for function names.  I thought that was true on Linux as well.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Nightlies (and releases) on Mac have symbols for function names.  I thought
> that was true on Linux as well.
> 

I could be wrong; however, when I try to run the program under DDD/GDB it complains "No debugging symbols."  Likewise, when the program cores and I let run-mozilla.sh run DDD on the core-file.  I can't really acquire any useful information.

Comment 3

12 years ago
We do not have diskspace/bandwidth to ship builds with full symbols by default. We are working on improvements to airbag that will allow users to dynamically download necessary symbols. This is easy on Windows because we can reuse the MS symbol server protocol.

But this bug as filed wont be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 24091
Duplicate of this bug: 400083

Updated

10 years ago
Duplicate of this bug: 329695

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.