Closed Bug 368192 Opened 13 years ago Closed 10 years ago

Popup blocker should allow one-time allowance, not just always and never

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 282515

People

(Reporter: mweber, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

When Firefox blocks a site from opening a popup, the options button should have an additional option to allow the popup to open a window one time.

Reproducible: Always

Steps to Reproduce:
1. Goto site that opens popups
2. See popup blocked message at top
3.
It does offer this, at least sometimes. Click the "Options" button and you'll see "Show <url>" items at the bottom of the list. For some reason it doesn't always appear, though (I can see them when visiting http://www.popuptest.com/popuptest1.html, but not when visiting http://cnn.com).
Not a dupe of 331739.  That bug addresses several things, but not a "allow just this once" functionality.

What I am after is two fold:  1) I want to see what the popup may be, and 2) I may want to allow one popup for a particular page, but not enable them for the entire site.  For example, I may want to allow one story to give me a popup vote window on CNN, but I do not want to enable popups for the entire cnn.com domain.
As I said in my earlier comment, we already do what you want, we just don't seem to do it consistently. There's likely an existing bug filed on that inconsistency.
Firefox 3.0.x does seems to occasionally allow the user to open the pop-up but this behavior seems inconsistent and there is no option to allow one-time.
OS: Windows 2000 → All
Hardware: x86 → All
Whiteboard: DUPEME
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 282515
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.