"ASSERTION: identical" and "ASSERTION: sorting error" with quotes and XUL

RESOLVED FIXED

Status

()

Core
XBL
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: sicking)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
PowerPC
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

598 bytes, application/xhtml+xml
Details
(Reporter)

Description

11 years ago
Created attachment 252880 [details]
testcase

Loading the testcase triggers:

###!!! ASSERTION: identical: 'pseudoType1 != pseudoType2', file /Users/admin/trunk/mozilla/layout/base/nsGenConList.cpp, line 133

###!!! ASSERTION: sorting error: 'IsLast(aNode) || NodeAfter(Next(aNode), aNode)', file /Users/admin/trunk/mozilla/layout/base/nsGenConList.cpp, line 198
(Reporter)

Updated

11 years ago
Duplicate of this bug: 368277
So this is basically an XBL bug; I wonder whether we have it filed...

The issue is that we get into nsBindingManager::ContentRemoved and notify the frame constructor _before_ we modify the insertion point information, since we need to find the frames in the right place.

But in this case, the <q> is an {ib} split, so we reframe the containing block, and in the process of doing that we end up recreating the <q> frames (even though it's not a child of the <dialog> anymore!) because the <q> is still in the insertion point array...

Then we unwind and remove the <q> from the insertion point, but the bogus frames are still there.

This looks pretty bad to me.
Flags: blocking1.9?
Assignee: dbaron → general
Component: Style System (CSS) → XBL
Blocks: 368641
Not blocking since so far this is only an assertion. However it's mine for sure so I'll try to get to it before 1.9
Assignee: general → jonas
Flags: blocking1.9? → blocking1.9-
(Reporter)

Comment 4

11 years ago
WFM, Mac trunk.

bz, is the underlying problem you mentioned in comment 2 still around?  If so, can you please file a new bug?
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
This got fixed by fixing that underlying problem in bug 382376.
Depends on: 382376
Resolution: WORKSFORME → FIXED
(Reporter)

Comment 6

11 years ago
The same assertions can be triggered with a different testcase; see bug 367251.
Flags: in-testsuite?
(Reporter)

Comment 7

10 years ago
Crashtest checked in.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.